View Single Post
Old 08-07-2011, 04:52 PM   #58
garyhgaryh began at the beginning.
Posts: 137
Karma: 13
Join Date: Jul 2011
Location: California
Device: Entourage Pocket Edge
Originally Posted by attemptress View Post
Yay! I finally got it to work!

Thanks, kennyminot for figuring out the method, and for responding to my questions. I suggest some slight changes to the overall method that might make future attempts easier.

Steps 1 and 2 work fine.

Here's where I suggest changing things slightly.

Step 2.1 Make a copy of the files you are planning to change. Put them on a usb drive, or your computer. Stick a .txt at the end, so you don't confuse your devices. This'll make it easier to change things back if the process goes "pear-shaped."

Step 3: Map your sdcard onto the /sdcard directory.dev_mount sdcard /mnt/sdcard auto /block/mmcblk0. . .

Download the 3 files kennyminot was kind enough to post. Replace the existing /system/etc files AND add the file (remove the .txt from the files).

Step 3.1: Make sure your partitiioned card is in the slot, and reboot.

Step 4: Setup Link2SD. Click on the program. It should automatically detect your second partition. . .

No changes needed---after reboot . . .

Step 5: Modify the Link2SD script to manually mount your sdcard's first partition. . .

. . .again. Link2SD messes with the file when it runs the setup (or, at least it did when I tried it), all you need to do is replace it again with the file kennyminot provided.

5.1 Reboot your eDGe (last time). Your system should now have mapped the first partition of your sdcard to the /sdcard directory.

6. Sort out where all your files went. Your Edge may not be able to find some of your application saved files and likely your library files. You'll need to move them over to the right folder in the sd card. If you're not sure where the Edge THINKS the files are, try saving a new one in whatever app is the problem, then find the old files (now on /extsd) and put them in the new folder. I found when using RootExplorer, that if I tried to replace the sd card library file with the folder that actually contained my library files, it made a sub-folder instead, so you may need to "multi-select," select all the files, copy and paste.

Hopefully, this'll save someone else some frustration.
What do you mean by this:

Step 3: Map your sdcard onto the /sdcard directory.dev_mount sdcard /mnt/sdcard auto /block/mmcblk0. . .

Please clarify. My PE just does not recoginize my microsd card. I think I have everything right, but obviously something is wrong.

I'm tempted to reformat it with sdformatter, but I don't think that's my issue.
It's as if my sd card does not exist.

garyhgaryh is offline   Reply With Quote