View Single Post
Old 07-10-2011, 07:34 PM   #1
Mr. mister
Junior Member
Mr. mister began at the beginning.
Posts: 5
Karma: 10
Join Date: Jul 2011
Device: Kindle 3
Suddenly stopped working

I didn't install any updates or anything but when I got on today Calibre didn't work. I run Linuxmint 11

when I try to start from terminal I get this.
Traceback (most recent call last):
  File "/usr/bin/calibre", line 19, in <module>
  File "/usr/lib/calibre/calibre/gui2/", line 362, in main
    app, opts, args, actions = init_qt(args)
  File "/usr/lib/calibre/calibre/gui2/", line 43, in init_qt
    from calibre.gui2.ui import Main
  File "/usr/lib/calibre/calibre/gui2/", line 30, in <module>
    from calibre.gui2.widgets import ProgressIndicator
  File "/usr/lib/calibre/calibre/gui2/", line 26, in <module>
    history = XMLConfig('history')
  File "/usr/lib/calibre/calibre/utils/", line 579, in __init__
  File "/usr/lib/calibre/calibre/utils/", line 590, in refresh
    with ExclusiveFile(self.file_path) as f:
  File "/usr/lib/calibre/calibre/utils/", line 113, in __enter__
    self.file  =  WindowsExclFile(self.path, self.timeout) if iswindows else open(self.path, 'a+b')
IOError: [Errno 5] Input/output error: '/home/jesse/.config/calibre/history.plist'
Also when I run as root it works... but I'd rather not have to make my library in root and take the trouble to run it like that every time I want to use the program.

Mr. mister is offline   Reply With Quote