View Single Post
Old 05-05-2011, 04:07 AM   #126
kindle-hopes began at the beginning.
Posts: 12
Karma: 10
Join Date: Apr 2011
Device: Kindle DXG
Another update: it partly works now! Silly mistake on my side: to recompile the updater-bin (including qinbill's changes to make-package.ffs), I have to use bash and not any other shell, of course...

Anyway, using qinbills method (move the tts-data on /mnt/us and comment the tts stuff out in make-mackage.ffs) it works now. Or should I say: the generate updater-bin installs flawlessly on the DXG, and the DXG has decent PDF!!

What does annoyingly NOT work, however (as reported by qinbill, too) is access to the USB drive from my computer. If I plug the kindle in, Linux detects an external storage, but no partitions on it. I can - as a workaround - access the userstore from recovery mode (hold down Enter during reboot and then press E), so I can put files on the kindle etc. What I can't do that way is put update pacakges, however, since the kindle would then try to install them during boot, which fails.

I had a look at the dumped messages (`dumpMessages), which show no obvious error - the partitions are clearly intact (otherwise I could not read my files), but they are for whatever reason not exported. lipc-props says:

I lipc-propsrop:: r Int mmcIsAvailable [0]
I lipc-propsrop:: r Int userstoreFreeSpace [3504416]
I lipc-propsrop:: r Int driveModeState [0]
I lipc-propsrop:: r Int mmcFreeSpace [-1]
I lipc-propsrop:: rw Int useUsbForSerial [0]
I lipc-propsrop:: w Int userstoreReadyToUnMount
I lipc-propsrop:: rw Str logMask [0xffff0000]
I lipc-propsrop:: r Int mmcTotalSpace [-1]
I lipc-propsrop:: rw Int useUsbForNetwork [0]
I lipc-propsrop:: r Int userstoreTotalSpace [3506528]
which seems somewhat contradictory: mmctotalspace, mmcisavailable etc seem wrong, while userstoretotalspace seems alright?

Anyway, my next step is to compile another update package, this time with usbnetwork installed on the K3W (and usbnet folder transferred to the dxg) to check if I could then get root access on the updated DXG to further explore what happened to the USB partition...

In the meantime, any thoughts about the problem are appreciated...
kindle-hopes is offline   Reply With Quote