View Single Post
Old 04-01-2011, 03:48 PM   #1
Junior Member
dcmarquardt began at the beginning.
Posts: 7
Karma: 10
Join Date: Apr 2011
Device: Kindle
Calibre-Server - Ubuntu 10.10 - Running but not serving

Hey, hoping that someone can help me out with this. I've tried quite a few times to get this working and nothing seems to work.

I installed calibre using the normal command-line installer, nothing fancy. Everything is installed correctly to /opt/calibre/...

A few things to keep in mind:
This is a Ubuntu 10.10 server.
I do not have any kind of X running on here, I'm trying to create strictly a calibre-server daemon. I've used a few of the scripts posted around to get it running as a daemon, and I can get it started up just fine, but no matter how I start it, I cannot reach it via a web browser.

I've disabled all firewalls on the machine.
I've set the port to port 8787, because I do have a tomcat server running using port 8080. (Just for fun I shut tomcat down, and tried it with the default port also, and no luck).
I am using a library created on my Windows machine that is on my NAS drive. The path to the library is an NFS share (hope that doesn't matter), and I am able to cd /.../.. to the directory with the books and .db file just fine.

When I start up the server (either using the script, or simply by running the command manually) I always get a message about a segfault, but it appears to start anyway. In the /var/log/messages file I see this:

Apr 1 14:24:01 sv03 kernel: [ 5064.271392] calibre-server[6850]: segfault at 4 ip 0017ba7d sp bfafd670 error 4 in[110000+134000]
Apr 1 14:24:01 sv03 kernel: [ 5064.293318] calibre-server[6855]: segfault at 4 ip 0017ba7d sp bfafd670 error 4 in[110000+134000]

Any help would be appreciated, I'm using the latest version of calibre (0.7.53).

Also, anytime I start up the server and do a sudo netstat -plntu, I see my normal running web server, and I see the tomcat server (and some other stuff) but never this server on any of the ports I've tried to start it on.
dcmarquardt is offline   Reply With Quote