View Single Post
Old 03-29-2011, 08:52 AM   #1
Junior Member
wildabandon began at the beginning.
Posts: 3
Karma: 10
Join Date: Mar 2011
Device: iriver story
Help: blank screen and horizontal lines

I bought my iRiver Story last year, in April if I recall correctly, and up until now it's worked fine with one or two quirks. Recently it has started giving me a blank screen when I try to turn the page or go to the menu or library. It is clearly still on, and when I hit the page turn button again, the screen flickers like it's turning the page, but nothing shows up. Sometimes it does this right away when it's fully charged and just turned on, sometimes it works fine for 15 minutes and then does it. Once the screen goes blank, the only thing that helps is shutting it off and turning it back on, and even then it sometimes still has issues.

Another, probably related, problem I've been having is horizontal lines. It's like when you're trying to print and you're low on ink- the text is wiped out in randomly placed and sized horizontal lines of blank screen. It happens both in the sun AND in the shade. I've been shutting it off and restarting it when this happens, but it's happening rather frequently now.

I am currently trying to install firmware 1.71, but my first download of it from the official website wouldn't open. We'll see if it helps, but I have a feeling it won't since it doesn't sound like this is a common issue that would get addressed via firmware. Am I going to have to send it back to Amazon UK? I'm unsure what else to do at this point.

EDIT: Well, now it's not fully booting up anymore, so the firmware is moot. It's definitely turning on, but there's nothing visible on the screen. It's like the e-ink has stopped working and the only way I know it's on at all is because the screen flickers when I shut it off again. I really have no idea what's going on with this thing. It's been treated like gold, so I know it's not something I've done to it.

EDIT the second!: I pressed on the screen lightly and it bounced back to life. I have no idea what's happening or how any of it makes sense. We'll see what happens. It's entirely possible that the fix is to press on the screen lightly from time to time. Still no new firmware since everything I've tried is invalid.

Last edited by wildabandon; 03-29-2011 at 03:08 PM.
wildabandon is offline   Reply With Quote