View Single Post
Old 03-10-2011, 08:16 AM   #1
Junior Member
phantom21 began at the beginning.
Posts: 5
Karma: 10
Join Date: Jan 2011
Device: Coby Kyros
Calibre won't read metadata.db

I've been getting an error message when I try to change preferences or load a book into the program.

Using it on Linux, Ubuntu 9.10, with the latest version (I think) of Calibre.

I've tried changing the permissions (initially they were root) and that hasn't worked.

The errors are:
A Tree Rustling over a Gravesite by Dennis Kiingati.pdf
Traceback (most recent call last):
File "/usr/lib/calibre/calibre/gui2/", line 83, in run
title = self.add(id, opf, cover, name)
File "/usr/lib/calibre/calibre/gui2/", line 128, in add
id = self.db.create_book_entry(mi, cover=cover, add_duplicates=False)
File "/usr/lib/calibre/calibre/library/", line 1371, in create_book_entry
(title, series_index, aus))
File "/usr/lib/calibre/calibre/library/", line 170, in run
raise DatabaseException(*res)
DatabaseException: attempt to write a readonly database
RemoteTraceback (most recent call last):
File "/usr/lib/calibre/calibre/library/", line 141, in run
ok, res = True, func(*args, **kwargs)
OperationalError: attempt to write a readonly database

Can someone advise how to fix the problems?


phantom21 is offline   Reply With Quote