View Single Post
Old 03-04-2011, 01:20 PM   #9
Huisie doesn't litterHuisie doesn't litter
Posts: 27
Karma: 100
Join Date: May 2010
Device: none
Hi, folks

I did reply this morning (my time), but my reply ain't here. Dunno what happened to it...

Thanks for the help and suggestions. I had another crack at it and solved my issue.
I'm not sure as to the root cause, though.

To recap:
  • I had 0.7.42 installed
  • I had set ebook-viewer.exe as my default external viewer for several formats
  • I uninstalled 0.7.42 and then installed 07.47, rather than updating
  • I ran into the problem of not being able to select ebook-viewer as external default anymore
  • I tried several methods to rectify this, including uninstalling and reinstalling, as mentioned

  • I uninstalled Calibre and rebooted
  • I deleted all Calibre folders from Program Files and User Profile
  • I ran a registry cleaner (Wise Registry Cleaner)
  • Amongst the entries listed as "safe to remove" were several referring to "ebook-viewer.exe"
  • I removed these and rebooted, then installed Calibre once more
  • Success! I could set "ebook-viewer.exe" as the default external viewer again

Not being a PC professional or MSVP, I can only hazard a guess.
  • It appears that setting "ebook-viewer.exe" as the default viewer creates a "sticky" reference in the registry.
  • Prior to deleting the "safe to remove" registry entries listed in the registry cleaner, I went and checked books that were in the formats I had set "ebook-viewer.exe" as default viewer for.
  • Though "ebook-viewer.exe" had been uninstalled and I had rebooted, the icons hadn't reverted to default - they were still showing the icon from when "ebook-viewer.exe" was installed.
Huisie is offline   Reply With Quote