View Single Post
Old 03-02-2011, 09:26 AM   #4
Huisie doesn't litterHuisie doesn't litter
Posts: 27
Karma: 100
Join Date: May 2010
Device: none
Thank you for the welcome - it's good to be here.

Thanks also for the replies, but I have already done as itimpi suggested.

I chose the "Open With..." dialog from the context menu, which opens the "Open With" window.
I then clicked the browse button, which opens an "Open With..." explorer window.
I browsed to "ebook-viewer.exe" in the "Calibre2" folder in "C:\Program Files(x86)".
I selected "ebook-viewer.exe", which closes the explorer window and takes me back to the "Open With" window.
"E-book viewer.exe" did not appear in the "Open With" window.

I have tried modifying the registry entry, to no avail:
HKEY_CURRENT_USER\Software\Microsoft\Windows\Curre ntVersion\Explorer\FileExts\.epub\OpenWithList

As an experiment, I tried selecting some of the other ".exe's" in the "C:\Program Files (x86)\Calibre2" folder, which did appear in the "Open With" window.

I right-clicked in "ebook-viewer.exe" and selected "Run as Administrator" - no joy.
I tried running it in various compatibility modes - again, no joy.
I have tried reinstalling Calibre - you guessed it, no joy.

Thanks for the help offered - I hope someone can steer me in the right direction.
If not, I'll restore a system backup over the weekend and try again, see if I can isolate the issue.
Huisie is offline   Reply With Quote