Thread: DR800 DR800 won't boot up
View Single Post
Old 02-18-2011, 05:54 PM   #1
Drop Bear
Drop Bear began at the beginning.
Posts: 35
Karma: 46
Join Date: Apr 2010
Device: dr800sg
DR800 won't boot up

Hello all,

My DR800SG will not boot up. It seems to be stuck on the very first screen that has the guy reading a book with lots of circles with IREX in the top right and the Adobe logo in the bottom left.

I have read a few other posts with similar problems and tried the following to resolve it with no result:

1. Disconnected battery for 1min, 5min, overnight then tried switching it back on.

2. Charged it overnight.

3. Reset it by sliding the on button leftwards up to 20-30 times in a row.

4. Tried turning it on whilst connected to charger with and without the battery.

5. As above but connected to PC via usb.

Does anyone else have any other advice to help me fix my beloved ereader? I haven't used it in months and really got very little use out of it considering how much it cost me. I would hate to think that it is bricked.

PS. Seeing as Irex is now kaput are any and all warranty claims now useless aswell?

Drop Bear.
Drop Bear is offline   Reply With Quote