View Single Post
Old 02-14-2011, 10:06 AM   #1
windycitygal has a complete set of Star Wars action figures.windycitygal has a complete set of Star Wars action figures.windycitygal has a complete set of Star Wars action figures.
Posts: 10
Karma: 282
Join Date: Feb 2011
Device: NookColor
Successfully rooting NC using a Mac

So many of the threads I've found on message boards focus on how to perform the root with a Windows PC or with Linux. I moved over to a Mac last year from Windows and am still learning about this system; add on the challenge of trying to learn what seems to be a rather technical process and yet another new system (Android), and I was really struggling.

My NC was bought the day after Christmas and used as-is for nearly two months. I liked the BN interface, but was tired of waiting for access to more apps. I started this process with a NC running the most recent BN update of 1.1 and a fresh micro SD card.

Here are the resources I used to successfully root my NC, the places where I got hung up, and the resolutions to those issues.

* Read through the XDA Developers Forum post about rooting several times.
* Read through the NookDevs entry on rooting several times, too, paying careful attention to the instructions on rooting with a Mac.
* Downloaded the most recent AutoNooter file 3.0.0. Unzipped it to my Mac desktop.

I got stuck trying to add to the AutoNooter .img file to the micro SD card. I had never worked in Terminal and didn't understand why my careful following of the instructions from Nookdevs (the most complete for a Mac user) weren't successful.

There were two problems with my approach: 1) I didn't unmount the micro SD card before running the command to burn the .img file. 2) When I did unmount the card and then tried to burn the .img file, I didn't wait long enough for the operation to complete. I didn't see any immediate feedback that my process was running, so I assumed it failed and ejected the card too early.

Please note this if you're unfamiliar with using Terminal: you have to wait several minutes for the files to write to the SD card; it will look like nothing is happening during this time; when the write is complete, you will see a message confirming that it is done.

I figured out this problem after watching Huskermania's Youtube video on how to root a NC using a Mac.

The video was great, so I highly advise watching it. Please note, though, that the experience I had when following his instructions wasn't exactly the same; I suspect that's because he shot the video using an older version of AutoNooter.

After getting the .img file on the micro SD card and confirming that all the files were there, I paused to review Huskermania's video again and to watch his other video about how to reset the NC in case I messed up the process.

I finally executed the final steps of inserting the micro SD card in my NC (making sure it was fully off first, of course) and attaching it to an open USB port on my Mac. According to Huskermania's video, I should wait five minutes then disconnect the device before moving on to the next steps. During those five minutes, his video shows nothing happening to the device.

Instead, only a minute or two into the process, my NC powered on by itself and I could see the Android logo painting on the screen. Apparently this was a difference due to the newer AutoNooter file I was using, since everything worked out OK.

I did make sure I removed the micro SD card before rebooting my NC, though, just to be on the safe side.

I was very happy to see that the standard BN menus were still there because I had gotten used to it and had been worried I wouldn't be able to figure out how to access my books and files. When I went to Extras I saw the new apps available and knew that I had a success!

Let me add that while I could log into YouTube with no problems, I did have issues with Gmail at first. It kept telling me it could not automatically sync my account, and I just kept trying. Finally it worked.

I do have some other little issues/questions about a few of the apps that were installed, but I'll post those separately.

And as Scion noted in one of her posts, there's a learning curve associated with using Android and the overlay apps. Keep that in mind when encountering issues, and keep searching the message boards for what others have done to address them.
windycitygal is offline   Reply With Quote