View Single Post
Old 02-02-2011, 09:11 PM   #1
Mystify began at the beginning.
Posts: 10
Karma: 10
Join Date: Feb 2011
Device: Kindle2
K2 2.5.7 - Collections - registration/usbNetwork hack?

I got a lovely second hand Kindle2 for Christmas. YAY.
This is the first ebook reader I have ever had...

Looking like a TL;DR post - just jump to the bottom, the nutshell and question are there.

The details:

But, the person that bought it for me didn't realize at the time that there was a difference between the Kindle US (B002) and international (B003) and bought me the B002 us only model. She's not a techy, so I can't really fault her.

Now, the ONE thing I want more than anything is to get the Kindle to register, and I will to why later.

Now, I've spent hours on the phone with Amazon techincal support and after many different phone calls, the agents basically said "Too bad, so sad. Your SOL."

So to the interweb I go, and I have spent DAYS trying to figure this out.

When I bought it, it had firmware 2.5.3 installed. I have no idea if it came pre-loaded with any hacks (I don't think so) but this being my first unit, I didn't even know you could hack it.

So once I got over the fact I could use the Wifi because I live outside the US, and finally tracked down a USB cable, I was finally able to start putting content on it and everything was good, if a little annoying.

During one of my phone calls with Amazon tech support, and trying to find a way to get the Wifi working, I noticed there was a firmware update available. 2.5.7

Upon reading the release notes and "what's new" I noticed it had "collections". OY! I REALLY want that feature as I have several hundereds files on my Kindle and it's a pain to sort through hem all... collections is exactly what I want.

So, I installed the 2.5.7 Firmware update. No problems.

Fire it up, only to discover the the "collections" feature is disabled...

Another phone call to Amazon tech support. APPARENTLY... this feature (and the sole reason for updating to this firmware to begin with) is only available to registered kindles. And since I can't connect to whispernet to register it because I am outside the US, they basically told me to bugger off.


I began trying to figure out a way around this.

and after about 2 weeks of solid reading and trying many different things, I have little to NO success.

95% of the stuff I have read or tried is "out of date" or pre-2.5.7 so I don't know if it's not working because of the new firmware or if it's something I am doing wrong.

My "plan" was to get the usbNetwork system working, so that I can register it via the internet on my computer.

But since I have 2.5.7 installed... none of the hacks and tutorials and posts I have read seem to work.

I tried installing jailbreak for the 2.5.x firmware, but I get a U007 error when I try... and it doesn't work.

I tried to revert back to a previous firmware (2.5.3) but the system won't take it.... grrrrr

All I want is collections to work.

So here is my question

Kindle2 with 2.5.7 firmware running on a Windows 7 Home PC
Model B002 outside the US sprint Network.
reset to factory defaults
I have no idea if there any active hacks installed or how to tell so that I could remove them. (I don't think there is... but I have no idea if any that I tried took and are still installed)

How can I get this thing registered so I can use collections.

Registration hack?
usbNetwork Hack?
Jailbreak that will actually install?
Something else?
Mystify is offline   Reply With Quote