Thread: Firmware Update Problem about Kindle 3 Firmware Update
View Single Post
Old 01-17-2011, 11:17 AM   #1
Junior Member
palmtenor began at the beginning.
Posts: 5
Karma: 10
Join Date: Dec 2010
Location: Paris, France
Device: Kindle 3 Wifi+3G, iPhone4, iPad
Problem about Kindle 3 Firmware Update

I've just bought my new Kindle3 WiFi, and I'm trying to upgrade it to firmware version 3.0.3. I followed the instruction on, downloaded the right version of firmware file(there is only one possible for WiFi version and it fits my device serial code B008), transfer it into my Kindle root directory, ejected properly, but when I go into Settings-Menu, the "Update Your Kindle" is still grey.(Preciously speaking it is black for a moment and instantly turns to grey) Also, when I plug the USB Wire again, I found that the firmware file I've transfered has been automatically deleted. Now matter how many time I tried that, the same thing keep happens. I even try to copy all version of firmware(B008, B006, B00A) into my Kindle, but only the right version (B008) be automatically deleted and still no way to upgrade. How could I solve that problem? My version is Kindle 3.0.3 (553210206). Have anyone encountered the same problem before?
Thank you very much!
palmtenor is offline   Reply With Quote