Thread: Bug report
View Single Post
Old 01-08-2011, 03:42 PM   #115
Junior Member
ivagiglie began at the beginning.
Posts: 2
Karma: 10
Join Date: Jan 2011
Device: pocketbook 603
Hi all, first post, great forum! (I've been lurking around for a while already before registering!)

Eventually I received yesterday my first ebook reader, it's a pocketbook 603 and I'm partially happy about it.
I chose the pocketbook for the "openness" but I've spent the whole day struggling to get an additional dictionary working, with no luck.

And given the device is a new model it's hard to find info/troubleshooting

I've downloaded several dictionaries taken from links in this forum, no one worked.
I've also downloaded some from
and converted them using the official converter:
but also here I had no luck.

Ok, time I describe the issue:
after I get the dictionaries I copy them to /system/dictionaries and they become available - I can select them in the dictionary application and in the integrated dictionary in fbreader.
I can see they're are *somehow* recognized by the fact that their entire long name is shown in the dictionary list (made also some experiments changing the proper field in the xdxf files before converting).
But whenever I open the dictionary from the fbreader, having selected a new dictionary I added, the device hangs for a moment and then jumps back to the home screen.
Something similar happens in the standalone dictionary application, I get the program to run (strangely it displays a different keyboard compared to the one shown when using the default dictionaries) but whenever I enter a key again small freeze and back to the home screen.

The very bad thing is, there's no way to get rid of this behavior without connecting the device to the pc and deleting the dictionary file.
And that's because I can't change the current selected dictionary, whenever I open the list, boom, back to the home screen.

Has anybody tried *successfully* additional dictionaries with the new pocketbook 603?
In case a link would be more than welcome!

Thanks in advance for your help.

ps my firmware is 2.0.4, the only one available for the device at the moment as far as I know
ivagiglie is offline   Reply With Quote