View Single Post
Old 11-04-2010, 12:37 PM   #1
Junior Member
cebyam began at the beginning.
Posts: 7
Karma: 10
Join Date: Nov 2010
Location: Vancouver, Canada
Device: Kindle
Unable to download to either Kindle or computer!


I'm hoping that someone can help me.

I've never had a problem before with my 2nd Gen Kindle.

Last night I bought two new books online. I eagerly switched on the kindle's wireless and Sync & Checked for new times, but nothing happened.

I tried that a few times, then I looked in the Archived Items and there they were. I selected them and it says "Now downloading the selected item... It willl automatically open when the download is complete."

However it never opens and times out.

I tried to access the Kindle store, but that doesn't work either, despite the fact that I have full bars!

I left it for the night, thinking it might work this morning, but alas. Same problem.

I tried doing everything it said on the Amazon site in their trouble shooting section. Restarting has had no effect whatsover.

I really want to read the new books, so I thought that maybe I could download to my computer and then upload them via USB, but when I try to do that, I can get past the Sign In page! It just keeps refreshing that page, and yes, my password is correct.

I can download them to my 'Kindle for Mac' though. But not my actual Kindle, nor my desktop to transfer to the Kindle itself.

Hoping that someone can help me....

Getting very frustrated!!!

Last edited by cebyam; 11-04-2010 at 03:12 PM.
cebyam is offline   Reply With Quote