Thread: Cybook Gen3
View Single Post
Old 11-09-2007, 08:53 AM   #2
kleykenb has learned how to buy an e-book online
Posts: 156
Karma: 99
Join Date: Jul 2007
Device: DR1kS/Cy3
Originally Posted by iamscottish View Post

I have been reading this forum for months now. Many thanks for all the information provided on the various eBook devices. I have been reading eBooks on my iPAQ till now and I then decided to buy a Cybook Gen3 which arrived yesterday.

I am embarrassed - to say the least - to say that I am having difficulty with it. Instead of the English language being displayed my Library displays the books using strange symbols.

Resetting (several times) hasn't worked. Can anyone please help?
Not clear what OS you are using so that would be helpful but first can you tell us if the device ever worked correctly ?
It comes with loads of demo and other stuff in the Library which should show up just nicely.
If it's about the library then I would first remove the SD card if you have one installed and then plug it in your computer.
Then look in My Computer and find the newly added drive and see what is on there.
kleykenb is offline   Reply With Quote