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Getting Started with Kindle Previewer, version 
1.6 

Kindle Previewer lets you validate the content formatting for Kindle books created for the 

following Kindle devices and applications: 

 Kindle (3rd Generation) 
 Kindle DX 
 Kindle for iPhone  
 Kindle for iPad 

Kindle Previewer makes it easy to preview the layout of a Kindle book so you can make sure its 

text displays properly for any orientation or font size. Kindle Previewer also lets you easily 

navigate a Kindle book and quickly turn pages so that you can verify how the book's content will 

look before you publish it in the Kindle Store. Publishers, eBook conversion companies, and 

individual authors can use Kindle Previewer independently or as a companion to KindleGen to 

produce the highest-quality Kindle books. 

System Requirements 

The minimum hardware requirements for using Kindle Previewer are the following: 

 1GHz processor 
 512 MB of RAM 
 15-inch display size 
 1024 by 768 screen resolution 

Kindle Previewer runs on the following operating systems: 

 Macintosh OSX 10.5 or later 
 Windows XP SP2 or later 
 Windows Vista SP1or later 
 Windows 7 

Supported File Formats 
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Kindle Previewer can display books created in the following formats: 

 .azw 
 .mobi 
 .prc 
 .epub 

For more information about creating books in these formats, see the Amazon Kindle Publishing 

Guidelines.  The publishing guidelines also provide information on formatting and testing your 

books and using Kindle publishing best practices. 

 

Downloading and Installing Kindle Previewer 

You can download Kindle Previewer for Windows and Mac OSX at this following location: 

http://www.amazon.com/kindlepublishing  

Installing Kindle Previewer on Windows 

An administrator account is not required to install Kindle Previewer on a Windows computer. 

To install Kindle Previewer for Windows, do the following: 

1. Download the file KindlePreviewerInstall.exe to your desktop. 
2. Double-click the file to start the installation. By default, Kindle Previewer will be 

installed to the following location: C:\Users\username\AppData\Local\Amazon\Kindle 
Previewer (Windows 7 and Windows Vista) or C:\Documents and 
Settings\username\Local Settings\Application Data\Amazon\Kindle Previewer (Windows 
XP), where username is the name of the user who installed the program.  You can also 
choose to install Kindle Previewer in a folder of your choice by clicking the Browse 
button and choosing the target folder. 

3. Once the installation completes, you can start Kindle Previewer by going to Start 
Menu>All Programs>Amazon>Kindle Previewer. 

 
Installing Kindle Previewer on Mac OSX 

To install Kindle Previewer for Macintosh, do the following: 

http://kindlegen.s3.amazonaws.com/AmazonKindlePublishingGuidelines.pdf
http://kindlegen.s3.amazonaws.com/AmazonKindlePublishingGuidelines.pdf
http://www.amazon.com/kindlepublishing
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1. Download the file KindlePreviewer.zip to your desktop. 
2. Unzip the file to get Kindle Previewer.app 
3. Drag Kindle Previewer.app from the Downloads folder to the Applications folder. 
4. Start Kindle Previewer. 

About the Kindle Previewer User's Guide  

When you install Kindle Previewer, the Kindle Previewer User's Guide is included as 

UserGuide.pdf in the same location as the application. You can also access the Kindle Previewer 

User's Guide from the Kindle Previewer Help menu. 

 

About Creating Kindle Books 

You use Kindle Previewer as a companion to KindleGen to create Kindle books. KindleGen is a 

free command-line tool that allows you to build a Kindle book from sources in HTML, XHTML, or 

IDPF 2.0 format (HTML content files with an XML .opf manifest file). KindleGen is the only tool 

officially supported by Amazon to convert files to the Kindle format. 

See the Amazon Kindle Publishing Guidelines, for more information on using KindleGen. You can 

download KindleGen at the following location: http://www.amazon.com/kindlepublishing  

The general steps to create Kindle books using KindleGen and Kindle Previewer are: 

1. Follow the steps described in the Amazon Kindle Publishing Guidelines to create the Kindle 
book's source files. 

2. Compiling the source files 
2.1. Using Kindlegen: Use KindleGen to create the Kindle book in one of the following 

formats: .azw, .mobi, or .prc. 
2.2. Using Kindle Previewer: Use Kindle Previewer to directly open source files which are in 

.epub format.  
3. Use Kindle Previewer to preview how the book will appear on Kindle devices and 

applications. 
4. Make any required changes to the book's source files. 
5. Repeat steps 2 - 4 as necessary. 
6. When you are ready to publish your Kindle book, follow the steps described in the Amazon 

Kindle Publishing Guidelines. 

http://kindlegen.s3.amazonaws.com/AmazonKindlePublishingGuidelines.pdf
http://www.amazon.com/kindlepublishing
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Using Kindle Previewer 

The following sections provide information on Kindle Previewer features and how to use them. 

Kindle Previewer Features 

You use Kindle Previewer to preview a book's content, navigate to different locations in the 

book, and change display options. 

 

 

Toolbar Buttons and Actions 

You can use the toolbar to navigate in a book and change a book's display options.   

Go Back: Returns to the page that was displayed before the last change in location. 

Goto Prev Section: Displays the beginning of the previous section or chapter. 

Goto Prev Page: Displays the previous page. 

Goto Next Page: Displays the next page. 
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Goto Next Section: Displays the beginning of the next section or chapter. 

Rotate Screen: Toggles the display between portrait and landscape orientation. This option is 

not available when the Custom skin is selected. 

Set Font Size: Changes the text size to one of the font sizes available on the selected device.  

Cover: Displays the book's cover. 

Table of Contents: Displays the first page of the table of contents. 

NCX View: Displays the book’s logical table of contents. 

The File Menu  

Use the File menu to open and close books and to exit the Kindle Previewer application. 

Open Book 

Opens a book file that's in one of the following formats: .azw, .mobi, .prc, .epub. You can also 

drag a book file into the Kindle Previewer window to open it. You cannot open encrypted Kindle 

books in Kindle Previewer. 

Close Book 

Closes the current book. 

Open Recent 

Displays a list of recently opened books. Select Clear List to remove all items from the list. 

Exit 

Exits the Kindle Previewer application. 

The View Menu 
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Use the View menu to open a book's logical Table of Contents. 

NCX View 

Opens a book's logical Table of Contents, which is defined by the book's navigation control 

(.NCX) file. Double-click an entry in the NCX View to navigate to the selected location. 

The .NCX file defines the hierarchical structure of a Kindle book, and also allows users to see 

their progress as they read a book. An .NCX file is required for all Kindle books. For more 

information on .NCX files and how to implement them, see the Amazon Kindle Publishing 

Guidelines. 

The Go to Menu 

Use the Go to menu to navigate to different locations in a book. In addition to the commands 

listed below, the Go to menu can also list additional locations if they were defined for the 

current book, such as the "start reading" location. 

Location 

Lets you enter a numeric location to go directly to that location. Even if you change the font 

size, the numeric location remains the same.  

Tip: To copy the numeric location of the current page to the clipboard, enter Ctrl+U. To go to 

first page in the book (typically the first page after the cover page), enter Ctrl+Shift+F. 

Table of Contents 

Displays the first page of the Table of Contents. 

Next Page 

Displays the next page. 

Prev Page 

http://kindlegen.s3.amazonaws.com/AmazonKindlePublishingGuidelines.pdf
http://kindlegen.s3.amazonaws.com/AmazonKindlePublishingGuidelines.pdf
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Displays the previous page. 

Beginning 

Displays the "start reading" location, as defined in the book's manifest (.opf) file. Typically this is 

the first page of the first chapter in the book. 

Cover 

Displays the book's cover. 

Prev Image 

Navigates to the location of the first image that appears before the current page 

Next image 

Navigates to the location of the first image that appears after the current page 

Auto Flip 

Helps you flip through the pages or images automatically.   

Search Word 

Lets you search for a particular word in the book.  There is also an option to view the search 

results as a list.  In Kindle Previewer version 1.6, search is enabled only for Kindle, Kindle DX and 

Custom device modes. 

The Devices Menu 

The Devices menu lets you see how a book will appear on Kindle devices and applications.  

Kindle 

Displays a book as it will appear on the Kindle Global Wireless device, latest generation, with 6-

inch display. 
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Kindle DX 

Displays a book as it will appear on a Kindle DX Global Wireless device, latest generation, with 

9.7-inch display. 

Kindle for iPhone 

Displays a book as it will appear in the Kindle for iPhone application. 

Kindle for iPad 

Displays a book as it will appear in the Kindle for iPad application. 

Custom 

Provides a freely resizable view so you validate that the book's content displays correctly using 

different screen sizes. Drag the view to resize it. 

The Utilities Menu 

The Utilities menu helps you to configure Transcoding settings and monitor the Transcoding 

Status on videos in a Kindle Edition.  The utilities menu will be enabled only when the opened 

book has videos in it. 

Set FFmpeg Path 

Lets you set the directory path where the FFmpeg executable is present.  FFmpeg executable is 

required by Kindle Previewer to perform transcoding on the videos in the book and convert 

them to iPhone/iPad specifications.  FFmpeg executable for windows and mac can be 

downloaded from internet.   If you prefer to preview the videos that are transcoded for 

iPhone/iPad, download FFmpeg and then set the path in Kindle Previewer. 

Transcode Status 

Displays the transcoding status of all the videos that are present in the opened book. 
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Transcode Automatically 

Lets you enable or disable automatic transcoding of the videos inside a book. 

The Help Menu 

The Help menu lets you send feedback on Kindle Previewer, displays a list of all keyboard 

shortcuts, and provides information about the application, such as software version number. 

Send Feedback 

Opens a new mail message in your default mail program, so you can send your feedback about 

Kindle Previewer to kindle-publishing-tools@amazon.com. 

Keyboard Shortcuts 

Displays a list of all keyboard shortcuts in the application. 

Navigation Keyboard Shortcuts 

Task Mac OSX Windows 

Go Back   Cmd+B Ctrl+B 

Go to Beginning  Cmd+S Ctrl+S 

Go to Cover  Cmd+R Ctrl+R 

Go to First Page  Cmd+Shift+F Ctrl+Shift+F 

Go to Location  Cmd+L Ctrl+L 

Go to Next Page  Right Arrow Right Arrow 

Go to Next Section  
 Cmd+Right 
Arrow 

Ctrl+Right 
Arrow 

Go to Prev Page  Left Arrow Left Arrow 

Go to Prev Section 
 Cmd+Left 
Arrow 

Ctrl+Left Arrow 

Go to Table of Contents  Cmd+T Ctrl+T 

Go to Prev Image  Fn + F3 F3 

Go to Next Image  Fn + F4 F4 

NCX View  Cmd+N Ctrl+N 
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 Book Keyboard Shortcuts 

Task Mac OSX Windows 

Close Book   Cmd+W Ctrl+W 

Exit   Cmd+Q Ctrl+X 

Open Book   Cmd+O Ctrl+O 

Copy numeric location of current page 
to clipboard 

 Cmd+U Ctrl+U 

Display Keyboard Shortcuts  Cmd+K Ctrl+K 

Search  Cmd+F Ctrl+F 

Transcode Status  Cmd+Shift+T Ctrl+Shift+T 

Auto Flip  Cmd+Shift+A Ctrl+Shift+A 

 

Screen Keyboard Shortcuts 

Task Mac OSX Windows 

Rotate Screen   Cmd+Shift+R  Ctrl+Shift+R 

Set Font Size  
Cmd+n, where n = 1 - 8  

 
Ctrl+n, where n = 1 - 8  

 

Kindle Previewer Help 

Opens the Kindle Previewer User's Guide, in a new Kindle Previewer window. 

About 

Displays the application's software version number and copyright information. 

Support for Kindle Editions with Audio/Video 

You can preview the audio/video contents of a Kindle Edition with Audio/Video in Kindle for 

iPhone/iPad views, by clicking on the audio/video object.  By default, Kindle Previewer will try 



12 
 

to play the transcoded video in case of a left click on a video object.  To preview the Source 

(original) video you can use the right-click option. To preview the audio/video contents in the 

player of your choice you can use the right-click option. 

Transcoding of Videos in a Kindle Edition 

If you want to preview the videos after they are transcoded to iPhone/iPad specifications, 

Kindle Previewer helps you do that with help of FFmpeg executable.  Download FFmpeg 

executable, and set the path to the executable in the Utilities menu.  You have the choice to 

enable/disable automatic transcoding from the Utilities menu.  If Transcode Automatically is 

enabled, transcoding of videos to iPhone/iPad specification will start automatically in the 

background, if the option is disabled you will have to click on a video object to start transcoding 

on that video.  The status of the transcoding process for each video in the book can be viewed 

using the Transcode Status sub menu in the Utilities Menu. 

Support for Command Line Arguments in Windows 

Kindle Previewer for Windows now supports command line arguments.  You can directly open a 

Kindle Book in Kindle Previewer from command prompt. 

Eg: 

KindlePreviewer.exe C:\books\sample.mobi 

If Kindle Previewer is set as the default application for opening Kindle Books, a double-click on 

the book will open it directly in Kindle Previewer.  Otherwise you can right-click and open the 

book in Kindle Previewer using “open with” option. 

Release Notes 

Version 1.5 

Features / Bugs Fixed 
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 Support for previewing Kindle Editions with Audio/Video 
 Support for "Kindle for iPad" preview mode 
 Support for opening ePub files 

Version 1.6 

Features / Bugs Fixed 

 Upgraded the previewing experience in “Kindle” preview mode to match with that of 
the Latest 3rd Generation Kindle Device. 

 Support for Transcoding of Videos in a Kindle Edition 
 Support for Search in Kindle, Kindle DX and Custom preview modes 
 Added additional Navigation features like Goto Previous Image and Goto Next Image 
 Added an Auto flipper to flip through pages and images automatically 
 Support for Command Line Arguments in Windows 
 Support for custom install location in Windows 
 Fixed the issue on windows with non-default DPI settings 

Kindle Previewer Known Issues 

 If a book contains characters in blue, they will display as black characters in Kindle 
Previewer but as light grey characters on a Kindle device. 

 Books that contain nested tables, large tables, or table cells that contain paragraphs of 
text or large images will not display properly in Kindle Previewer or on Kindle devices. 
Consider reformatting such tables and refer to the table guidelines provided in the 
Amazon Kindle Publishing Guidelines. 

 If a book contains tables, the tables may not display properly when navigating in the 
book using the Kindle for iPhone/iPad view. 

 Some options (for example, changing the text color) that are available in the Kindle for 
iPhone/iPad application are not available in the Kindle for iPhone/iPad view in Kindle 
Previewer. 

 The device location bar that appears inside the Kindle Previewer window in 
Kindle/Kindle DX view is for display purposes only and cannot be used for navigating a 
book. 

 If an image has border lines, the border lines may not display correctly in Kindle 
Previewer or on Kindle devices. 

 The number of words per line and the number of lines per page in Kindle for 
iPhone/iPad views might not match with those in the corresponding applications. 

 The number of lines per page in Kindle/Kindle DX modes might not match with those in 
the corresponding devices. 
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 Kindle Previewer’s display looks best when the DPI of the screen is set to the default 
value of 100%.  For higher DPI settings the previewing experience will remain the same 
but the quality of the book display might be compromised. 

 Search Menu is disabled in Kindle for iPhone/iPad modes 
 In Windows XP, the Auto Flip feature does not work if a screensaver runs during the 

flipping and the Kindle Previewer goes into an unresponsive state. 
 In Mac, when multiple instances of Kindle Previewer runs the Auto Flip, the application 

sometimes goes into an unresponsive state. 


