
eBooks: Optimizing images 
for the EPUB !le format
Guide to using Adobe® InDesign® to produce eBooks with 
high-quality images

!e electronic publication (EPUB) "le format is an open eBook standard that was developed by 
the International Digital Publishing Forum (IDPF) to allow publishers to produce and distribute 
a single version that can be read on a diverse range of eBook readers—from handheld devices 
(like the Sony Reader) to desktop reading applications (like Adobe Digital Editions) and 
smartphone reading applications (like Stanza on the iPhone). When producing an EPUB "le 
with Adobe InDesign, it’s important to prepare the images for optimum display on a variety of 
screen sizes and resolutions. !is white paper provides some best practices to follow when laying 
out images in an InDesign document that will be exported as an EPUB "le. It also walks you 
through each of the image export options that InDesign provides when exporting an EPUB "le.

Best practices for working with images
For optimum display when exporting to the EPUB format, use the following best practices to 
prepare the images in InDesign.

Convert InDesign artwork to external images. Only the images that have been placed into 
InDesign are retained in the EPUB "le. Artwork created with the InDesign vector drawing tools 
is discarded. To include artwork generated in InDesign in an EPUB "le, copy and paste the 
artwork into either Adobe Illustrator®, Adobe Photoshop®, or another InDesign document to 
create an external image that you can then place into InDesign.

Anchor images. To precisely control where images appear in the EPUB "le, anchor the images 
within the main body of text. Anchoring the images also ensures that when the text in the EPUB 
"le re#ows, the images travel with the text to which they are attached. If you don’t anchor the 
images, InDesign exports them in the order they are arranged on the page—from le$ to right 
and then from the top down. !e images will likely end up toward the beginning or end of all the 
text in the EPUB "le, unless you carefully extend or relocate the text and image frames to control 
their #ow order. To create an anchored image, select the image with the Selection tool and 
choose Edit > Cut. !en use the Type tool to position the cursor within the text where you want 
the image to appear and choose Edit > Paste. By default, the anchored image’s position is inline.

Anchor each image to its own paragraph. To ensure that an image appears between paragraphs 
in the EPUB "le, it must be anchored to its own paragraph by inserting an extra paragraph 
return and anchoring the image to that paragraph. You can then apply a paragraph style to the 
paragraph to further control the image’s position. For example, to center an image and create 
some space above and below it in the EPUB "le, you center-align the paragraph and apply space 
before and a$er it.

Note: Since text wrap settings are discarded in the EPUB !le, you must use the InDesign Space 
Before and Space A"er options to add extra space above or below an image.
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If you want to preserve the original layout of your InDesign document, you must customize the 
position of the anchored images. Select the anchored image that you want to reposition and 
choose Object > Anchored Object > Options. In the Anchored Object Options dialog box, choose 
Custom from the Position menu, specify the position options as necessary, and then click OK. If 
the image is anchored to its own paragraph, extra space will appear in your layout. To remove 
the space, apply a leading value of 0 points to the paragraph that the image is anchored to.

Note: When you use the Custom position option in the Anchored Object Options dialog box, the 
exact position of the image is not preserved in the EPUB !le, but you gain full control over its 
position in the InDesign document.

Use color images. While many current eBook readers have grayscale displays, it’s a good idea to 
use color images for two reasons. For one, future eBook readers will likely have color displays, so 
you won’t have to update your eBooks when that time comes. Second, some reading devices, such 
as the iPhone, iPod touch, and various Mobipocket-supported devices, do support color images.

Create a single image for the cover. !e cover for an eBook must be a single image. If your cover 
design is composed of an assortment of text and image frames within InDesign, the design 
elements will be linearized in the eBook. To quickly generate a cover image, you can export the 
cover from InDesign as a JPEG "le. Choose File > Export, specify a name for the image, choose 
JPEG from the Format menu, and then click Save. In the Export JPEG dialog box, specify which 
page you want exported. For optimum display on di%erent screen sizes and resolutions, specify a 
resolution of 72 pixels per inch (ppi) and choose Maximum from the Quality menu. Click Export 
to generate the image. !e "nal image size for the cover should be around 600x800 pixels so that 
the cover looks good on a variety of eBook readers. If the pixel dimensions of the image are not 
large enough, export the image at a higher resolution. A$er your cover image has been created, 
import it into InDesign.

Alternatively, you can copy and paste the cover artwork into another InDesign document and 
then place that document into your book layout. When you export the EPUB "le, the imported 
InDesign document is converted to a JPEG image.

Manage the cover with a book !le. !e EPUB "le format does not de"ne page structure, so all 
content #ows together in one continuous linear stream. !is can be problematic for an eBook 
cover, because text from the following page can potentially run into the cover image. To avoid 
this problem, create a separate InDesign document for the cover image. !en combine the cover 
document with any other documents that make up your book layout into an InDesign book "le 
(File > New > Book).

To learn more about setting up an InDesign document, the training resources at Adobe.com can 
point you in the right direction. See www.adobe.com/support/training/products/indesign.html.

Understanding the InDesign image export options
When you are ready to export a document as an EPUB "le, choose File > Export for Digital 
Editions. If you are exporting a book "le, choose Export Book For Digital Editions from the 
Book panel menu. In the Digital Editions Export Options dialog box, select the Images category 
to display the image export options.
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InDesign provides two methods for exporting images to an eBook. You can choose to export the 
original images or an optimized version of each image. From the Copy Images menu, determine 
how you want the images to be exported.

Exporting optimized images
When producing a document in InDesign, you typically use high-resolution images. However, if 
you try to use the same images for an eBook, they will be too large. Large images consume a lot 
of memory and take longer to draw on screen. If an image is too large, you encounter problems 
on eBook readers with limited memory and processing power. If you choose Optimized from the 
Copy Images menu, InDesign automatically exports an optimized version of each image that 
displays well on most eBook readers and is small enough to avoid performance and memory 
issues.

With the Optimized option selected, InDesign provides several options to specify how the 
images are exported.

Formatted—!e exported images are reformatted to the size to which you have scaled them in 
your InDesign document. !e images are also converted to the RGB color mode, and their 
resolution is changed to 72 ppi, which helps reduce the overall "le size of the "nal EPUB "le. In 
addition, the Formatted option preserves InDesign formatting that you’ve applied to your image 
frames, such as stroke, "ll, rotation, shear angle, and any cropping you’ve done.

If you do not select the Formatted option, any formatting you’ve applied to your image frames is 
discarded. !e images are still converted to the RGB color mode (except for grayscale images), 
and their resolution is changed to 72 ppi.

If you plan on selecting the Formatted option, make sure that your images and illustrations are 
between 300 points and 600 points wide so that the exported versions look good on various 
eBook readers. An image that is 600 points wide becomes 600 pixels wide when it is exported.

Image Conversion—You can choose whether the optimized images are converted to GIF or 
JPEG. If you choose Automatic, InDesign determines which format to use for each image. GIF 
uses a limited color palette that cannot exceed 256 colors, so it’s best for logos and simple 
graphics. !e JPEG format is best for images and illustrations. If your InDesign document 
contains a combination of logos and images, choose Automatic. Otherwise, specify the format 
that "ts your needs best.
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GIF options—!ere are two main options in this section of the Digital Editions Export Options 
dialog box: the Palette menu and the Interlace option. With the Palette menu, you can determine 
how you want InDesign to handle colors when optimizing GIF images. !e Adaptive (no dither) 
option creates a palette using a representative sample of colors in the image without any 
dithering. !e Web option creates a palette of web-safe colors. !e System option creates a 
palette using the built-in operating system color palette. Select the Interlace option to speed up 
the download time of the GIF images. !is option also increases "le size.

JPEG options—!is section contains two menus: Image Quality and Format Method. Select an 
option from the Image Quality menu to determine the amount of compression and image quality 
of each JPEG image created. Choose Low to produce the smallest "le sizes and the lowest image 
quality. Choose Maximum to produce the highest image quality and the largest "le sizes. Use the 
Format Method menu to determine how quickly the JPEG images display when the eBook is 
opened. !e Progressive option creates images that increase in detail as they are downloaded. 
!e Baseline option creates images that display a$er they have been completely downloaded.

Exporting original images
If you prefer to optimize the images yourself, choose Original from the Copy Images menu, and 
InDesign will export the original images to the EPUB "le. With this option selected, all the other 
image export options are not available.

When optimizing images for the EPUB "le format, it’s best to create one eBook that works well 
across a variety of reading devices. Keep in mind that there is an abundance of eBook readers 
available on the market today. !ey vary in screen size and resolution. For example, the iPhone 
has a 3.5-inch display with a resolution of 163 ppi, whereas the Amazon Kindle has a 6-inch 
display with a resolution of 167 ppi, and the Amazon Kindle DX has a 9.7-inch display with a 
resolution of 150 ppi. Figuring out how to handle images depending on the end device is a 
challenge. And as the eBook reader market continues to grow, there will be newer models with 
even more advanced technology and impressive features.

If you choose to manually optimize images for your eBooks, consider the following criteria.

Color space—Convert your images to either RGB or grayscale.

Resolution—Save your images at a resolution of 72 ppi or higher if you are publishing your 
eBook on a speci"c reading device that has a high-resolution display.

Image dimensions—It’s not always possible to predict which reading device your eBooks will be 
read on. So if you are not targeting a speci"c device, make sure that your images are larger than 
300 pixels wide and smaller than 600 pixels wide. Logos can be smaller, at around 75–100 pixels 
wide. !ese dimensions ensure that your images display well on most eBook readers. If you are 
creating an eBook for a speci"c device, make your images the same size or smaller than the 
viewable area of the device.

File format—!e EPUB "le format supports JPEG, GIF, and PNG images. !e JPEG format is 
commonly used for photographs. !e GIF and PNG formats are good for logos, charts, and 
graphs.

Keep in mind that it’s always a good idea to test your eBooks on various eBook readers before 
o%ering them for sale.
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