Book Designer Hints and Tips
Prepared by Patricia for the MobileRead Community at http://www.mobileread.com/ 
[V.1, 21 January 2009]
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Book Designer: Useful Links:

There’s a useful page about Book Designer on the MobileRead Wiki:

http://wiki.mobileread.com/wiki/Book_Designer
A thread on how to install BD:

http://www.mobileread.com/forums/showthread.php?t=11786 
And HarryT’s excellent Book Designer tutorial is a good place to start:

http://www.mobileread.com/forums/showthread.php?t=10313 
And Andybaby is working on a graphical Guide to BD here: 

http://www.mobileread.com/forums/showthread.php?t=36107 

JSWolf’s Book Cleaner files are here:

http://www.mobileread.com/forums/showthread.php?t=11649 

Which Version do I Have?

Currently (January 2009) the latest version is BD5.0, with the last update dated 30 July 2007. 
To work out which version you have, do this:

1. Open BD. Click on “Help” then on “Book Designer Main Help.” If it says “Book Designer 5.0 alfa” then you have BD5.0. If it says “Book Designer 4” then it is a good idea to get BD5.0 and install it over BD4.0.
2. To check whether you have the latest version of BD5.0 (currently 30 July 2007) click on “Insert” and examine the options for inserting a TOC. If you are offered “insert TOC” AND “insert TOC (all)” then you have the latest update.

 If you only have “insert TOC” then you don’t have the latest update.
Importing a Text
I often open BD, then drag and drop the icon with my source book onto the BD screen. This works as well as anything else, and is fast. The Book Cleaner files will still work.
RWood has found another way: “I start BD by right clicking on the file and selecting to open with BD.”
The Text Monolith

Sometimes when you import a text, all the paragraphs vanish and there is one solid block of text.

1. Check “Configuration/settings.” Have you ticked (checked, in the USA) the “keep original format” box? You probably have, which is good. So try something else.
2. Try re-importing the text. Go to “File/empty book” and try again. This works more often than you might think.

3. Go back to the source text. Sometimes replacing manual line breaks with paragraph marks does the trick. (Use the find and replace menu. Click on “More”, then “Special” to find the symbols.)
4. When all else fails, open the source file. Click on “Edit/Select All” and copy the entire text. Then paste it into BD.

Note: if you do this, then all the emdashes in the source text may turn into hyphens. So before copying and pasting, replace all emdashes with two hyphens (or the @.character). Once the text is in BD, use “Find and Replace” to restore them. 

Also note that the Book cleaner files will not work on pasted text.

Saving your Book

I import my text into BD, scroll through it quickly, to check it’s all there, and that it isn’t all one long paragraph. Then I make a Book Designer book almost immediately. 

(Click on “Make Ebooks/book Designer”, or click on the BD icon on the toolbar or the book corrector bar. Or press CTRL+F11.)

At intervals, click “save” and you shouldn’t have the horror seeing all your hard work vanishing in a crash.

It’s no good pressing “save” until you’ve made a file for BD to save to. 

Admittedly, BD will save your work in the “last file”, but this can easily get overwritten if you juggle several books, or have a crash.
It’s always good idea to save the text as a BD book if there’s any chance that you may want to add corrections at a later date.

My method is to make a BD book for every book I convert, and to have a separate folder where I toss the cover pictures.
HarryT likes to save his source files, pictures and the BD “last file” of each of his books in an individual folder.

Correcting an Earlier Book
If you saved your book as a BD book (as advised above), as well as in your chosen format then corrections are easy. Just open the BD book, edit it and make another Sony/LIT/IMP version.

Where Are My Books Stored?

By default, Book Designer is likely to be in “My Computer/C drive/program files/Book Designer 4.0.” (It still says 4.0, even if you have 5.0. Don’t worry.)
The BD folder will contain a folder called “BD” which is where your saved Book Designer books will be. It will also have folders labelled “Sony Reader”, “imp” etc for books that you have made in those formats. 

Exporting Files

Sometimes I import a LIT file into BD and realise that it needs a lot of editing, more easily done in Word. 

Under “Make Ebooks” there is an option called “Conventional: doc, rtf, html, txt.” This doesn’t work. 

But there is a workaround:

1. Go to “Save” then “Save As.” 

2. Save the book as an html0 file on your desktop or wherever you like. 

3. Open the html0 file. Click on the “Edit in Word” icon and edit away. When you are finished you can just save the file and re-import it into BD. 
4. But if you happen to want it as a Doc or RTF then use the “Save As” option in Word and save it in whichever format you like.
Characters and Accents

Emdashes

BD will render all emdashes and endashes as hyphens, unless you take some precautions. 
1. In the Tools menu, open Book Cleaner 

2. In Book Cleaner at the bottom of the pop up box, in “input file: before formatting”: choose “MiddleDashes_before.bcf” and in “input file: after formatting”: choose “MiddleDashes_after.bcf” 

3. Close Book Cleaner 

4. Load your book 

5. Finally, in the Make Sony Reader file pane, go to the options tab, find the “dashes” option and select “as it is”. 
An even better way is to download JSWolf’s Book Cleaner files and drop them into the Book Cleaner directory. (There’s a link at the top of this document.)

Accents in General

Whatever western European language your book is in, set the language in BD to German. (In Configuration/settings)This will display the fullest range of accents.

In German, BD will show graves, acute accents, cedillas, circumflexes, umlauts with no problems at all. It even seems to cope with Scandinavian characters. 

Correcting accents can be a nuisance in BD because it ignores many of the keystrokes. (Cntl+’+e should give “é”, but doesn’t.) It helps to have a Word document open. Write the accented word into the doc, then copy and paste into BD. You may find that it is less trouble to do all the accent correction before importing into BD.

The Æ Ligature

BD will manage both Æ and æ, provided that you set the language to German, Spanish or French. (It looks very odd in English, appearing as Ж; and in Polish and Czech it becomes Ć).

Many people prefer to change the ligature to “ae” for the sake of a simple life.
The Œ Ligature 
Both Œ and œ can cause serious problems in Book Designer. When importing a file it misses out the character completely, so that “manœuvre” becomes “manvre.” (I haven’t yet worked out why the adjacent “u” also vanished.
It vanishes completely in Auto, English, Spanish, Polish and French. 
RWood reports success when using it in German, but it vanished from my test pieces today. I have some recollection of using it successfully about a year ago, and have a suspicion that the latest version of Book Cleaner has a bug.
Meanwhile, it is best to find and replace œ with “oe” in the source file.
This is a great drawback for people converting French books, because œ is a true linguistic ligature and “oe” is a very poor substitute.

Multiple spaces

RWood has noticed that multiple spaces between words will diminish to a single space in the resulting book:

“There is a quirk in BD I have not seen mentioned before: Multiple spaces are collapsed in a line. Thus if I try to format a table by adding spaces to line up the data, it all shifts to the left.”
I can confirm this “feature.”
Macrons

Macrons are meant to look like this: 
Ā ā Ē ē Ḡ ḡ Ī ī Ō ō Ū ū Ȳ ȳ Ǣ ǣ 

I haven’t found a way for BD to do them properly in any language.
Complex Formatting

Book Designer is not capable of doing complex formatting, such as tables, complex mathematical formulae and the like.

You only real option in BD is to make them into an image, then insert the image into BD.

If you have the paper book, then you can scan the table and save as a picture. 

Or you can do a screen grab of your source and make a picture. (Use the print screen—Prt Sc—button on the top right of your keyboard. Then paste into Paint, or your favourite picture editor.)

If you have a PDF source then you can use the snapshot tool.

HarryT has inserted scanned images of Greek text into books, so that classical quotations are rendered accurately. 
However, if you have a book which is full of complex formatting then you may need to explore other conversion tools, such as Calibre, or making a reader-sized PDF.

Editing Text Elements

Author and Book Title

RWood has a useful hint: “I always place the author’s name(s) on the first line and the book title on the second line so when it imports to BD I do not need to set these pieces of metadata.”
If the author and book title have been wrongly assigned, so that the title is set as the author, one click on the Book Corrector toolbar button with the A and T will put it right.  
Using the Element Browser
The Element Browser (found under “Tools/Element Browser” gives a very fast way of assigning titles, subtitles, and other features. Scroll down the options, and you will see that you can identify subscript, superscript, italics, pictures etc.
Changing Titles to Subtitles

If you open the Element Browser and select “titles”, and find some that are meant to be subtitles or paragraphs then:

1. You can click on an individual title, then on “subtitle” in the Book Corrector toolbar on the right of the screen. 
2. You can select “reformat selected elements as...” in the bottom of the element Browser itself to change single titles, or en bloc, as follows:

2. You can convert several adjacent titles to subtitles in the Element Browser in one swoop. Highlight the first incorrect title, press the shift bar on your keyboard and select the others. When they are all highlighted then click on the “reconfigure selected elements as …” at the bottom of the toolbar. (I believe that Roy White was the first person to notice that this could be done.)
Bold

If you want bold some text then highlight it and select “Bold” on the Book Corrector bar. Or select “Bold” on the Format menu. Or press Ctrl+B.

By default, the Sony Reader books are all in bold, so these options will have no effect at all. If you don’t like this, then when you are making a Sony Book, click on the “Styles” tab and edit the paragraph style, so that it is no longer bold by default.

Subscript and Superscript

Many people find that these don’t display well in the finished book, so prefer to have footnotes as “[1]” rather than a superscript. The Element Browser will find all superscripts. Click on each one and then on the “superscript” button in the Book Corrector bar and they automatically become ordinary sized text. Ditto subscripts.

Underlining

1. You can find underlined text by searching for underlining in the element Browser.

2. You can remove unwanted underlining by highlighting it and pressing Ctrl+U.
3. You can underline a word by highlighting it and pressing Ctrl+U. (Or go to Format/More Styles/underline).

Occasionally, one encounters unexpected underlining which refuses to be removed as described above. These are sometimes links, so it’s worth checking in Notes and Links (in the Edit menu). If you don’t want them, they can be removed there.
More Formatting

Centred Text

By default, centred text will come out as a subtitle. This isn’t obvious in BD if you just centre it using “Format/more transformations/align center,” or just click Alt+C. But that’s the way it will appear in the book.

If you want centred text that doesn’t look like a subtitle then this is only available if you are making a Sony Reader book.

1. When you’ve finished editing, click on “make Sony Reader book” as usual.

2. In the “Make Sony Reader file” pane, click in the “Styles” tab, and edit the subtitle setting so that it uses the same font as the paragraph but is centred.

Unwanted Centred Text

Sometimes the text looks fine in BD, then you make a book and find that chunks are centred. 
1. Often this is because a title or subtitle has been moved or edited, leaving one or more centred line-spaces. Go to “View/show nbsp” You will notice that there are four non-broken spaces at the beginning of each paragraph. They are meant to be there. But if you find one that is centred then delete it. This usually solves the problem. 
2. If it doesn’t, then there may be a stray html tag, perhaps in the source. Go to Tools/html fragment editor and remove it there.

3. If you aren’t confident about doing that, then delete the beginning of the passage, retype the beginning of the passage in a word doc and paste it in.

Right-aligned Text

This simply isn’t available in books made using BD.

Oddly, you can go to “Format/more transformations/align right,” and you will get a right-aligned text in the BD book. But it won’t translate into any of the other formats.

Indented text

You can’t indent passages of text in BD.

But there is a workaround for Sony Reader books only.

1. Mark the passage(s) that you wish to indent as an epigraph. (They will now appear as blue italics but don’t worry.)

2. When you’ve finished editing, click on “make Sony Reader book” as usual.

3. In the “Make Sony Reader file” pane, click in the “Styles” tab, and edit the epigraph setting. Reduce the width as necessary, remove the italics, and set the font as the same as the one in the paragraph menu. By default, the paragraph setting is bold. It often looks nice if the indented text is not bold.
Page Breaks

Click on “Format/more transformations/insert all page breaks.” Then check (using the Element Browser, for speed) that there is a page break at the end of each chapter. 

This step is not absolutely essential, but BD often fails to make breaks above very short chapters, so it is sometimes necessary to add them yourself. 

When making a Sony Reader book, be sure to check the “page breaks” and “user page breaks” options on the “Options” tab in the “Make Sony Reader file” pane.

Alt+x will force a page break, and is faster than going to “Format/more transformations/insert page break after selection.”
Pictures

To insert a picture into a BD file, either go the Insert menu and select insert picture, or press F5.

The screens of the Sony, Cybook and Hanlin Readers are 600 by 800 pixels. It is a bit pointless (and a waste of space) to insert larger pictures: they can be resized in the picture menu.

Sony Reader users can also adjust the picture display in the “Make Sony Reader file” pane. Click on the “options” tab and look at the image options. This also includes a choice of colour or various greyscale options. Colour will not display on the current e-ink devices, but may render a clearer picture. But it will make for a bigger book. 256 greyscale is both clear and more compact.
Tables of Contents

HarryT has given full instructions for manually making a TOC in his Book Designer tutorial.
You can also generate an automatic TOC of all titles very easily.

1. Check that everything that you want to appear in the TOC has been marked as a title. (Go to “Tools/Element Browser” and select “titles.”
2. Click on “Format/more transformations/insert all page breaks.” 
3. To make the TOC, click on “Insert/insert TOC (all).”
4. The TOC will appear directly below the Book title. If you have subtitles or epigraphs then you can copy, cut and paste them to go above the TOC.

5. Or you can copy, cut and move the TOC.

Truncated TOCs

In the “Make Sony Reader file” pane, under the “options” tab, remember to click on the TOC option and to select “full TOC”, otherwise long titles can appear in strangely truncated forms.

Footnotes, Linking

If you want to link footnotes then there is a useful section in HarryT’s Book Designer Tutorial. Basically, open “Notes and Links” (from the Edit menu): mark the item in the text as a note, and add the endnote as a link.

A Fast Way of Linking Notes
Suppose that your notes are in the form of “[1], [2], [3]” etc.
1. Open Notes and Links (from the Edit menu).
2. Open Find and Replace (also in the Edit menu).

3. Find “[1]”. This should find the first item that you want to note. When it is highlighted, click on “Add Note”. 
4. Find “[1]” again. You should now find the first link. When it is highlighted, click on “Add link” to link it to the chosen note.”
5. Repeat for “[2]” etc.

A Very Fast Way of Linking Notes

Suppose that your notes are in the form of “[1], [2], [3]” etc.

1. Open Notes and Links (from the Edit menu).
2. Open Find and Replace (also in the Edit menu).

3. In Find and Replace, search for

\[[0-9]*\]

and click the RegExp option.

This will find all the things looking like “[1], [2], [3] etc.

4. Go through the text and just add the relevant items as either notes or links. 

(I once linked 400 notes in an hour, using this method.)
Spell-Checking

BD has the slowest spell-checker that I have ever seen. I suggest that you spell-check in Word before importing your source file. 

Tables

BD does not do tables. 
By default the tables are stripped out. 
Alternatively, under “configuration/settings” you have the option to let BD convert tables into text. You are often better off doing this in the source file.
If you have a very complex table that cannot translate into text then there is only one option in BD: make the table into a picture and insert the picture in the text at the right place.

Text Size

This can mean two things:

1. The default text size in the BD file is tiny. You can make it bigger by going to Configuration, then zoom, and adjusting the size. This has no effect at all on the final book, but is easier on the editor’s eyes.
2. You can edit the font size in a Sony Reader book. 
In the Make Sony Reader file pane, click the Styles tab and edit font sizes. 

2a.The Make Iliad file and Make Librié file allows users to set the font size too. 
2b. Mobipocket users are best off making proper PRC books (see the next section), and can often adjust font size on their devices. 
2c. There isn’t an option to edit the font size in the Make imp file (GEB 1150/2150 REB 1200) menu. 
But here is a tip from the forum. 
“The default size font is x-small for books you build in BD and they will zoom to medium. The latest file (PubUtil21.dll) can be downloaded from here and unzipped. Place in the BD installation replacing the file that is there. This change will make the default size small and the zoom size large.”
It is also possible to make a Book image file instead, which will allow for a larger font to be set.
Mobipocket Books (PRC)

BD has very poor Mobipocket/PRC support. You can just click the “Palm/Pocket PC (Prc/pdb)” option in “Make Ebooks,” or the Palm icon. But the result is apt to be a bit disappointing. Pictures do not come out at the right size, and the metadata can be dodgy. If you are just making a quick conversion of a text for your own use, this may not matter. But if you want a nice Mobipocket book, HarryT has provided detailed instructions on how to export from BD and make a book that displays properly. You can find his Mobipocket Book tutorial here:

http://www.mobileread.com/forums/showthread.php?t=17914  
The BD Toolbar Vanishes

This happens if one moves from the editor mode of BD to the Reader mode and it is very disconcerting. But just right-click and a menu appears. Select Editor mode, which is the first option. 
Should you ever actually want the Reader Mode, then you can find it on the Configuration menu.

The Pointer

RWood notes: “While the Cntl-X or ^X as the old notation would show, you have to reclick to restore the active pointer in BD when you use ^X. Other command like ^T or ^S leave the active pointer so you can continue to edit.”
Pre-Processing Text Files Before Using Book Designer: Some Resources
If you put a text file into Book Designer then you will sooner or later be annoyed by the way that paragraphs get mangled. Sometimes it renders them perfectly but a lot of errors can creep in.

 It is easy to get a flowing doc before importing the file into BD. Any of the following tools will make the job easier.
Replacing Breaks using Word

Paste the text file into a word document. Save it.

Open Find and Replace (In the “Edit” menu). You need to make three passes with it.
1. Find ^p^p (i.e. find two paragraph marks. The symbols are in More then Special. The paragraph mark is at the top of the list.). Replace with @ (These act as placeholders to preserve the real paragraphs.)
2. Now, for the second pass, find ^p (single paragraph mark). Replace with a single space.

3. Finally, for the third pass, find @ and replace with either a single paragraph mark, or two paragraph marks if you prefer an empty line between paragraphs.

Stingo’s Word Macro

This does a good job at removing the hard line breaks in text files and making a reflowable document. It also sets the font to Times New Roman, point 14. Once installed, it is very easy to use. Paste your text file into a word document. Save the Doc and run the macro.
You can find it here, together with instructions on how to install it:

http://www.mobileread.com/forums/showthread.php?t=8793 

(The only time this has ever given me trouble was when I failed to save the doc before running the macro. It crashed.)
BookCreator and Book Designer

MobileRead member =X= has produced BookCreator. This is a Word template containing a number of useful macros, which speed up the editing process. He envisages using it in connection with Calibre. However, it is entirely feasible to run the macros and then import the edited document into BD.

BookCreator is available here:

http://www.mobileread.com/forums/showthread.php?t=28313 

Textify
HarryT says, “I use a little freeware tool called “textify” to convert the text to HTML. This also does a nice job of converting underscores to italics.”
Textify is here

http://sno2.iwarp.com/ebook-faq/documents/textify.html 

and Textify 2.1 is here

http://www.felocity.org/files/gaia_textify/
(click on info to download.)

Gutenmark
Gutenmark is designed to convert Project Gutenberg text files into html. It is easy to use.

Gutenmark will reflow the text, convert caps to italics, also italicising text between underscores. Emdashes are made automatically.  It makes a fair stab at identifying chapter titles. The curly quotes need checking both before and after emdashes.

You can get Gutenmark here:

http://www.sandroid.org/GutenMark/ 
Underscores to Italics

Gutenmark and BookCreator will convert underscored text to italics. So a phrase with something _like this_ becomes a phrase with something like this. But you can also do this in Word.

Ricdiogo, a forum member who also is involved with Project Gutenberg, notes that you can use Find and Replace in the Edit menu of Word to convert underscores to italics. I quote from his post on this topic:

1. Use _(*)_ (wildcards enabled) in the “Find” field. Then place your cursor in the “Replace” field and hit the More/Format/Font and select “Italic”. Don’t type anything in that field. Then “Replace all”
2. Then, write _ in the “Find” field (wildcards disabled). Be sure you remove the formatting instructions from the “Replace” field and that you haven’t hit space bar in the field. “Replace all”.

3. If something looks wrong after you did this properly, probably the problem is that one of the _italics was not closed in the *.txt. The number of underscores in the *.txt must be a pair.”
UltraEdit
RWood find UltraEdit a very useful tool:

“Like you, I do all the editing I can outside BD. Word is a favorite although I will use UltraEdit (a straight text editor of almost unlimited power—it reminds me of my old days working on a mainframe computer.”
On the other hand, Alex believes that UltraEdit has become “bloated.”
Conclusion
I hope that this helps you work with BD. If you have any tips then let us know and I will issue a revised version of this tipsheet.
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