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  Author's note


  Screenshots in this guide are taken in Windows 10. Screen views for other operating systems may be slightly different. Also, the keys on a Mac PC may have different names to those for Windows eg the CTRL key.


  PageEdit includes a page inspector but this is not discussed in this publication.



  Introduction: What is PageEdit?


  Originally, Sigil included Book View; this allowed users to both view the appearance of an epub and edit/format its text while observing the changes made. However, it was buggy and could no longer be maintained. Consequently Book View was removed from Sigil. The standalone app, PageEdit provides similar functionality in a separate app i.e. it is not included in Sigil. However, PageEdit and Sigil can be linked so that they work together.


  PageEdit is similar to a wordprocessor in that text may be typed, copied, pasted, deleted and formatted; the effect of these changes can be seen on screen immediately. The work can then be saved to an ePub file.


  PageEdit does not replace Sigil; it works in conjunction with Sigil. Sigil is required for inserting diagrams, hyperlinks, splitting text at Page markers, inserting a table of contents, etc.


  How to Install PageEdit


  Download the file PageEdit-x.x.x-Windows-x64-Setup.exe using the recommended link provided in Mobile Forums. Double-click this file to install PageEdit.


  HINT: When upgrading PageEdit, if the PageEdit folder destination already exists, just answer the prompt about replacing existing files with (A)lways.


  How to Link PageEdit to Sigil


  1. Open Sigil and click Preferences on the Edit menu to open the Preferences dialog window.


  2. Click General settings. The last item in the dialog window is a box labelled Set your preferred external xhtml editor.


  [image: SetXhtmlEditor]


  3. Click the button marked Browse at the right of this box and browse to the file PageEdit.exe (the installation process places this program file in the folder C:\Program Files\PageEdit\).


  4. Click OK.


  How to open PageEdit in Sigil


  1. To open the currently selected xhtml section from Sigil


  PageEdit can be used to view the layout of the text and images for the currently selected xhtml section in Sigil. PageEdit can also be used to modify the text and its formatting, and will show the effect of any changes immediately.


  If the preferred external xhtml editor has been set up as in the previous section then the Sigil toolbar will include the following icon:


  [image: IconXhtmlEditor]


  Click this icon after selecting the xhtml section that is to be viewed and PageEdit will open to show this section just as it will appear in an ePub reader.


  2. To open all the xhtml sections from Sigil


  (i) Double click on content.opf in the Book Browser in Sigil:


  [image: BookBrowser]


  (ii) Click the toolbar button to Launch an External xhtml editor:


  [image: IconXhtmlEditor]


  (iii) The lower part of the toolbar in PageEdit shows a drop dpwn box with a list of all the xhtml sections from the epub. Click on this box and select the xhtml section that is to be edited.


  [image: xhtml combobox]


  



  Use the blue arrows next to the drop down box to move to the next or previous xhtml section; this is faster than opening the drop down box if you want to move to the next or previous section.


  How to Edit a document in PageEdit


  PageEdit acts like a word processor; text may be inserted via the keyboard, deleted, copied, cut or pasted.


  PageEdit provides three different ways to copy, insert or cut text:


  1. Using shortcut keys


  The standard shortcut keys can be used to copy, insert or cut text:


  Cut text: Ctrl-X


  Copy text: Ctrl-C


  Paste text: Ctrl-V


  Also, all text may be selected using the standard shortcut Ctrl-A.


  2. Using the Edit menu


  Commands for copying, inserting or cutting selected text can be found in the Edit menu.


  3. Using the toolbar


  The toolbar includes buttons for copying, inserting (pasting) or cutting selected text:


  [image: ToolbarIconCutCopy]


  There is also a button to select all text.



  Spelling checker


  PageEdit will check text as it is typed and underline in red any words that may be spelt incorrectly. PageEdit uses a dictionary to check the spelling of words and you may need to set this up for a particular language.


  How to select the language for the spell checker


  Select Preferences from the File menu or press the function key F5 to open the Preferences dialog window.


  Click General Settings to see a drop down box near the top of the dialog window marked Spellcheck Dictionary. Select the required language from this drop down box and click OK.


  [image: Spell]


  Alternatively right-click on a word to obtain a popup menu that includes Select Language. Click this option and a submenu appears with a list of languages that are available for the spell checker:


  [image: SelectLang]


  Select the required language by clicking on it.


  How to find suggested spellings to correct possible spelling errors


  When the spelling checker detects a word that is not in the dictionary it underlines that word with a red wavy line. Right-click on this word to view a list of possible spellings as illustrated:


  [image: SpellCheckPopup]


  Click on one of the listed spellings to replace the original word with this spelling.


  How to turn spell checking off (and on)


  The popup menu in the previous section shows that the option Check Spelling is ticked. To turn off spell checking click this item on the popup menu. The tick will disappear and words that the spell checker deems to be mispelt will no longer be underlined.


  To turn on spell checking, right-click a word and you will see the following popup menu:


  [image: PopUp2]


  Click on Check Spelling to switch the spelling checker on.


  How to install additional spellcheck dictionaries


  PageEdit only comes with spellcheck dictionaries for English, French, German and Spanish.


  To install additional PageEdit spellcheck dictionaries:


  1. Close all PageEdit instances and visit the Chromium hunspell_dictionaries website.


  2. Download the .bdic dictionary file for the language that you want to install. For example, it-IT-3-0.bdic for Italian.


  3. Copy it to the PageEdit qtwebengine_dictionaries folder.


  [Thanks to Doitsu for this information]


  How to format text in PageEdit


  Format a selected block of text in PageEdit either by clicking the appropriate buttons on the toolbar (described below) or by selecting the appropriate option from the Format menu or by using shortcut keys.The effect of any changes will be shown immediately in PageEdit, just like a wordprocessor.


  Style fonts


  Fonts can be styled as bold, italic, underlined, strike through, subscript and/or superscript using these six buttons:


  [image: ToolbarIconFonts]


  Alternatively, the following shortcut keys may be used:


  Ctrl-B Bold font


  Ctrl-I  Italic font


  Ctrl-U Underline font


  



  Buttons to position paragraphs (including images)


  Paragraphs may be aligned to the left, centred, the right or justified using these four buttons:


  [image: ToolbarIconPos]


  Alternatively, the following shortcut keys may be used:



  Ctrl-E Centre paragraph


  Ctrl-J Justify paragraph


  Buttons for bullets and numbering


  Paragraphs can start with bullet points or numbers using these two buttons:


  [image: ToolbarIconNumber]


  If numbering is applied to several paragraphs that have been selected then those paragraphs will be numbered sequentially.


  Alternatively, the following shortcut keys may be used:



  Ctrl-Shift-L Bullet list


  Buttons to indent paragraphs


  The indentation of paragraphs can be increased or decreased using these two buttons:


  [image: ToolbarIconIndent]


  How to set the heading level


  New paragraphs in PageEdit are assigned the heading level normal (ie <p>....</p>) by default. The heading level can be changed by clicking the button on the toolbar marked h+ and then selecting the required heading level from the drop down list that appears:


  [image: ToolbarIconHeading]


  How to undo and redo recent changes


  PageEdit provides three ways to undo (and redo) recent changes made to an epub:


  1. Using shortcut keys


  The standard shortcut keys can be used to undo (or redo) changes:


  Undo changes: Ctrl-Z


  Redo changes: Ctrl-Y



  2. Using the Edit menu


  Commands for undoing (or redoing) recent changes can be found in the Edit menu.


  3. Using the toolbar


  The toolbar includes buttons for undoing or redoing recent changes:


  [image: ToolbarIconUndoChange]


  How to insert special characters in a document


  PageEdit provides two ways to open a dialog for inserting special characters such as ©, ½ and ÷:



  1. Using the Insert menu


  Select Special character... from the Edit menu.


  2. Using the toolbar


  Like Sigil, the toolbar in PageEdit includes a button with an omega symbol to insert special characters:


  [image: ToolbarIconOmega]


  Either method opens a dialog that contains special symbols:


  [image: dlgSpecialChars]


  To insert one or more of these special characters place the cursor at the insertion point for the special symbol. Open the dialog and then click a character to insert the character in the document. Insert more characters after the first one by clicking additional characters if required. After clicking the required character(s), close the dialog box by clicking its close button (the 'X' at the top right hand side).


  


  How to insert the Sigil Split Marker



  A page of text can be split into separate xhtml sections in Sigil. Page edit provides two ways for inserting a special marker at the cursor where text is to be split into two xhtml sections:


  1. Using shortcut keys


  


  Press Ctrl-Shift-Return to insert a Split Marker at the point.


  2. Using the Insert menu


  The Insert menu contains the command Split Marker for inserting a special marker to split the text.


  PageEdit displays a horizontal line at the point where the split in the text will be made. 


  You cannot split the text in PageEdit; this must be done in Sigil by saving the changes in PageEdit so that the work is transferred to Sigil, closing PageEdit and then using one of the methods provided in Sigil to split the text eg press function key F6.


  How to find specified text


  PageEdit provides three ways to find text in the epub. 


  1. Using shortcut keys


  Press Ctrl-F to find text.


  2. Using the Find menu


  The Find menu contains the command Find for finding text.


  3. Using the toolbar


  The toolbar includes buttons for finding text:


  [image: ToolbarIconFind]


  When you search for text, a Search box appears below the toolbar:


  

  [image: Search]

  


  


  


  Enter the text to find in the box marked Search. To find text in the epub that matches the case of the text in the Search box click the button Match Case. This button will have the appearance of being pressed in when set to match case, otherwise this button will have the appearance of not being pressed in. The appearance of the button (and case matching) can be toggled by clicking it.


  Text in the epub that matches the text in the Search box will be highlighted in yellow. One of the matches in the epub will be highlighted in brown. To go to the next match in the epub click the arrow in the green circle that points downward; to go to the previous match in the epub click the arrow in the green circle that points upward. The next piece of text that is found will be highlighted in brown.


  Lines will appear on the scroll bar to indicate the approximate position of matches found:


  [image: ScrollBarLines]


  Searches are wrapped i.e. clicking  the arrow in the green circle that points downward when the last piece of matching text is found in the epub the first piece of matching text in the epub will be highlighted.


  Click the cross in the red box to close the Search box.


  Using hyperlinks in PageEdit


  Although PageEdit does not provide a facility for inserting, amending or deleting hypelinks, clicking on a hyperlink will cause PageEdit to jump to the relevant section if Preview mode is selected.


  To select preview mode, click on the button:


  [image: IconXhtmlEditor]


  The image on this button will change to that of a book to show that PageEdit is in preview mode:


  [image: PreviewMode]


  Clicking on hyperlinks while in this mode will take you to the relevant page.


  To change back to edit mode, click the button that shows the image of a book. The image on the button reverts to its original appearance to show that PageEdit is in Edit mode.


  How to return to the previously clicked link


  Return to the previously clicked link by clicking on the yellow arrow in the toolbar.


  [image: YellowArrow]


  



  Possible error


  If you see a message box asking whether you really want to open 'this file' in your browser this is because you have not opened all the xhtml files from Sigil in PageEdit. See the section To open all the xhtml sections from Sigil to find out how to do this.


  Saving changes to an epub


  PageEdit provides three ways to save changes made to an epub:


  1. Using shortcut keys


  Press Ctrl-S to save the epub to the currently opened epub file.


  2. Using the File menu


  The File menu has two commands for saving work:


  	Save - save the epub to the current file



  	Save as - save the epub to an xhtml file. This key combination opens the file dialog to enable a different path and/or filename to be entered for the xhtml file.


  


  3. Using the toolbar


  Changes to an epub can be saved to the current file using the toolbar button:


  [image: ToolbarIconSave]


  Saving work as an xhtml file


  Work in PageEdit can be saved as an xhtml file. PageEdit provides three ways to save work as an xhtml file:


  1. Using shortcut keys


  Press Ctrl-Shift-S to save the work to an xhtml file. This key combination opens the file dialog to enable a different path and/or filename to be entered for saving the work as an xhtml file.


  2. Using the File menu


  Select Save as from the File menu. This key combination opens the file dialog to enable a different path and/or filename to be entered for saving the work as an xhtml file.


  Saving changes in Sigil and PageEdit


  Sometimes it is necessary to do some edits in Sigil eg to insert diagrams, change css settings, insert a table of contents, split text at markers, etc. There may therefore be a need to swap back and forth between Sigil and PageEdit when editing/formatting text. What follows comes from the author's experience of using these two apps when PageEdit is opened via Sigil.


  1. When saving work to the current file in PageEdit the work will be transferred to Sigil. Therefore there is no need to reopen the saved file in Sigil if, for example, a diagram is to be inserted in the text using Sigil after carrying out some edits in PageEdit.


  2. However, any changes made in Sigil are not copied across to PageEdit, even if the work is saved to the current file in Sigil. The following procedure is suggested when needing to switch to Sigil for, eg, inserting diagrams.


  (i) Save the work in PageEdit to the current file.


  (ii) Close PageEdit.


  (iii) Make the changes in Sigil and save the work to the current file.


  (iv) Open PageEdit via Sigil to continue working in PageEdit.


  Opening an existing xhtml file


  PageEdit provides three ways to open an xhtml file. Each of these opens the normal file dialog box:


  1. Using shortcut keys


  Press Ctrl-O to open the file dialog box.


  2. Using the File menu


  Select Open from the File menu.


  3. Using the toolbar


  Click the toolbar button that resembles a folder:


  [image: ToolbarIconOpen]
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