Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Readers > Amazon Kindle > Kindle Developer's Corner

Notices

Reply
 
Thread Tools Search this Thread
Old 06-17-2010, 04:27 AM   #1
wisery
Junior Member
wisery began at the beginning.
 
Posts: 2
Karma: 10
Join Date: Jun 2010
Device: kindle
K2I:2.5.2 upgrade browser_prefs checksum failure

During the 2.5.2 upgrade processing, there is a error in phase 1 of "browser_prefs checksum failure".
Does anyone have succeeded in upgrading the kindle 2 international from 2.3.4 to 2.5.2, and can share your this file to me: browser_prefs
the path is : /opt/amazon/ebook/config/browser_prefs

Thanks a lot!

ps: this file's version should be 2.3.4, before upgraded to 2.5.2.

Last edited by wisery; 06-17-2010 at 04:47 AM.
wisery is offline   Reply With Quote
Old 06-20-2010, 06:30 AM   #2
freezer2k
Enthusiast
freezer2k doesn't litterfreezer2k doesn't litter
 
Posts: 38
Karma: 154
Join Date: Dec 2009
Device: Kindle 2 intl.
My upgrade from 2.3.4 to 2.5.2 also fails, where do i check which file(s) have the wrong checksum?

Do i need to have the usbnetwork hack installed?
freezer2k is offline   Reply With Quote
Old 06-20-2010, 08:45 PM   #3
wisery
Junior Member
wisery began at the beginning.
 
Posts: 2
Karma: 10
Join Date: Jun 2010
Device: kindle
Quote:
Originally Posted by freezer2k View Post
My upgrade from 2.3.4 to 2.5.2 also fails, where do i check which file(s) have the wrong checksum?

Do i need to have the usbnetwork hack installed?
yes, you should install usbnetwork, and input the following command lines on your kindle:
;debugOn
;dumpMessages

If your failure is not because of the "browser_prefs", maybe you can share the file to us.

Last edited by wisery; 06-20-2010 at 08:48 PM.
wisery is offline   Reply With Quote
Old 06-23-2010, 12:29 AM   #4
mopaston
Junior Member
mopaston began at the beginning.
 
Posts: 6
Karma: 10
Join Date: Jun 2010
Device: Kindle 2I
I got my new k2i several days ago, with 2.3.3 firmware pre-installed.
I downloaded 2.5.2 update package from Amazon website and tried to update it manually, but the updating process stopped at "stage 1 of 3" with error code U006, after reboot, the firmware version became 2.3.4.
I didn't install any hacks before update, totally untouched.
After that, by enabling debug mode and dumping messages, I found the error line:
ota_install: C defatchatchinfo="/opt/amazon/ebook/config/browser_prefs":checksum failure
Because I didn't modify the file at all, there should have no conflicts between them.
I tried again and again(including reset to the factory defaults), nothing changed, same error.

I have no idea why 2.5.2 update can't accept files from its own.

Have you guys figured out the solution? Dose replacing the browser_prefs file works?
mopaston is offline   Reply With Quote
Old 06-26-2010, 01:58 AM   #5
freezer2k
Enthusiast
freezer2k doesn't litterfreezer2k doesn't litter
 
Posts: 38
Karma: 154
Join Date: Dec 2009
Device: Kindle 2 intl.
Have you guys tried the version out of

http://www.avenard.org/kindle2/root.2.2.1.img.bz2

It might be too old, but worth a shot!


I'm about to install usbnetwork it will try it myself later...
freezer2k is offline   Reply With Quote
Old 06-26-2010, 03:11 AM   #6
freezer2k
Enthusiast
freezer2k doesn't litterfreezer2k doesn't litter
 
Posts: 38
Karma: 154
Join Date: Dec 2009
Device: Kindle 2 intl.
Okay,

Here is what I got (UPDATE Log 2.3.4 ---> 2.5.2):


100615:041402 ota_install: C defatchatchinfo="/opt/amazon/ebook/config/framework.mario.conf":checksum failure
100615:041402 ota_install: I defatch:current_md5=aa884eb0797fb1ff8f441b3afef6 1c40,expected_md5=4e0e386401fe76120f5058343ae2254d ,patch_md5=84f8cf0a54777f221e00171b3e0b55bb:checks um verify


I remember i was playing with the proxy settings, and forgot to make a backup


On the other hand, good news for you guys:


100615:041402 ota_install: I defatchatchinfo="/opt/amazon/ebook/config/browser_prefs"atching file

No error on the browser_prefs file.

I put a copy of the file here:

http://www.uploadmb.com/dw.php?id=1277536052


So before you try your Update to 2.5.2 it would be VERY helpful, if you could fetch a copy of your 2.3.4 Version of

/opt/amazon/ebook/config/framework.mario.conf


Thanks a lot!
freezer2k is offline   Reply With Quote
Old 06-28-2010, 01:18 PM   #7
mopaston
Junior Member
mopaston began at the beginning.
 
Posts: 6
Karma: 10
Join Date: Jun 2010
Device: Kindle 2I
I have updated to 2.5.2 from 2.3.4 successfully, got browser_prefs error first, then framework.mario.conf, what you need is here, grab it and enjoy update.

http://www.easy-share.com/1911099807...(2.3.3K2I).rar
mopaston is offline   Reply With Quote
Old 06-29-2010, 12:37 AM   #8
freezer2k
Enthusiast
freezer2k doesn't litterfreezer2k doesn't litter
 
Posts: 38
Karma: 154
Join Date: Dec 2009
Device: Kindle 2 intl.
Hi,

Glad it worked for you!

Did you get the framework.mario.conf error too?


I ran a MD5 on the file you uploaded: d3987bd2c0b31ef8b888ae86cd728bf4 *framework.mario.conf

Seems like it has the wrong checksum for update from 2.3.4 --> 2.5.2

My error msg (see earlier post) expects a checksum of 4e0e386401fe76120f5058343ae2254d

I might try the update anyway, but don't have high hopes because of this.


Maybe anyone else here has a version of framework.mario.conf with the right checksum?
freezer2k is offline   Reply With Quote
Old 06-29-2010, 03:08 AM   #9
mopaston
Junior Member
mopaston began at the beginning.
 
Posts: 6
Karma: 10
Join Date: Jun 2010
Device: Kindle 2I
Hi freezer2k,
Yes I got the error too and the file I posted works for me, it was dumped from 2.3.3K2I. You should backup your file and give it a try.

BTW. the MD5 expected does not mean the original file before update, it means the MD5 checksum is expected after patched.

Good luck.
mopaston is offline   Reply With Quote
Old 06-29-2010, 03:53 AM   #10
freezer2k
Enthusiast
freezer2k doesn't litterfreezer2k doesn't litter
 
Posts: 38
Karma: 154
Join Date: Dec 2009
Device: Kindle 2 intl.
Thanks man!

I just tried the update with the file and now I'm on 2.5.2 too!
freezer2k is offline   Reply With Quote
Old 06-29-2010, 11:26 AM   #11
mopaston
Junior Member
mopaston began at the beginning.
 
Posts: 6
Karma: 10
Join Date: Jun 2010
Device: Kindle 2I
Smile

Quote:
Originally Posted by freezer2k View Post
Thanks man!

I just tried the update with the file and now I'm on 2.5.2 too!
You're welcome, glad it works for you, enjoy.
mopaston is offline   Reply With Quote
Reply

Tags
kindle 2 upgrade

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fiddling with proxy settings in /opt/amazon/ebook/config/browser_prefs YYZscientist Kindle Developer's Corner 5 11-17-2010 09:49 PM
Kobo1.4 firmware upgrade failure Marcels Kobo Reader 20 07-31-2010 01:10 AM
Kindle 2 update fails due to checksum failure at libTopaz.so file?? Opus Kindle Developer's Corner 1 06-02-2010 11:15 AM
500 Upgrade Failure RSaunders Sony Reader 14 01-16-2010 01:22 AM
505 upgrade with PRS-Plus v.9b FAILURE jeshule Sony Reader 1 12-28-2009 10:39 AM


All times are GMT -4. The time now is 08:58 PM.


MobileRead.com is a privately owned, operated and funded community.