Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre

Notices

Reply
 
Thread Tools Search this Thread
Old 06-26-2010, 11:42 AM   #1
lmamakos
Member
lmamakos began at the beginning.
 
Posts: 11
Karma: 10
Join Date: Dec 2009
Device: PRS-600
Bug in calibre 0.7.5 on Mac related to iTunes

I upgraded calibre on my fancy iMac and noticed that it wasn't detected my Sony PRS-600 device (which has previously worked just fine.) After some amount of poking around, it seems to be related to iTunes running or not when I start calibre. I ran calibre-debug in the two circumstances which might shed some light on the issue.

Here's what happens when iTunes is already running:

Code:
louie@lmamakos-iMac[28] $ ./calibre-debug -d
Version: 0.7.5
USB devices on system:
[['0x5acL',
  '0x8006L',
  '0x200L',
  u'Apple Inc.',
  u'EHCI Root Hub Simulation',
  u''],
 ['0x424L', '0x2514L', '0x3L', u'', u'', u''],
 ['0x5acL', '0x8242L', '0x16L', u'Apple Computer, Inc.', u'IR Receiver', u''],
 ['0x5acL',
  '0x8502L',
  '0x230L',
  u'Apple Inc.',
  u'Built-in iSight',
  u'8JA1S2L5N77J3L00'],
 ['0x46dL', '0xc50eL', '0x2510L', u'Logitech', u'USB RECEIVER', u''],
 ['0x152dL',
  '0x2336L',
  '0x100L',
  u'JMicron',
  u'JM20336 SATA, USB Combo',
  u'519D88888888'],
 ['0x5acL',
  '0x8006L',
  '0x200L',
  u'Apple Inc.',
  u'EHCI Root Hub Simulation',
  u''],
 ['0x424L', '0x2514L', '0x3L', u'', u'', u''],
 ['0xa5cL', '0x4500L', '0x100L', u'Apple Inc.', u'BRCM2046 Hub', u''],
 ['0x5acL',
  '0x8403L',
  '0x9833L',
  u'Apple',
  u'Internal Memory Card Reader',
  u'000000009833'],
 ['0x5e3L', '0x607L', '0x805L', u'', u'USB2.0 Hub', u''],
 ['0x5acL',
  '0x8215L',
  '0x182L',
  u'Apple Inc.',
  u'Bluetooth USB Host Controller',
  u'7C6D62928E9D'],
 ['0x5e3L', '0x607L', '0x805L', u'', u'USB2.0 Hub', u''],
 ['0x4a9L', '0x1735L', '0x105L', u'Canon', u'MX860 series', u'120633'],
 ['0x56aL', '0xd4L', '0x106L', u'Wacom Co.,Ltd.', u'CTL-460', u''],
 ['0x424L', '0x2502L', '0x1L', u'', u'', u''],
 ['0x424L', '0x2504L', '0x1L', u'', u'', u''],
 ['0x424L', '0x223aL', '0x360L', u'SMSC', u'USB2223', u'000223223223'],
 ['0x5e3L', '0x608L', '0x901L', u'', u'USB2.0 Hub', u''],
 ['0x152dL',
  '0x2329L',
  '0x100L',
  u'JMicron',
  u'USB to ATA/ATAPI Bridge',
  u'152D20329000'],
 ['0x5e3L', '0x722L', '0x9802L', u'Generic', u'USB Storage', u'000000009802'],
 ['0x5acL',
  '0x1292L',
  '0x1L',
  u'Apple Inc.',
  u'iPhone',
  u'd169811e684d8fea23de50a1ab16548546904ade'],
 ['0x54cL',
  '0x31eL',
  '0x31aL',
  u'Sony',
  u'Sony Digital Book Reader',
  u'0800461000C21E1B']]
Looking for ALEX
Looking for ANDROID
Looking for AVANT
Looking for AZBOOKA
Looking for BLACKBERRY
Looking for BOOQ
Looking for BOOX
Looking for COOL_ER
Looking for CYBOOK
Looking for DBOOK
Looking for E71X
Looking for EB511
Looking for EB600
Looking for EBK52
Looking for ECLICTO
Looking for EDGE
Looking for ELONEX
Looking for ESLICK
Looking for FOLDER_DEVICE_FOR_CONFIG
Looking for GER2
Looking for HANLINV3
Looking for HANLINV5
Looking for INVESBOOK
Looking for IPAPYRUS
Looking for IREXDR1000
Looking for IREXDR800
Looking for IRIVER_STORY
Looking for ITALICA
Looking for ITUNES
	(1452L, 4754L, 1L, u'Apple Inc.', u'iPhone', u'd169811e684d8fea23de50a1ab16548546904ade')
ITUNES.can_handle()
 ITUNES:_launch_iTunes():
  Instantiating iTunes
2010-06-26 11:14:53.274 defaults[5906:60f] 
The domain/default pair of (com.apple.itunes, NSNavLastRootDirectory) does not exist
  could not confirm valid iTunes.media_dir from com.apple.itunes
  media_dir: 
  calibre 0.7.5
  [OSX iTunes - 9.2 (already running), driver version 0.8.0]
  iTunes_media: None
 ITUNES._discover_manual_sync_mode()
   book_playlist not found
Python function terminated unexpectedly: object of type 'NoneType' has no len()
Traceback (most recent call last):
  File "/Apps/calibre.app/Contents/Resources/Python/lib/python2.6/site.py", line 147, in main
    return run_entry_point()
  File "/Apps/calibre.app/Contents/Resources/Python/lib/python2.6/site.py", line 116, in run_entry_point
    return getattr(pmod, func)()
  File "site-packages/calibre/debug.py", line 155, in main
  File "site-packages/calibre/debug.py", line 106, in debug_device_driver
  File "site-packages/calibre/devices/__init__.py", line 101, in debug
  File "site-packages/calibre/devices/scanner.py", line 161, in is_device_connected
  File "site-packages/calibre/devices/interface.py", line 151, in is_usb_connected
  File "site-packages/calibre/devices/apple/driver.py", line 430, in can_handle
  File "site-packages/calibre/devices/apple/driver.py", line 1271, in _discover_manual_sync_mode
TypeError: object of type 'NoneType' has no len()
louie@lmamakos-iMac[29] $
If I quit the iTunes application, and re-run calibre-debug, I seem to get something that works. I notice during this process that iTunes gets launched and then the window is minimized or closed.

Code:
louie@lmamakos-iMac[29] $ ./calibre-debug -d
Version: 0.7.5
USB devices on system:
[['0x5acL',
  '0x8006L',
  '0x200L',
  u'Apple Inc.',
  u'EHCI Root Hub Simulation',
  u''],
 ['0x424L', '0x2514L', '0x3L', u'', u'', u''],
 ['0x5acL', '0x8242L', '0x16L', u'Apple Computer, Inc.', u'IR Receiver', u''],
 ['0x5acL',
  '0x8502L',
  '0x230L',
  u'Apple Inc.',
  u'Built-in iSight',
  u'8JA1S2L5N77J3L00'],
 ['0x46dL', '0xc50eL', '0x2510L', u'Logitech', u'USB RECEIVER', u''],
 ['0x152dL',
  '0x2336L',
  '0x100L',
  u'JMicron',
  u'JM20336 SATA, USB Combo',
  u'519D88888888'],
 ['0x5acL',
  '0x8006L',
  '0x200L',
  u'Apple Inc.',
  u'EHCI Root Hub Simulation',
  u''],
 ['0x424L', '0x2514L', '0x3L', u'', u'', u''],
 ['0xa5cL', '0x4500L', '0x100L', u'Apple Inc.', u'BRCM2046 Hub', u''],
 ['0x5acL',
  '0x8403L',
  '0x9833L',
  u'Apple',
  u'Internal Memory Card Reader',
  u'000000009833'],
 ['0x5e3L', '0x607L', '0x805L', u'', u'USB2.0 Hub', u''],
 ['0x5acL',
  '0x8215L',
  '0x182L',
  u'Apple Inc.',
  u'Bluetooth USB Host Controller',
  u'7C6D62928E9D'],
 ['0x5e3L', '0x607L', '0x805L', u'', u'USB2.0 Hub', u''],
 ['0x4a9L', '0x1735L', '0x105L', u'Canon', u'MX860 series', u'120633'],
 ['0x56aL', '0xd4L', '0x106L', u'Wacom Co.,Ltd.', u'CTL-460', u''],
 ['0x424L', '0x2502L', '0x1L', u'', u'', u''],
 ['0x424L', '0x2504L', '0x1L', u'', u'', u''],
 ['0x424L', '0x223aL', '0x360L', u'SMSC', u'USB2223', u'000223223223'],
 ['0x5e3L', '0x608L', '0x901L', u'', u'USB2.0 Hub', u''],
 ['0x152dL',
  '0x2329L',
  '0x100L',
  u'JMicron',
  u'USB to ATA/ATAPI Bridge',
  u'152D20329000'],
 ['0x5e3L', '0x722L', '0x9802L', u'Generic', u'USB Storage', u'000000009802'],
 ['0x5acL',
  '0x1292L',
  '0x1L',
  u'Apple Inc.',
  u'iPhone',
  u'd169811e684d8fea23de50a1ab16548546904ade'],
 ['0x54cL',
  '0x31eL',
  '0x31aL',
  u'Sony',
  u'Sony Digital Book Reader',
  u'0800461000C21E1B']]
Looking for ALEX
Looking for ANDROID
Looking for AVANT
Looking for AZBOOKA
Looking for BLACKBERRY
Looking for BOOQ
Looking for BOOX
Looking for COOL_ER
Looking for CYBOOK
Looking for DBOOK
Looking for E71X
Looking for EB511
Looking for EB600
Looking for EBK52
Looking for ECLICTO
Looking for EDGE
Looking for ELONEX
Looking for ESLICK
Looking for FOLDER_DEVICE_FOR_CONFIG
Looking for GER2
Looking for HANLINV3
Looking for HANLINV5
Looking for INVESBOOK
Looking for IPAPYRUS
Looking for IREXDR1000
Looking for IREXDR800
Looking for IRIVER_STORY
Looking for ITALICA
Looking for ITUNES
	(1452L, 4754L, 1L, u'Apple Inc.', u'iPhone', u'd169811e684d8fea23de50a1ab16548546904ade')
ITUNES.can_handle()
 ITUNES:_launch_iTunes():
  Instantiating iTunes
ITUNES:_launch_iTunes(): Launching iTunes
2010-06-26 11:16:19.312 defaults[5925:60f] 
The domain/default pair of (com.apple.itunes, NSNavLastRootDirectory) does not exist
  could not confirm valid iTunes.media_dir from com.apple.itunes
  media_dir: 
  calibre 0.7.5
  [OSX iTunes - 9.2 (launched), driver version 0.8.0]
  iTunes_media: None
 waiting for connected iPad, attempt #2
 waiting for connected iPad, attempt #3
 waiting for connected iPad, attempt #4
 waiting for connected iPad, attempt #5
 waiting for connected iPad, attempt #6
 waiting for connected iPad, attempt #7
 waiting for connected iPad, attempt #8
 waiting for connected iPad, attempt #9
 waiting for connected iPad, attempt #10
 self.ejected = True
Looking for JETBOOK
Looking for KINDLE
Looking for KINDLE2
Looking for KINDLE_DX
Looking for KOBO
Looking for MENTOR
Looking for N516
Looking for N770
Looking for N810
Looking for NEWSMY
Looking for NOOK
Looking for NUUT2
Looking for PALMPRE
Looking for POCKETBOOK301
Looking for POCKETBOOK360
Looking for PRS505
	(1356L, 798L, 794L, u'Sony', u'Sony Digital Book Reader', u'0800461000C21E1B')
Looking for README
Looking for S60
Looking for SHINEBOOK
Looking for SNE
Looking for TECLAST_K3
Looking for THEBOOK
Devices possibly connected: SONY Device Interface,  
Trying to open SONY Device Interface ... OK
Main memory: '/Volumes/READER/'
Total space: (410689536L, 2059010048L, 0)
 
Dont forget to send the contents of /tmp/ioreg.txt
You can open it with the command: open /tmp/ioreg.txt
louie@lmamakos-iMac[30] $
I can seeming use Calibre with success if I remember to exit iTunes before launching. It would be nice to avoid launching itunes just to probe for the iPad that I don't own and speed up the Sony device detection.

Hope this is helpful!
lmamakos is offline   Reply With Quote
Old 06-26-2010, 11:54 AM   #2
Elnino
Junior Member
Elnino began at the beginning.
 
Posts: 8
Karma: 10
Join Date: Jul 2008
Device: Sony PRS-505
I have the same problem with Windows 7 and my Sony 505. When I start Calibre it is automatically launching Itunes and my device isn't detected in Calibre.
Elnino is offline   Reply With Quote
Old 06-26-2010, 11:55 AM   #3
GRiker
Comparer of the Ephemeris
GRiker ought to be getting tired of karma fortunes by now.GRiker ought to be getting tired of karma fortunes by now.GRiker ought to be getting tired of karma fortunes by now.GRiker ought to be getting tired of karma fortunes by now.GRiker ought to be getting tired of karma fortunes by now.GRiker ought to be getting tired of karma fortunes by now.GRiker ought to be getting tired of karma fortunes by now.GRiker ought to be getting tired of karma fortunes by now.GRiker ought to be getting tired of karma fortunes by now.GRiker ought to be getting tired of karma fortunes by now.GRiker ought to be getting tired of karma fortunes by now.
 
Posts: 1,497
Karma: 424627
Join Date: Mar 2009
Device: iPad
@Imamakos: You have an iPhone plugged in, which is a recognized iDevice.

If you don't want calibre to detect your iPhone as a Reader, you can disable the Apple driver in Preference|Plugins|Device interface plugins.

More information available on the 0.7.5 updates in 'Calibre 0.7 + iPad: Start here'.

G
GRiker is offline   Reply With Quote
Old 06-26-2010, 03:16 PM   #4
Elnino
Junior Member
Elnino began at the beginning.
 
Posts: 8
Karma: 10
Join Date: Jul 2008
Device: Sony PRS-505
GRiker - thanks that fix worked for me as well as I was charging my Iphone.
Elnino is offline   Reply With Quote
Old 06-26-2010, 07:55 PM   #5
lmamakos
Member
lmamakos began at the beginning.
 
Posts: 11
Karma: 10
Join Date: Dec 2009
Device: PRS-600
Yes, an iPhone is plugged in, but you'll note that at least calibre-test fails with an error. When I run Calibre it doesn't find any devices, including the Sony.
lmamakos is offline   Reply With Quote
Old 06-26-2010, 09:07 PM   #6
GRiker
Comparer of the Ephemeris
GRiker ought to be getting tired of karma fortunes by now.GRiker ought to be getting tired of karma fortunes by now.GRiker ought to be getting tired of karma fortunes by now.GRiker ought to be getting tired of karma fortunes by now.GRiker ought to be getting tired of karma fortunes by now.GRiker ought to be getting tired of karma fortunes by now.GRiker ought to be getting tired of karma fortunes by now.GRiker ought to be getting tired of karma fortunes by now.GRiker ought to be getting tired of karma fortunes by now.GRiker ought to be getting tired of karma fortunes by now.GRiker ought to be getting tired of karma fortunes by now.
 
Posts: 1,497
Karma: 424627
Join Date: Mar 2009
Device: iPad
The reason you're not seeing any devices is that your iPhone is still physically connected to your computer while charging, but ejected from iTunes. It's still detected as a physical USB device on the bus, even though you ejected it in iTunes. Calibre sees it and tries to mount it as a device, but fails because it's been ejected.

If you want to see your iPhone in calibre, physically disconnect the iPhone from the computer, then reconnect and run calibre again. If you want to see your Sony, follow the directions I supplied earlier to disable the apple driver, or run calibre with the iPhone physically disconnected. If you want learn more about the apple driver, see the 'Calibre + iPad: Start here' thread.

G
GRiker is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Little Things That Bug Me about the Desktop iTunes App Store kjk Apple Devices 10 07-12-2010 06:14 PM
Cover Browser (related) bug (0.7.3) Stinger Calibre 5 06-19-2010 07:30 PM
Bug (?) related to polish (non-ascii) chars parasit Calibre 8 05-30-2009 03:55 PM


All times are GMT -4. The time now is 02:14 AM.


MobileRead.com is a privately owned, operated and funded community.