Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre

Notices

Reply
 
Thread Tools Search this Thread
Old 04-18-2011, 09:50 AM   #1
prashc
Junior Member
prashc began at the beginning.
 
Posts: 1
Karma: 10
Join Date: Apr 2011
Device: none
Unable to install Calibre 0.7.56 from source

Hi..

We have a shared-desktop server running Debian Lenny. An upgrade to Squeeze is not possible anytime soon so installing Calibre from the Debian repo is not an option.
I'm trying to install Calibre 0.7.56 from source. Since many packages required by Calibre are not available/were in conflict with existing packages on our server running Lenny, I installed all of the dependencies manually, from source, taking care to match the versions with the minimum listed on the calibre site. The installation completed successfully, terminating with a 'calibre successfully installed. You can start it by running the command calibre' message, but upon launching calibre, I get hit with the following error traceback. Incidentally, I get the exact same error with calibre 0.7.54, 0.7.55 and 0.7.56. Any help would be greatly appreciated. I'm using SIP version 4.12.1.


Traceback (most recent call last):
File "/opt/python-2.7.1/bin/calibre", line 19, in <module>
sys.exit(main())
File "/opt/python-2.7.1/lib/calibre/calibre/gui2/main.py", line 362, in main
app, opts, args, actions = init_qt(args)
File "/opt/python-2.7.1/lib/calibre/calibre/gui2/main.py", line 43, in init_qt
from calibre.gui2.ui import Main
File "/opt/python-2.7.1/lib/calibre/calibre/gui2/ui.py", line 39, in <module>
from calibre.gui2.init import LibraryViewMixin, LayoutMixin
File "/opt/python-2.7.1/lib/calibre/calibre/gui2/init.py", line 17, in <module>
from calibre.gui2.library.views import BooksView, DeviceBooksView
File "/opt/python-2.7.1/lib/calibre/calibre/gui2/library/views.py", line 15, in <module>
from calibre.gui2.library.delegates import RatingDelegate, PubDateDelegate, \
File "/opt/python-2.7.1/lib/calibre/calibre/gui2/library/delegates.py", line 27, in <module>
class RatingDelegate(QStyledItemDelegate): # {{{
File "/opt/python-2.7.1/lib/calibre/calibre/gui2/library/delegates.py", line 28, in RatingDelegate
COLOR = QColor("blue")
TypeError: unable to convert a Python 'str' object to a C++ 'QString' instance
prashc is offline   Reply With Quote
Old 04-18-2011, 10:39 AM   #2
theducks
Grand Sorcerer
theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.
 
theducks's Avatar
 
Posts: 15,093
Karma: 5939999
Join Date: Aug 2009
Location: (The original) Silicon Valley, USA
Device: Galaxy Tab 2, Astak Pocket Pro, K4NT
Moderator Notice
Not a device question. Moved to main
theducks is offline   Reply With Quote
Old 04-18-2011, 10:42 AM   #3
chaley
"chaley", not "charley"
chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.
 
Posts: 5,802
Karma: 1216080
Join Date: Jan 2010
Location: France
Device: Many android devices
I tried to install calibre on Lenny and failed miserably. The libraries are too old, and getting everything from backports wasn't possible. Installing upgraded versions of some libraries, in particular glibc, hosed my system.

I did succeed using a chroot'ed jail, where I could add the necessary libraries. This post describes what I did. I never attempted to run the GUI, so there is likely more work to do.
chaley is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to install Calibre 0.07.40 hombre Calibre 1 01-16-2011 08:32 AM
Unable to install Calibre angb37 Calibre 3 07-12-2009 03:52 AM
Unable to install calibre 0.5.6. on windows Vista SP1 kiklop74 Calibre 4 04-10-2009 05:59 PM
Also unable to install calibre Emi801 Calibre 2 10-03-2008 03:19 PM
Unable to install Calibre orien Calibre 3 08-03-2008 02:22 AM


All times are GMT -4. The time now is 07:39 PM.


MobileRead.com is a privately owned, operated and funded community.