Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre

Notices

Reply
 
Thread Tools Search this Thread
Old 06-05-2010, 06:27 AM   #1
grizedale
NEXUS 7
grizedale shares his or her toysgrizedale shares his or her toysgrizedale shares his or her toysgrizedale shares his or her toysgrizedale shares his or her toysgrizedale shares his or her toysgrizedale shares his or her toysgrizedale shares his or her toysgrizedale shares his or her toysgrizedale shares his or her toysgrizedale shares his or her toys
 
Posts: 167
Karma: 5628
Join Date: May 2010
Location: UK, County Durham
Device: NEXUS 7 & PW2
Calibre 0.7 and PRS-300

A few observations, updated to 0.7 this morning and found that

I. Would not now allow me to save to disc from device, it goes through the motions but the book does not appear, no matter which option I choose.

II. When a book has been transferred to device and I unplug, the length of loading time has been greatly extended, has gone from a seconds to at least a minute. No great hardship I know but just wondering why.

Because of the above I have reverted back to 0.6.55 and all the above issues have gone away.


Windows 7 64bit, 4G Ram

Last edited by grizedale; 06-05-2010 at 06:48 AM.
grizedale is offline   Reply With Quote
Old 06-05-2010, 07:06 AM   #2
DoctorOhh
US Navy, Retired
DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.
 
DoctorOhh's Avatar
 
Posts: 8,908
Karma: 12755553
Join Date: Feb 2009
Location: North Carolina
Device: Nexus 7
Quote:
Originally Posted by grizedale View Post
A few observations, updated to 0.7 this morning and found that

I. Would not now allow me to save to disc from device, it goes through the motions but the book does not appear, no matter which option I choose.

II. When a book has been transferred to device and I unplug, the length of loading time has been greatly extended, has gone from a seconds to at least a minute. No great hardship I know but just wondering why.

Because of the above I have reverted back to 0.6.55 and all the above issues have gone away.


Windows 7 64bit, 4G Ram
The new version cached all the books (metadata) on your reader to a file on your reader. I would just have done a shutdown via the menu then turn it back on fresh and let it go through its start sequence. That might clear the cobwebs out and give it new life.
DoctorOhh is offline   Reply With Quote
 
Advertisement
Old 06-05-2010, 07:28 AM   #3
grizedale
NEXUS 7
grizedale shares his or her toysgrizedale shares his or her toysgrizedale shares his or her toysgrizedale shares his or her toysgrizedale shares his or her toysgrizedale shares his or her toysgrizedale shares his or her toysgrizedale shares his or her toysgrizedale shares his or her toysgrizedale shares his or her toysgrizedale shares his or her toys
 
Posts: 167
Karma: 5628
Join Date: May 2010
Location: UK, County Durham
Device: NEXUS 7 & PW2
Hi dwanthny

I did a reboot to no avail, the issues remained.

Not sure I follow why this would this have an effect on what is, I would have thought to be, a Calibre issue in that I could not save books from my device?

Last edited by grizedale; 06-05-2010 at 07:30 AM.
grizedale is offline   Reply With Quote
Old 06-05-2010, 07:47 AM   #4
DoctorOhh
US Navy, Retired
DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.
 
DoctorOhh's Avatar
 
Posts: 8,908
Karma: 12755553
Join Date: Feb 2009
Location: North Carolina
Device: Nexus 7
Quote:
Originally Posted by grizedale View Post
Hi dwanthny

I did a reboot to no avail, the issues remained.

Not sure I follow why this would this have an effect on what is, I would have thought to be, a Calibre issue in that I could not save books from my device?
I admit you're one up on me I never thought to try to use the Save to disk feature from my reader. You are correct though, I can not save to disk from my device even though it walks me through all of the suspected prompts.

Beside having a feature, I never knew existed, not work everything else is working as expected. Then again currently I'm using a 505 not a 300.

Hopefully someone else can shed some light on this.

Last edited by DoctorOhh; 06-05-2010 at 09:01 AM.
DoctorOhh is offline   Reply With Quote
Old 06-05-2010, 08:32 AM   #5
Chi
Junior Member
Chi began at the beginning.
 
Posts: 5
Karma: 10
Join Date: Feb 2010
Location: Norway
Device: Sony Reader PRS-300 and Sony Reader PRS-T1
I'va also got a problem with Calibre 0.7 and my PRS-300. As the program dosen't want to connect properly with the Reader.

I'm using Linux (Ubuntu 10.04) and got his error message:
Quote:
(30, 'Read-only file system')

Traceback (most recent call last):
File "/home/kovid/build/calibre/src/calibre/gui2/device.py", line 58, in run
File "/home/kovid/build/calibre/src/calibre/gui2/device.py", line 262, in _books
File "/home/kovid/build/calibre/src/calibre/devices/prs505/driver.py", line 97, in books
File "/home/kovid/build/calibre/src/calibre/devices/usbms/driver.py", line 147, in books
File "/home/kovid/build/calibre/src/calibre/devices/prs505/driver.py", line 103, in sync_booklists
File "/home/kovid/build/calibre/src/calibre/devices/prs505/driver.py", line 93, in initialize_XML_cache
File "/usr/lib/python2.6/os.py", line 150, in makedirs
makedirs(head, mode)
File "/usr/lib/python2.6/os.py", line 157, in makedirs
mkdir(name, mode)
OSError: [Errno 30] Read-only file system: '/media/Sony Reader Storage Card (1)/Sony Reader'
Is it possible to downgrade or something? I really need to use my PRS-300 today.

Last edited by Chi; 06-05-2010 at 08:35 AM.
Chi is offline   Reply With Quote
Old 06-05-2010, 08:55 AM   #6
grizedale
NEXUS 7
grizedale shares his or her toysgrizedale shares his or her toysgrizedale shares his or her toysgrizedale shares his or her toysgrizedale shares his or her toysgrizedale shares his or her toysgrizedale shares his or her toysgrizedale shares his or her toysgrizedale shares his or her toysgrizedale shares his or her toysgrizedale shares his or her toys
 
Posts: 167
Karma: 5628
Join Date: May 2010
Location: UK, County Durham
Device: NEXUS 7 & PW2
Chi

I just uninstalled and went to the Calibre download page, there is a link there to previous versions.

http://calibre-ebook.com/download_linux
grizedale is offline   Reply With Quote
Old 06-05-2010, 01:41 PM   #7
kovidgoyal
creator of calibre
kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.
 
kovidgoyal's Avatar
 
Posts: 26,435
Karma: 5383257
Join Date: Oct 2006
Location: Mumbai, India
Device: Various
That's a permission denied error. Check the reader mount point. Is it the correct partition? i.e. is it the sont launcher partition being mounted or the sd card?
kovidgoyal is offline   Reply With Quote
Old 06-05-2010, 02:17 PM   #8
Chi
Junior Member
Chi began at the beginning.
 
Posts: 5
Karma: 10
Join Date: Feb 2010
Location: Norway
Device: Sony Reader PRS-300 and Sony Reader PRS-T1
Quote:
Originally Posted by grizedale View Post
Thanks

Quote:
Originally Posted by kovidgoyal View Post
That's a permission denied error. Check the reader mount point. Is it the correct partition? i.e. is it the sont launcher partition being mounted or the sd card?
It shows both a SD-card and the reader. And since the PRS-300 dosen't have a SD card, I find it kind of weird. When I try to click on the device in calibre no books show up and they don't communicate with each other, except from that I can see the device icon. Ubuntu communicates with the PRS-300 as well as before.
Chi is offline   Reply With Quote
Old 06-05-2010, 02:53 PM   #9
chaley
"chaley", not "charley"
chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.
 
Posts: 5,902
Karma: 1216548
Join Date: Jan 2010
Location: France
Device: Many android devices
Quote:
Originally Posted by Chi View Post
It shows both a SD-card and the reader. And since the PRS-300 dosen't have a SD card, I find it kind of weird. When I try to click on the device in calibre no books show up and they don't communicate with each other, except from that I can see the device icon. Ubuntu communicates with the PRS-300 as well as before.
The 300 has a read-only windows installation partition that shows up as a second disk. It is possible that somehow calibre is connecting to that partition instead of to the library.

Could you run the calibre device detection debug function and post the results? That might help find what is going on. Go to preferences/advanced/debug device connection.
chaley is offline   Reply With Quote
Old 06-07-2010, 05:51 AM   #10
Chi
Junior Member
Chi began at the beginning.
 
Posts: 5
Karma: 10
Join Date: Feb 2010
Location: Norway
Device: Sony Reader PRS-300 and Sony Reader PRS-T1
chaley: When you posted I had downgraded and it worked just well.

Just now I upgraded to 0.7.1 and it seems like it's communicates with my PRS-300 just well ^^
Chi is offline   Reply With Quote
Old 06-07-2010, 06:06 AM   #11
chaley
"chaley", not "charley"
chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.
 
Posts: 5,902
Karma: 1216548
Join Date: Jan 2010
Location: France
Device: Many android devices
Quote:
Originally Posted by Chi View Post
chaley: When you posted I had downgraded and it worked just well.

Just now I upgraded to 0.7.1 and it seems like it's communicates with my PRS-300 just well ^^
Thanks for the confirmation that the fix worked.
chaley is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 14 + Sony PRS-300: calibre doesn't work nodata Calibre 14 05-20-2012 05:36 PM
PRS 300 with Calibre/900 with SRL cozworth Sony Reader 0 09-04-2010 03:37 AM
PRS-300 not recognized by Calibre RavenZwei Calibre 9 01-26-2010 06:16 AM
Calibre doesn't transfer book to Sony PRS 300 Krystine Calibre 2 12-27-2009 07:05 PM
Calibre and the NEW PRS-300 Scarpad Calibre 11 10-28-2009 09:24 AM


All times are GMT -4. The time now is 08:13 PM.


MobileRead.com is a privately owned, operated and funded community.