Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Readers > PocketBook

Notices

Reply
 
Thread Tools Search this Thread
Old 05-11-2010, 10:05 AM   #1
tomh
Member
tomh doesn't littertomh doesn't litter
 
Posts: 13
Karma: 166
Join Date: Mar 2010
Location: Allentown, PA
Device: Nexus 7.2
Using the PockeBook SDK (15.1)

Hello all. I downloaded the SDK while waiting for my PocketBook 302 to arrive. It looked like the 15.1 version is for the 302 and the 14.2 version is for the 301. Since the web page is not english I am not sure, but it seemed reasonable. I imagine PB developers feel nervous about finding info on web sites written in english, but they manage.

I learned a few things about setting the SDK up in a 64 bit Win7 system and thought others might be interested. Eventually, it all works.

I got it here: http://pocketbook-free.sourceforge.n...pbsdk-15.1.exe

The web page is not english (Ukrainian?) but the file name is obvious. Click on the link to request the download.

Running this file looks scary because there are lots of question marks (unsupported font?) on the installer dialog box, but clicking where the install button should be results in a clean install on Win 7. Look at another install dialog to find the right button to click if you don't feel lucky; bottom left button is where to click if you feel lucky. The default install location is c:\pdsdk, which is a good place to put it.

The SDK appears to be 32 bit code. If you are running a 64 bit windows version there will be a few problems. These can be fixed by changing the installation file (c:\pbsdk\install.bat). My changes are not elegant, but they work. They can be cleaned up later.

The first thing is to change is where the cygpb1.dll library is copied. In 64 bit windows all 32 bit library code goes to %WINDIR%\SysWOW64. Yeah, it looks funky but that is how it works. In 64 bit Windows all 64 bit library code goes to System32 and all 32 bit library code goes to SysWOW64, which *may* make sense to Microsoft.

The second thing is to replace every occurrence of %CD% with "c:\pbsdk" (don't include the quotes). If you just run the original install.bat script as admin the value of %CD% resolves to the wrong location. This is why you get lots of warnings and errors when building an application with the SDK.

After doing these steps, I went to sources\inkdemo and got an app build for the windows emulator by clicking on make.bat. Doubling clicking the inkdemo.exe file successfully runs the inkdemo app.

I assume you get an ARM build by clicking on makearm.bat, but am waiting for my 302 before exploring this.

The build script and exe file did not work before I fixed the install.bat file.

Now, to figure out what you can do with the SDK...
tomh is offline   Reply With Quote
Old 05-11-2010, 02:31 PM   #2
kacir
Wizard
kacir ought to be getting tired of karma fortunes by now.kacir ought to be getting tired of karma fortunes by now.kacir ought to be getting tired of karma fortunes by now.kacir ought to be getting tired of karma fortunes by now.kacir ought to be getting tired of karma fortunes by now.kacir ought to be getting tired of karma fortunes by now.kacir ought to be getting tired of karma fortunes by now.kacir ought to be getting tired of karma fortunes by now.kacir ought to be getting tired of karma fortunes by now.kacir ought to be getting tired of karma fortunes by now.kacir ought to be getting tired of karma fortunes by now.
 
kacir's Avatar
 
Posts: 2,809
Karma: 3119503
Join Date: May 2006
Device: PocketBook 360, before it was Sony Reader, cassiopeia A-20
Thank you.
Thanks to your post I have noticed that the English version of the page is much older than Russian one.
When visiting such pages I usually cheat and open them through translate.google.com, even if I understand Russian. I am not used to reading in Azbuka and therefore I read very slowly.

15.1 is the current firmware also for PocketBook 360 and 301, but it is not as rock-stable as 14.2, so the official recommendation from PocketBook is to keep 14.2 unless you need features that 15.1 introduced.

A new, more stable firmware version was promised, and will be available "Real Soon Now" (TM).

http://www.jargon.net/jargonfile/r/RealSoonNow.html
http://www.urbandictionary.com/defin...l%20soon%20now
http://encyclopedia2.thefreedictiona.../Real+Soon+Now
kacir is offline   Reply With Quote
 
Enthusiast
Old 05-11-2010, 05:57 PM   #3
tomh
Member
tomh doesn't littertomh doesn't litter
 
Posts: 13
Karma: 166
Join Date: Mar 2010
Location: Allentown, PA
Device: Nexus 7.2
Kacir, thanks for the clarification on which version to use. I dropped back to the 14.2 SDK and tried that setup. This showed I left out an important step in my earlier note.

The exe file that installs the SDK must be run as admin. You do this by right clicking on the file and selecting the "run as administrator" option. You must do the same when running the modified install.bat file in c:\pbsdk.

Both operations modify the computer configuration and Win 7 insists this must be done by an administrator. Earlier Windows versions were more relaxed in regard to changes.
tomh is offline   Reply With Quote
Old 05-12-2010, 01:51 AM   #4
kacir
Wizard
kacir ought to be getting tired of karma fortunes by now.kacir ought to be getting tired of karma fortunes by now.kacir ought to be getting tired of karma fortunes by now.kacir ought to be getting tired of karma fortunes by now.kacir ought to be getting tired of karma fortunes by now.kacir ought to be getting tired of karma fortunes by now.kacir ought to be getting tired of karma fortunes by now.kacir ought to be getting tired of karma fortunes by now.kacir ought to be getting tired of karma fortunes by now.kacir ought to be getting tired of karma fortunes by now.kacir ought to be getting tired of karma fortunes by now.
 
kacir's Avatar
 
Posts: 2,809
Karma: 3119503
Join Date: May 2006
Device: PocketBook 360, before it was Sony Reader, cassiopeia A-20
Quote:
Originally Posted by tomh View Post
Kacir, thanks for the clarification on which version to use. I dropped back to the 14.2 SDK and tried that setup. This showed I left out an important step in my earlier note.
I think I did not write clearly.
The recommendation to stick with 14.2 is for PocketBook 301 and PocketBook 360 users. As for the 302 you have to judge for yourself or ask out resident PocketBook representatives.
kacir is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
SDK available hakim HanLin eBook 25 09-10-2011 04:17 PM
Pockebook 301, Kobo, Sony PSR600 emmad Which one should I buy? 3 07-28-2010 10:27 PM
Hanvon SDK? mh445 General Discussions 0 05-20-2010 02:50 PM
SDK ? KimJ PocketBook 1 01-01-2010 01:04 PM
SDK? foo Gen3 Developer's Corner 18 12-27-2007 11:01 AM


All times are GMT -4. The time now is 01:00 PM.


MobileRead.com is a privately owned, operated and funded community.