Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Readers > Kobo Reader

Notices

Reply
 
Thread Tools Search this Thread
Old 07-22-2010, 11:32 PM   #91
chutz
Member
chutz began at the beginning.
 
Posts: 11
Karma: 10
Join Date: May 2010
Device: Kobo eReader
Quote:
Originally Posted by Bloggins View Post
/usr/local/Kobo/Kobo: /lib/libc.so.6: version `GLIBC_2.11' not found (required by /usr/local/Trolltech/Qt-4.6.2/lib/libQtGuiKobo.so.4)
That generally means that you need at least glibc 2.11, which came out in November 2009. It's possible that your distro has an update for it in a repository somewhere.
chutz is offline   Reply With Quote
Old 07-23-2010, 01:12 AM   #92
chandana
Junior Member
chandana began at the beginning.
 
Posts: 7
Karma: 10
Join Date: Jun 2010
Device: none
Kobo Update does not work in Linux

Since about two weeks ago, the Linux version tries to download an update and crashes. It downloads KoboSetup.exe, which is not much use...

Last edited by chandana; 07-23-2010 at 01:17 AM.
chandana is offline   Reply With Quote
Old 07-23-2010, 01:33 AM   #93
chandana
Junior Member
chandana began at the beginning.
 
Posts: 7
Karma: 10
Join Date: Jun 2010
Device: none
To answer my own question the deb has been updated, though the name is the same.
It can be downloaded from http://dl.dropbox.com/u/2183775/kobo-desktop.deb.

Thanks to those who posted this in the main Kobo forum
chandana is offline   Reply With Quote
Old 07-27-2010, 07:57 PM   #94
panzer
Member
panzer began at the beginning.
 
Posts: 23
Karma: 10
Join Date: Jul 2010
Device: Kobo
I'm thinking to buy the Kobo eReader. I read somewhere the latest firmware is v1.4. I'm using Ubuntu 10.04 and I installed the Debian application found on this thread.
So, just to make sure, this application will be able to install the latest firmware version into my Kobo, right?

Thanks.
panzer is offline   Reply With Quote
Old 07-31-2010, 05:52 PM   #95
Ozman
Junior Member
Ozman ought to be getting tired of karma fortunes by now.Ozman ought to be getting tired of karma fortunes by now.Ozman ought to be getting tired of karma fortunes by now.Ozman ought to be getting tired of karma fortunes by now.Ozman ought to be getting tired of karma fortunes by now.Ozman ought to be getting tired of karma fortunes by now.Ozman ought to be getting tired of karma fortunes by now.Ozman ought to be getting tired of karma fortunes by now.Ozman ought to be getting tired of karma fortunes by now.Ozman ought to be getting tired of karma fortunes by now.Ozman ought to be getting tired of karma fortunes by now.
 
Ozman's Avatar
 
Posts: 8
Karma: 463230
Join Date: Apr 2010
Device: Kobo, Nexus 7
Yes it can.
Ozman is offline   Reply With Quote
Old 08-04-2010, 03:24 AM   #96
Rodney9
Junior Member
Rodney9 began at the beginning.
 
Posts: 3
Karma: 10
Join Date: May 2010
Device: kobo
The Kobo Desktop eReader for Linux has stopped working on my xubuntu 10.4, it was working and I re-installed the latest one, but no luck.
Rodney9 is offline   Reply With Quote
Old 08-04-2010, 03:35 AM   #97
zoran
himself
zoran can tame squirrels without the assistance of a chair or a whip.zoran can tame squirrels without the assistance of a chair or a whip.zoran can tame squirrels without the assistance of a chair or a whip.zoran can tame squirrels without the assistance of a chair or a whip.zoran can tame squirrels without the assistance of a chair or a whip.zoran can tame squirrels without the assistance of a chair or a whip.zoran can tame squirrels without the assistance of a chair or a whip.zoran can tame squirrels without the assistance of a chair or a whip.zoran can tame squirrels without the assistance of a chair or a whip.zoran can tame squirrels without the assistance of a chair or a whip.zoran can tame squirrels without the assistance of a chair or a whip.
 
Posts: 576
Karma: 11226
Join Date: May 2010
Device: Kobo
Quote:
Originally Posted by Rodney9 View Post
The Kobo Desktop eReader for Linux has stopped working on my xubuntu 10.4, it was working and I re-installed the latest one, but no luck.
My best bet is that it should be some kind of perl/python app, portable
without too many frills. Having book management on mind. For upgrade,
SD card method only.
I loaded books by the hand, all at once and it took an hour to process.
Still, I do not regret, since I know what I was doing. Mount, copy, check,
umount. Sing.
zoran is offline   Reply With Quote
Old 08-05-2010, 08:52 AM   #98
nebcanuck
Kobo user
nebcanuck began at the beginning.
 
nebcanuck's Avatar
 
Posts: 11
Karma: 10
Join Date: Aug 2010
Location: Peterborough, Ontario
Device: Kobo
Quote:
Just unpack the deb and install by hand. There's only a few files to copy.

ar vx kobo-desktop.deb
tar -zxf data.tar.gz
Tried this on Fedora 13. Program runs okay, but get this error message when I try to sign into my account:

Quote:
Qt: Session management error: None of the authentication protocols specified are supported
WTF ROBERT "/usr/local/Kobo"
CHECKING DB VERSION FOR MIGRATION
DESIRED VERSION: 4
CURRENT VERSION: 2
ERROR ---------- QSqlError(-1, "Parameter count mismatch", "")
EXECUTED QUERY ---------- "SELECT * FROM ? WHERE ___SyncTime > ?"
BOUND VALUES ---------- QMap((":mostRecentSyncTime", QVariant(QDateTime, QDateTime("") ) ) ( ":tableName" , QVariant(QString, "content") ) )
INIT TIME: 784
_inApplicationSupportStatus "1"
"https://mobilepartner.kobobooks.com/login.html?pwsdid=00:26:82:2E:49:33&pwspt=Desktop& pwspov=1.4&wsd=desktop&wscfv=1.5&wscf=kxml&wsa=Kob o"
/usr/bin/Kobo: line 3: 2237 Segmentation fault /usr/local/Kobo/Kobo
Seems to be having trouble writing to a database? Do I need a different QSql file, or is it telling me that it doesn't like the access requested by the Kobo desktop?
nebcanuck is offline   Reply With Quote
Old 08-05-2010, 10:23 PM   #99
chandana
Junior Member
chandana began at the beginning.
 
Posts: 7
Karma: 10
Join Date: Jun 2010
Device: none
Linux Reader Does not work off-line

I am using the updated linux reader. Since the recent upgrade, it does not work off-line.

On startup, it tries to connect to the Kobo site to do a sync, and dies. Also it seems to need to do a sync on every new chapter, and needs to kobo site to do a sync. So, now it cannot be used off-line.
chandana is offline   Reply With Quote
Old 08-05-2010, 11:06 PM   #100
Spinner
Bibliofreak
Spinner began at the beginning.
 
Spinner's Avatar
 
Posts: 8
Karma: 10
Join Date: May 2010
Device: kobo
Running Ubuntu 10.04 64-bit; I had to install libpng3 before I could get the new version of the Desktop to work. Just completed the firmware update, and all appears to have worked as advertised... so far.
Spinner is offline   Reply With Quote
Old 08-09-2010, 12:04 AM   #101
snmilliken
Member
snmilliken is a glorious beacon of lightsnmilliken is a glorious beacon of lightsnmilliken is a glorious beacon of lightsnmilliken is a glorious beacon of lightsnmilliken is a glorious beacon of lightsnmilliken is a glorious beacon of lightsnmilliken is a glorious beacon of lightsnmilliken is a glorious beacon of lightsnmilliken is a glorious beacon of lightsnmilliken is a glorious beacon of lightsnmilliken is a glorious beacon of light
 
snmilliken's Avatar
 
Posts: 21
Karma: 12050
Join Date: Aug 2010
Device: Kobo,Kobo Vox & BB Playbook
New to the forum and also looking to get the desktop working in Linux. I have Simply Mepis 8.5 installed and it is a Debian Lenny base KDE 4.3.4. I downloaded the deb and installed in it. I'm getting the error of missing glibc 2.11. Any suggestions? or is this a KDE4.4 build? Is there a tarball that could be used to build?

Last edited by snmilliken; 08-09-2010 at 12:14 AM.
snmilliken is offline   Reply With Quote
Old 08-13-2010, 01:42 AM   #102
chandana
Junior Member
chandana began at the beginning.
 
Posts: 7
Karma: 10
Join Date: Jun 2010
Device: none
This is a proprietary product, so forget building it.

For glibc, try this;
$ dpkg -l libglib2.0-0

Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Cfg-files/Unpacked/Failed-cfg/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Description
+++-==========================-==========================-================================================== ==================
ii libglib2.0-0 2.24.1 The GLib library of C routines


If you don't get a valid response you will need to install the libglib2.0-0 deb.

I have been able to run the desktop linux version on Ubuntu 10.0.4.

However, the latest version has a problem, in that it tries to continuously sync with Kobo and sometimes refuses the decrypt the ebooks.
chandana is offline   Reply With Quote
Old 08-15-2010, 12:28 AM   #103
snmilliken
Member
snmilliken is a glorious beacon of lightsnmilliken is a glorious beacon of lightsnmilliken is a glorious beacon of lightsnmilliken is a glorious beacon of lightsnmilliken is a glorious beacon of lightsnmilliken is a glorious beacon of lightsnmilliken is a glorious beacon of lightsnmilliken is a glorious beacon of lightsnmilliken is a glorious beacon of lightsnmilliken is a glorious beacon of lightsnmilliken is a glorious beacon of light
 
snmilliken's Avatar
 
Posts: 21
Karma: 12050
Join Date: Aug 2010
Device: Kobo,Kobo Vox & BB Playbook
Thanks. I'll give it a try. Is the project still an active one?

EDIT: libglib2.0-0 is already installed. Now the version is 2.21.4-1, not sure if this makes the difference.

This is the error:

Quote:
/usr/local/Kobo/Kobo: /lib/libc.so.6: version `GLIBC_2.9' not found (required by /usr/local/Trolltech/Qt-4.6.2/lib/libQtGuiKobo.so.4)
/usr/local/Kobo/Kobo: /lib/libc.so.6: version `GLIBC_2.11' not found (required by /usr/local/Trolltech/Qt-4.6.2/lib/libQtGuiKobo.so.4)
/usr/local/Kobo/Kobo: /lib/libc.so.6: version `GLIBC_2.10' not found (required by /usr/local/Trolltech/Qt-4.6.2/lib/libQtNetworkKobo.so.4)
/usr/local/Kobo/Kobo: /lib/libc.so.6: version `GLIBC_2.9' not found (required by /usr/local/Trolltech/Qt-4.6.2/lib/libQtCoreKobo.so.4)

Last edited by snmilliken; 08-18-2010 at 04:52 PM.
snmilliken is offline   Reply With Quote
Old 08-20-2010, 02:59 AM   #104
chandana
Junior Member
chandana began at the beginning.
 
Posts: 7
Karma: 10
Join Date: Jun 2010
Device: none
Apologies, my mistake, You need libc6.
chandana is offline   Reply With Quote
Old 08-20-2010, 11:11 PM   #105
snmilliken
Member
snmilliken is a glorious beacon of lightsnmilliken is a glorious beacon of lightsnmilliken is a glorious beacon of lightsnmilliken is a glorious beacon of lightsnmilliken is a glorious beacon of lightsnmilliken is a glorious beacon of lightsnmilliken is a glorious beacon of lightsnmilliken is a glorious beacon of lightsnmilliken is a glorious beacon of lightsnmilliken is a glorious beacon of lightsnmilliken is a glorious beacon of light
 
snmilliken's Avatar
 
Posts: 21
Karma: 12050
Join Date: Aug 2010
Device: Kobo,Kobo Vox & BB Playbook
Quote:
Originally Posted by chandana View Post
Apologies, my mistake, You need libc6.
libc6 was already installed. It is version 2.7-18lenny4. Does it require a more up to date version?
snmilliken is offline   Reply With Quote
Reply

Tags
desktop, kobo, linux, software

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to Get Sony Reader Desktop Version to Work with Linux? Flyweight Sony Reader 3 11-14-2010 07:47 PM
Over trying to manage Kobo reader with Kobo desktop. Some help with Calibre? digital_steve Calibre 14 09-18-2010 01:12 AM
Over trying to manage Kobo reader with Kobo desktop. Some help with Calibre? digital_steve Kobo Reader 11 08-02-2010 10:31 PM
Kobo Desktop for Linux: Update Available? luqmaninbmore Kobo Reader 2 07-16-2010 11:00 AM
Using Kobo Desktop issues... clicker666 Kobo Reader 6 06-29-2010 04:21 PM


All times are GMT -4. The time now is 07:47 AM.


MobileRead.com is a privately owned, operated and funded community.