Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre

Notices

Reply
 
Thread Tools Search this Thread
Old 02-17-2010, 03:49 AM   #1
conryf
Member
conryf began at the beginning.
 
Posts: 12
Karma: 10
Join Date: Feb 2010
Device: none
Installation Error GLIB_2.9 not found

I'm installing calibre via command line on a server running Ubuntu Hardy LTS and it seems to install (via binary) fine but when I try to run it I get this error:

ImportError: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.9' not found (required by /opt/calibre/libQtCore.so.4)

I have installed libc6-dev and it didn't seem to help. Is there spme deependency I'm not seeing?

thanks in adavance for your help,
conryf is offline   Reply With Quote
Old 02-17-2010, 11:27 AM   #2
kovidgoyal
creator of calibre
kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.
 
kovidgoyal's Avatar
 
Posts: 26,437
Karma: 5383257
Join Date: Oct 2006
Location: Mumbai, India
Device: Various
yes, the dependency is glibc >= 2.9
kovidgoyal is offline   Reply With Quote
 
Advertisement
Old 02-18-2010, 12:29 AM   #3
conryf
Member
conryf began at the beginning.
 
Posts: 12
Karma: 10
Join Date: Feb 2010
Device: none
GLIBC 2.9

I'm sorry but I can't seem to figure out how to install it. The only references I've found online are to glib 2.0 a la the command:

sudo apt-get install libglib2.0-0 libglib2.0-dev libglib2.0-doc

I tried replacing 2.0 with 2.9 or 3.0 to no avail. Sorry but I'm kind of a newbie, your help is much appreciated.
conryf is offline   Reply With Quote
Old 02-18-2010, 06:00 AM   #4
conryf
Member
conryf began at the beginning.
 
Posts: 12
Karma: 10
Join Date: Feb 2010
Device: none
update

sudo apt-get install libglib-dev also didn't seem to satisfy this requirement.

please help
conryf is offline   Reply With Quote
Old 02-18-2010, 01:27 PM   #5
kovidgoyal
creator of calibre
kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.
 
kovidgoyal's Avatar
 
Posts: 26,437
Karma: 5383257
Join Date: Oct 2006
Location: Mumbai, India
Device: Various
I doubt Ubuntu Hardy has glibc 2.9 in its repositories. You need to upgrade to a newer version of Ubuntu
kovidgoyal is offline   Reply With Quote
Old 04-05-2010, 12:11 PM   #6
conryf
Member
conryf began at the beginning.
 
Posts: 12
Karma: 10
Join Date: Feb 2010
Device: none
Upgraded

Ok I upgraded to Jaunty. Still no luck. Output:


[prompt ~] sudo apt-get install libglib-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting libglib1.2-dev instead of libglib-dev
libglib1.2-dev is already the newest version.
The following packages were automatically installed and are no longer required:
openssh-blacklist
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
[prompt ~] sudo apt-get install glibc
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package glibc


any ideas?
conryf is offline   Reply With Quote
Old 04-05-2010, 03:12 PM   #7
conryf
Member
conryf began at the beginning.
 
Posts: 12
Karma: 10
Join Date: Feb 2010
Device: none
Glib 2.9 not enough

ok I managed to install glib 2.9 by removing belocs-locales-bin

and now I get this:

[prompt ~] sudo calibre
Traceback (most recent call last):
File "/tmp/init.py", line 46, in <module>
File "/home/kovid/build/calibre/src/calibre/gui2/__init__.py", line 18, in <module>
File "/home/kovid/build/calibre/src/calibre/ebooks/metadata/meta.py", line 11, in <module>
File "/home/kovid/build/calibre/src/calibre/customize/ui.py", line 12, in <module>
File "/home/kovid/build/calibre/src/calibre/customize/builtins.py", line 418, in <module>
File "/home/kovid/build/calibre/src/calibre/ebooks/pdf/output.py", line 18, in <module>
File "/home/kovid/build/calibre/src/calibre/ebooks/pdf/writer.py", line 22, in <module>
File "ExtensionLoader_PyQt4_QtWebKit.py", line 12, in <module>
ImportError: /lib/libc.so.6: version `GLIBC_2.10' not found (required by /opt/calibre/libQtNetwork.so.4)


argh! Now I need glib 2.10!? please help.
conryf is offline   Reply With Quote
Old 04-05-2010, 10:44 PM   #8
kovidgoyal
creator of calibre
kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.
 
kovidgoyal's Avatar
 
Posts: 26,437
Karma: 5383257
Join Date: Oct 2006
Location: Mumbai, India
Device: Various
yes, you need glibc 2.10, it says so on the binary download instructions
kovidgoyal is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ERROR: Error: Error communicating with device JWood Calibre 10 04-20-2010 08:28 PM
Error code 2329 during installation deb27 Calibre 1 01-23-2010 12:54 AM
Error on installation of calibre 0.6.13 sleepyDragon Calibre 5 09-22-2009 05:37 AM
Installation FizzyWater Calibre 5 12-08-2008 04:21 PM
Cybook not found in linux, found in win XP fjf Bookeen 15 01-18-2008 07:57 PM


All times are GMT -4. The time now is 11:08 AM.


MobileRead.com is a privately owned, operated and funded community.