Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre

Notices

Reply
 
Thread Tools Search this Thread
Old 02-13-2010, 09:25 PM   #1
lamparty
Member
lamparty began at the beginning.
 
lamparty's Avatar
 
Posts: 24
Karma: 10
Join Date: Aug 2009
Device: Sony Reader PRS-505
Question V o.6.40 install in Ubuntu 9.10 problem?

I just installed the binary of 6.40 and got an error message in terminal. Thing is Calibre starts and says it is 6.40 and I can view LRF files with it, so am a bit puzzled about whether it installed correctly or not!!! Here the error message anyhow!
Extracting files to /opt/calibre ...
Extracting application files...

bzip2: I/O or other error, bailing out. Possible reason follows.
bzip2: Broken pipe
Input file = (stdin), output file = (stdout)
tar: Child returned status 1
tar: Exiting with failure status due to previous errors
Traceback (most recent call last):
File "<string>", line 1, in <module>
File "<string>", line 207, in main
File "<string>", line 182, in extract_tarball
File "/usr/lib/python2.6/subprocess.py", line 488, in check_call
raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command '['tar', 'xjf', '/tmp/tmpIhSAiD', '-C', '/opt/calibre']' returned non-zero exit status 2

Last edited by lamparty; 02-13-2010 at 09:27 PM. Reason: Correcton to Title
lamparty is offline   Reply With Quote
Old 02-16-2010, 11:27 AM   #2
halljames
Zealot
halljames has a complete set of Star Wars action figures.halljames has a complete set of Star Wars action figures.halljames has a complete set of Star Wars action figures.halljames has a complete set of Star Wars action figures.halljames has a complete set of Star Wars action figures.
 
halljames's Avatar
 
Posts: 116
Karma: 463
Join Date: Feb 2007
Location: Newcastle, UK
Device: Apple iPad
I am getting the exact same error??
halljames is offline   Reply With Quote
Old 02-16-2010, 11:48 AM   #3
=X=
Wizard
=X= ought to be getting tired of karma fortunes by now.=X= ought to be getting tired of karma fortunes by now.=X= ought to be getting tired of karma fortunes by now.=X= ought to be getting tired of karma fortunes by now.=X= ought to be getting tired of karma fortunes by now.=X= ought to be getting tired of karma fortunes by now.=X= ought to be getting tired of karma fortunes by now.=X= ought to be getting tired of karma fortunes by now.=X= ought to be getting tired of karma fortunes by now.=X= ought to be getting tired of karma fortunes by now.=X= ought to be getting tired of karma fortunes by now.
 
=X='s Avatar
 
Posts: 3,672
Karma: 12205306
Join Date: Mar 2008
Device: Galaxy S, Nook w/CM7
Yeah it failed the exit status of 2 is an error.

I tried to install calibre .6.40 on Ubuntu 9.10 as well. However it failed because calibre after 29 requires glibc v 2.10. And Ubutu has 2.9.

=X=
=X= is offline   Reply With Quote
Old 02-16-2010, 01:31 PM   #4
hairybiker
Connoisseur
hairybiker began at the beginning.
 
Posts: 70
Karma: 10
Join Date: Aug 2009
Device: PRS-505
I have it installed no problem on my installation, 64bit Karmic.
I have had bad downloads before and had to retry several times to get it to install properly before now.
hairybiker is offline   Reply With Quote
Old 02-17-2010, 04:39 AM   #5
Kaie
Junior Member
Kaie began at the beginning.
 
Posts: 1
Karma: 10
Join Date: Feb 2010
Device: nook
I have 2 exact OS installs on 2 different laptops. The first laptop i put Calibre on w/ 0 issues.

The other, i get the error stated in OP. I've tried it about 15 times and its just not working.

I also googled and found the error stated by other people. Though i never discovered a fix.

I tried manually extracting the tar into /opt/calibre and that gives me an error that i dont have permission. Even though i opened as root.

Please help.
Kaie is offline   Reply With Quote
Old 02-17-2010, 10:34 AM   #6
booksonthemove
Connoisseur
booksonthemove began at the beginning.
 
Posts: 72
Karma: 16
Join Date: Sep 2009
Location: UK
Device: Sony PRS-600 with latest Calibre and Linux Ubuntu-9.10
My upgrade also went without hassle. I run daily updates though (ubuntu karmic x64)
booksonthemove is offline   Reply With Quote
Old 02-17-2010, 10:38 AM   #7
booksonthemove
Connoisseur
booksonthemove began at the beginning.
 
Posts: 72
Karma: 16
Join Date: Sep 2009
Location: UK
Device: Sony PRS-600 with latest Calibre and Linux Ubuntu-9.10
Maybe a silly question, but can I ask the OP

1. how much space is available on the partition with /opt
2. is the hard drive going bad

basically bunzip2 tried to write, found that it couldn't, hence the error

edit: also, how did you install it?

Last edited by booksonthemove; 02-17-2010 at 10:41 AM.
booksonthemove is offline   Reply With Quote
Old 02-19-2010, 01:07 AM   #8
lamparty
Member
lamparty began at the beginning.
 
lamparty's Avatar
 
Posts: 24
Karma: 10
Join Date: Aug 2009
Device: Sony Reader PRS-505
/ partition has 4GB used out of 23GB and I used the binary install with copy and paste in terminal.
lamparty is offline   Reply With Quote
Reply

Tags
0.6.40, installtion error, linux, problem, ubuntu 9.10

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Install problem on Linux (Ubuntu 9.10) hmonster Calibre 8 03-25-2010 05:08 AM
Install problem on ubuntu frdimond Calibre 14 02-19-2010 01:26 AM
Cannot install calibre on ubuntu 8.04 kkkidder Calibre 1 03-19-2009 10:44 PM
ubuntu hardy problem with binary install `Illegal instruction` lampadena Calibre 2 02-10-2009 02:57 AM
Ubuntu 7.10 90% of libprs500 install... knewbie Calibre 3 12-24-2007 04:38 PM


All times are GMT -4. The time now is 09:51 AM.


MobileRead.com is a privately owned, operated and funded community.