Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre

Notices

Reply
 
Thread Tools Search this Thread
Old 02-08-2009, 08:29 AM   #1
kacir
Wizard
kacir ought to be getting tired of karma fortunes by now.kacir ought to be getting tired of karma fortunes by now.kacir ought to be getting tired of karma fortunes by now.kacir ought to be getting tired of karma fortunes by now.kacir ought to be getting tired of karma fortunes by now.kacir ought to be getting tired of karma fortunes by now.kacir ought to be getting tired of karma fortunes by now.kacir ought to be getting tired of karma fortunes by now.kacir ought to be getting tired of karma fortunes by now.kacir ought to be getting tired of karma fortunes by now.kacir ought to be getting tired of karma fortunes by now.
 
kacir's Avatar
 
Posts: 2,858
Karma: 3164175
Join Date: May 2006
Device: PocketBook 360, before it was Sony Reader, cassiopeia A-20
problems running Calibre on FreeBSD

Dear FreeBSD and/or Calibre gurus.

as a main desktop I use PC-BSD 7.02 http://www.pcbsd.org/
It is built on FreeBSD 7.1-PRERELEASE

I have been trying to install Calibre on vanilla FreeBSD and on PC-BSD for quite a long time, and I simply can't make it run.

I have tried to install Windows .exe file under wine.
No success.

I have tried to run Linux binaries (after running brandelf -t Linux on a binary)
Not surprisingly, it does not work. Perhaps with a statically linked binaries I might have had a success here.

I have tried to follow "Install from source" steps on http://calibre.kovidgoyal.net/download_generic
- I have installed all the components from the list of dependencies on "Install from source" page.
- I have unpacked calibre-0.4.134.tar.gz
- went into the directory by cd calibre-0.4.134
- I have run (as a root) python setup.py build
and I get the following error
# python setup.py build
Setup calibre version: 0.4.134
running build
running resources
WARNING: Could not find Qt transations
Resources are up to date
running translations
Translations up to date
running gui
Compiling form /usr/ports/0Moje/calibre/calibre-0.4.134/src/calibre/gui2/dialogs/epub.ui
Traceback (most recent call last):
File "setup.py", line 492, in <module>
'sdist' : sdist,
File "/usr/local/lib/python2.5/distutils/core.py", line 151, in setup
dist.run_commands()
File "/usr/local/lib/python2.5/distutils/dist.py", line 974, in run_commands
self.run_command(cmd)
File "/usr/local/lib/python2.5/distutils/dist.py", line 994, in run_command
cmd_obj.run()
File "/usr/local/lib/python2.5/distutils/command/build.py", line 112, in run
self.run_command(cmd_name)
File "/usr/local/lib/python2.5/distutils/cmd.py", line 333, in run_command
self.distribution.run_command(command)
File "/usr/local/lib/python2.5/distutils/dist.py", line 994, in run_command
cmd_obj.run()
File "setup.py", line 292, in run
self.build_forms()
File "setup.py", line 326, in build_forms
compileUi(form, buf)
File "/usr/X11R6/lib/python2.5/site-packages/PIL/__init__.py", line 56, in compileUi

File "uic/Compiler/compiler.py", line 71, in compileUi
File "uic/uiparser.py", line 569, in parse
File "uic/uiparser.py", line 428, in createUserInterface
File "uic/uiparser.py", line 406, in traverseWidgetTree
File "uic/uiparser.py", line 301, in createLayout
File "uic/uiparser.py", line 406, in traverseWidgetTree
File "uic/uiparser.py", line 309, in handleItem
File "uic/uiparser.py", line 406, in traverseWidgetTree
File "uic/uiparser.py", line 153, in createWidget
File "uic/uiparser.py", line 128, in setupObject
File "uic/objcreator.py", line 62, in createQObject
PyQt4.uic.exceptions.NoSuchWidgetError: Unknown Qt widget: QScrollArea
Exit 1

Can you please help me please?
Can I build at least a non-GUI (commandline) version of Calibre?
kacir is offline   Reply With Quote
Old 02-08-2009, 09:27 AM   #2
itimpi
Wizard
itimpi ought to be getting tired of karma fortunes by now.itimpi ought to be getting tired of karma fortunes by now.itimpi ought to be getting tired of karma fortunes by now.itimpi ought to be getting tired of karma fortunes by now.itimpi ought to be getting tired of karma fortunes by now.itimpi ought to be getting tired of karma fortunes by now.itimpi ought to be getting tired of karma fortunes by now.itimpi ought to be getting tired of karma fortunes by now.itimpi ought to be getting tired of karma fortunes by now.itimpi ought to be getting tired of karma fortunes by now.itimpi ought to be getting tired of karma fortunes by now.
 
Posts: 4,103
Karma: 780247
Join Date: Nov 2008
Device: Sony PRS-950, iphone/ipad (Marvin/iBooks/QuickReader)
I would expect some of the source packages to require building. Looking at the error message you have, it suggests that Qt was not built?

Although it is not directly comparable, you might want to look at what needs doing on OS/X or Windows to get a calibre environment running. That might give you a better idea of what packages will need building after their source has been installed.

Of course I could be wrong, and Kovid can give you some simpler advice to getting things working
itimpi is offline   Reply With Quote
 
Advertisement
Old 02-08-2009, 02:44 PM   #3
kovidgoyal
creator of calibre
kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.
 
kovidgoyal's Avatar
 
Posts: 26,433
Karma: 5383257
Join Date: Oct 2006
Location: Mumbai, India
Device: Various
I believe NetBSD has a package of calibre, you may be able to get that to runbv
kovidgoyal is offline   Reply With Quote
Old 02-08-2009, 03:52 PM   #4
kacir
Wizard
kacir ought to be getting tired of karma fortunes by now.kacir ought to be getting tired of karma fortunes by now.kacir ought to be getting tired of karma fortunes by now.kacir ought to be getting tired of karma fortunes by now.kacir ought to be getting tired of karma fortunes by now.kacir ought to be getting tired of karma fortunes by now.kacir ought to be getting tired of karma fortunes by now.kacir ought to be getting tired of karma fortunes by now.kacir ought to be getting tired of karma fortunes by now.kacir ought to be getting tired of karma fortunes by now.kacir ought to be getting tired of karma fortunes by now.
 
kacir's Avatar
 
Posts: 2,858
Karma: 3164175
Join Date: May 2006
Device: PocketBook 360, before it was Sony Reader, cassiopeia A-20
Quote:
Originally Posted by kovidgoyal View Post
I believe NetBSD has a package of calibre
Thank you for the tip.
I have just looked.
According to the Readme.html file in ports directory ftp://ftp.netbsd.org/pub/NetBSD/pack.../misc/calibre/ calibre needs 162 dependencies to build and 135 (slightly different list) to run.

many of those are secondary dependencies, I believe. It means that you depend on, for example, html2man and that package depends on other packages.

I will try to investigate.
Now I am looking for an expert on Calibre, FreeBSD and porting of applications from NetBSD to FreeBSD
kacir is offline   Reply With Quote
Old 08-28-2009, 03:23 AM   #5
lapo
Junior Member
lapo began at the beginning.
 
Posts: 4
Karma: 10
Join Date: Dec 2008
Location: Italy
Device: Cybook Gen3
I'm also interested on running Calibre on FreeBSD and have experience in creating Ports. I'll try at it in the near future, when I do find some free time =)
lapo is offline   Reply With Quote
Old 10-22-2009, 03:24 AM   #6
wntsolstice
Junior Member
wntsolstice began at the beginning.
 
Posts: 1
Karma: 10
Join Date: Oct 2009
Device: Sony PRS-505
Quote:
Originally Posted by lapo View Post
I'm also interested on running Calibre on FreeBSD and have experience in creating Ports. I'll try at it in the near future, when I do find some free time =)
Curious if you had any success here - I'm a huge fan of Calibre and use it on Debian all the time. I'd like very much to have it work under FreeBSD ( especially if there were a PBI for PC-BSD )

I have never ported from NetBSD to FreeBSD, but if you need a hand, let me know. I'll see what I can do.
wntsolstice is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Calibre and FreeBSD bgalbrecht Calibre 1 01-27-2010 11:12 PM
Observations/problems running Calibre under OS X garygibsonsf Calibre 17 07-26-2008 12:03 AM
Running Calibre (0.4.77) dsb66 Calibre 9 07-18-2008 05:42 AM
Problems running calibre on Windows XP maccow Calibre 2 06-05-2008 02:35 PM
Problems running calibre 0.4.56 on Windows astrodad Calibre 17 05-22-2008 11:49 AM


All times are GMT -4. The time now is 09:43 PM.


MobileRead.com is a privately owned, operated and funded community.