Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Readers > Sony Reader

Notices

Reply
 
Thread Tools Search this Thread
Old 09-24-2009, 11:30 AM   #1
gadgetfreak
Member
gadgetfreak began at the beginning.
 
Posts: 12
Karma: 20
Join Date: Sep 2009
Location: London, UK
Device: PRS-600
Lightbulb Sony eBook Library, PRS-600 and Mac Snow Leopard -- Works with External USB Hub!!!

Hi there...

I basically found this out by accident, and thought I'd share it everybody out there who are trying to use Sony eBook Library 3.0 with Mac OSX Snow Leopard. I have been getting mixed success in getting eBook Library to work with my Macbook Air, and then realised that there was one thing in common in every instance that it worked successfully: I had my PRS-600 plugged into the external USB hub that's incorporated into my external Apple Cinema Display.

Upon realising this, I did a number of experiments to test it out, and sure enough, when I plug the PRS-600 directly into my Macbook Air's USB port, the behaviour is very different. The "LAUNCHER" drive pops up immediately, but it takes a while for "READER" to mount. Then, the icon for Sony eBook Library starts up, but usually it the window for the application doesn't come up. If the window does come up, it's very slow in interacting with the reader. Actually, if I try to open up the READER drive in Finder, it's very slow as well.

If I plug the PRS-600 into the USB hub on my display, though, and then plug the display's USB cable into the Macbook Air, the LAUNCHER and READER drives mount immediately, and the Sony eBook Library loads quickly and without any problems. Browsing the READER drive in Finder is very fast as well.

Please note that I've set the Sony eBook Library to run in Rosetta -- I had a bunch of random freezes if I didn't, regardless of which USB port I plugged the PRS-600 into.

I don't know enough about how USB works, so can't begin to guess why it works properly through the external USB hub and not when directly connected to the Macbook Air. Maybe it's a USB driver issue?

I hope that this is helpful to any Mac users out there running Snow Leopard!
gadgetfreak is offline   Reply With Quote
Old 09-24-2009, 02:42 PM   #2
Seventh Son
lurker
Seventh Son has a complete set of Star Wars action figures.Seventh Son has a complete set of Star Wars action figures.Seventh Son has a complete set of Star Wars action figures.Seventh Son has a complete set of Star Wars action figures.
 
Posts: 118
Karma: 356
Join Date: Sep 2009
Location: EU
Device: Sony PRS-600
Maybe Air doesn't provide enough power to the USB port. I've seen this happen with other laptops. External hub in you display most likely has additional power going in.
Seventh Son is offline   Reply With Quote
Old 09-24-2009, 09:53 PM   #3
capnttom
Junior Member
capnttom began at the beginning.
 
capnttom's Avatar
 
Posts: 9
Karma: 46
Join Date: Sep 2009
Device: Sony PRS-600
I too have a Macbook Air running Snow Leopard, but my circumstances are very different. eBook Library ran fine on my MBA for a couple of weeks then all of a sudden I didn't see a display and parts of the menu bar are missing. I've uninstalled and installed many times to no avail. I finally gave up and installed eBook Library on my Mac Pro and all is well. It's a real mystery to me. Hopefully Sony will release a software fix in the near term.
capnttom is offline   Reply With Quote
Old 09-25-2009, 06:08 AM   #4
gadgetfreak
Member
gadgetfreak began at the beginning.
 
Posts: 12
Karma: 20
Join Date: Sep 2009
Location: London, UK
Device: PRS-600
Hmmmm.... Interesting idea. However, I thought the Macbook Air had more power available through the USB port than other Mac laptops (due to having to power the external SuperDrive)?
gadgetfreak is offline   Reply With Quote
Old 09-25-2009, 06:26 AM   #5
Seventh Son
lurker
Seventh Son has a complete set of Star Wars action figures.Seventh Son has a complete set of Star Wars action figures.Seventh Son has a complete set of Star Wars action figures.Seventh Son has a complete set of Star Wars action figures.
 
Posts: 118
Karma: 356
Join Date: Sep 2009
Location: EU
Device: Sony PRS-600
Maybe it's a bad USB cable then, that one has too much resistance. So of my cables can power my external HDD and some don't, even when connected to a powered hub.
Seventh Son is offline   Reply With Quote
Old 09-25-2009, 06:56 AM   #6
myrrhs
poetic terrorist
myrrhs began at the beginning.
 
myrrhs's Avatar
 
Posts: 5
Karma: 20
Join Date: Sep 2009
Device: Sony PRS600
@capnttom

You should erase the preferences for the Sony Library, to make it work again. Been there, done that.

Regards,

IEG
myrrhs is offline   Reply With Quote
Old 09-25-2009, 09:14 AM   #7
capnttom
Junior Member
capnttom began at the beginning.
 
capnttom's Avatar
 
Posts: 9
Karma: 46
Join Date: Sep 2009
Device: Sony PRS-600
Quote:
Originally Posted by myrrhs View Post
@capnttom

You should erase the preferences for the Sony Library, to make it work again. Been there, done that.

Regards,

IEG
Thanks myrrhs. I tried the preference route and that didn't work for me.

Late last night I uninstalled/installed again and tried to run in Rosetta, which worked. After that I said "let's try to run without Rosetta." Voila, that worked. Something happened when I switched to Rosetta; damned if I understand it.

If you think about it, the v3.0 release is really beta software at best.
capnttom is offline   Reply With Quote
Old 09-25-2009, 12:50 PM   #8
Juliette
I eat books
Juliette , Klaatu Barada Niktu!Juliette , Klaatu Barada Niktu!Juliette , Klaatu Barada Niktu!Juliette , Klaatu Barada Niktu!Juliette , Klaatu Barada Niktu!Juliette , Klaatu Barada Niktu!Juliette , Klaatu Barada Niktu!Juliette , Klaatu Barada Niktu!Juliette , Klaatu Barada Niktu!Juliette , Klaatu Barada Niktu!Juliette , Klaatu Barada Niktu!
 
Juliette's Avatar
 
Posts: 602
Karma: 5124
Join Date: Jun 2009
Location: Milan, Italy
Device: Gen3 PRS-505 PRS-600 PB360 PB302 K2 Opus BebookMini OnyxBoox K3 KDXG
Just in case somebody else stumble upon this, may I suggest resetting the PRAM as a way to check if the USB is ok?
Juliette is offline   Reply With Quote
Old 09-26-2009, 10:03 AM   #9
gadgetfreak
Member
gadgetfreak began at the beginning.
 
Posts: 12
Karma: 20
Join Date: Sep 2009
Location: London, UK
Device: PRS-600
Just an update... I've tried using a different USB cable, and I'm getting the same results... works through the USB hub, and doesn't work properly when plugged directly into the USB port on the computer.

I've also just tried resetting the PRAM as recommended by Juliette, and that didn't have any effect either.
gadgetfreak is offline   Reply With Quote
Old 09-26-2009, 11:03 AM   #10
Juliette
I eat books
Juliette , Klaatu Barada Niktu!Juliette , Klaatu Barada Niktu!Juliette , Klaatu Barada Niktu!Juliette , Klaatu Barada Niktu!Juliette , Klaatu Barada Niktu!Juliette , Klaatu Barada Niktu!Juliette , Klaatu Barada Niktu!Juliette , Klaatu Barada Niktu!Juliette , Klaatu Barada Niktu!Juliette , Klaatu Barada Niktu!Juliette , Klaatu Barada Niktu!
 
Juliette's Avatar
 
Posts: 602
Karma: 5124
Join Date: Jun 2009
Location: Milan, Italy
Device: Gen3 PRS-505 PRS-600 PB360 PB302 K2 Opus BebookMini OnyxBoox K3 KDXG
Ugh. Erase pref files? Now that I think about it, it's kind of more sluggish these days, but I have my PRS-600 since last week and I can't really compare.

EDIT: to add more fun, now the software doesn't like to import files. It goes like that:

1. I add the file to the directory of books I don't buy and get on free sites (like PG).
2. I dutifully open the ebook Library and press cmd-I. Select files, give ok.
3. They don't open!
3b. The search won't work anymore!
4. Close, restart, they work.

Okay, it's nice to see that after all you can work it out, but it's still a very annoying process. Open-add-close-open. Not a nice piece of software at all, they gave us.

Last edited by Juliette; 09-26-2009 at 12:12 PM.
Juliette is offline   Reply With Quote
Old 10-03-2009, 12:38 AM   #11
karinc
Enthusiast
karinc began at the beginning.
 
karinc's Avatar
 
Posts: 25
Karma: 18
Join Date: Sep 2009
Location: winnipeg, canada
Device: Sony 505
I have installed and reinstalled NUMEROUS times, and I still can't even see any windows! I think I'll start a new thread, but I thought it would be worth adding my two cents. I have a MacBook Pro running OS 10.5.8. I've also installed Adobe Digital Editions, which shows windows, but doesn't see the Reader. The only software I can use is calibre but I can't use that with my public library. ;0(
karinc is offline   Reply With Quote
Old 10-03-2009, 08:37 AM   #12
gadgetfreak
Member
gadgetfreak began at the beginning.
 
Posts: 12
Karma: 20
Join Date: Sep 2009
Location: London, UK
Device: PRS-600
Have you tried running it in Rosetta? Does it start up if the Reader isn't plugged in?
gadgetfreak is offline   Reply With Quote
Old 10-03-2009, 01:19 PM   #13
pilotbob
Grand Sorcerer
pilotbob ought to be getting tired of karma fortunes by now.pilotbob ought to be getting tired of karma fortunes by now.pilotbob ought to be getting tired of karma fortunes by now.pilotbob ought to be getting tired of karma fortunes by now.pilotbob ought to be getting tired of karma fortunes by now.pilotbob ought to be getting tired of karma fortunes by now.pilotbob ought to be getting tired of karma fortunes by now.pilotbob ought to be getting tired of karma fortunes by now.pilotbob ought to be getting tired of karma fortunes by now.pilotbob ought to be getting tired of karma fortunes by now.pilotbob ought to be getting tired of karma fortunes by now.
 
pilotbob's Avatar
 
Posts: 19,632
Karma: 11390499
Join Date: Jan 2007
Location: Tampa, FL USA
Device: Kindle Touch
Quote:
Originally Posted by karinc View Post
I have installed and reinstalled NUMEROUS times, and I still can't even see any windows! I think I'll start a new thread, but I thought it would be worth adding my two cents. I have a MacBook Pro running OS 10.5.8. I've also installed Adobe Digital Editions, which shows windows, but doesn't see the Reader. The only software I can use is calibre but I can't use that with my public library. ;0(
What is your Mac's region and language set to?

BOb
pilotbob is offline   Reply With Quote
Old 10-03-2009, 08:40 PM   #14
karinc
Enthusiast
karinc began at the beginning.
 
karinc's Avatar
 
Posts: 25
Karma: 18
Join Date: Sep 2009
Location: winnipeg, canada
Device: Sony 505
Hi everybody. Now I see why you're not supposed to put the same thing on multiple posts! ;0) oops. My System Prefs are English and US, and I don't know what Rosetta is. Is that like Linux? It starts up fine with or without the Reader being plugged in. In either case I can't see any windows, only the menu. So I choose any option in the menu and nothing really happens.
karinc is offline   Reply With Quote
Old 10-09-2009, 02:12 AM   #15
karinc
Enthusiast
karinc began at the beginning.
 
karinc's Avatar
 
Posts: 25
Karma: 18
Join Date: Sep 2009
Location: winnipeg, canada
Device: Sony 505
Hi folks. I talked to support and he got me to do what I had done before (I thought) but perhaps it was the order in which I did the steps, or the phase of the moon... but anyhoo we got the Mac version to work. I tossed the app from the application folder and then tossed the Sony stuff from the Library and from the Preferences. Then I reinstalled and it seems to work now. I'm not going to use the Adobe software (still can't get that to "see" the Reader anyway), but I'll let everyone know in case you need to know that version 3 WILL work with the files you download from the (public) library. You just have to say "YES" when the Sony Library prompts you to make the file association with .epub files. Then you download the files you have checked out from the (public) library, and when you double-click on them the Sony software opens them up. ;0)
karinc is offline   Reply With Quote
Reply

Tags
mac, osx, prs-600, snow leopard, usb

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
adding recipes in mac osx snow leopard borjoz Calibre 2 07-30-2012 01:27 AM
Mac Snow Leopard/Sigil crash erikjacobson Sigil 22 10-29-2010 03:45 PM
Calibre 0.7.2 Mac Snow Leopard problem NAHMME Calibre 8 06-13-2010 02:29 PM
Calibre 0.7.2 Mac Snow Leopard problem NAHMME Introduce Yourself 5 06-12-2010 09:57 PM


All times are GMT -4. The time now is 03:57 PM.


MobileRead.com is a privately owned, operated and funded community.