Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre

Notices

Reply
 
Thread Tools Search this Thread
Old 07-24-2009, 11:28 PM   #1
andrewb
Junior Member
andrewb began at the beginning.
 
Posts: 5
Karma: 10
Join Date: Jul 2009
Device: PRS-505
Exclamation 0.6.0: can't install/launch

Upon attempting an install of 0.6.0, I get a failure. This is not the segmentation fault mentioned on the download page.

Here's a copy/paste from my shell:


abennett@E6400:~/calibre$ cd ../tempc
abennett@E6400:~/tempc$ sudo python -c "import urllib2; exec urllib2.urlopen('http://calibre.kovidgoyal.net/download_linux_binary_installer').read(); main()"
Enter the installation directory for calibre (Its contents will be deleted!)[/opt/calibre]: /home/abennett/calibre
Downloading calibre...
100% [================================================== ====================]
Extracting files to /home/abennett/calibre ...
Extracting application files...
Traceback (most recent call last):
File "/tmp/init.py", line 43, in <module>
File "/home/kovid/work/calibre/src/calibre/linux.py", line 8, in <module>
File "/home/kovid/work/calibre/src/calibre/customize/ui.py", line 11, in <module>
File "/home/kovid/work/calibre/src/calibre/customize/builtins.py", line 339, in <module>
File "/home/kovid/work/calibre/src/calibre/ebooks/pdf/output.py", line 18, in <module>
File "/home/kovid/work/calibre/src/calibre/ebooks/pdf/writer.py", line 22, in <module>
File "ExtensionLoader_PyQt4_QtWebKit.py", line 12, in <module>
ImportError: libphonon.so.4: cannot open shared object file: No such file or directory


And then I'll try and launch calibre from the shell:


abennett@E6400:~/tempc$ ../calibre/calibre
Traceback (most recent call last):
File "/tmp/init.py", line 43, in <module>
File "/home/kovid/work/calibre/src/calibre/gui2/__init__.py", line 16, in <module>
File "/home/kovid/work/calibre/src/calibre/ebooks/metadata/meta.py", line 11, in <module>
File "/home/kovid/work/calibre/src/calibre/customize/ui.py", line 11, in <module>
File "/home/kovid/work/calibre/src/calibre/customize/builtins.py", line 339, in <module>
File "/home/kovid/work/calibre/src/calibre/ebooks/pdf/output.py", line 18, in <module>
File "/home/kovid/work/calibre/src/calibre/ebooks/pdf/writer.py", line 22, in <module>
File "ExtensionLoader_PyQt4_QtWebKit.py", line 12, in <module>
ImportError: libphonon.so.4: cannot open shared object file: No such file or directory
abennett@E6400:~/tempc$
andrewb is offline   Reply With Quote
Old 07-24-2009, 11:29 PM   #2
andrewb
Junior Member
andrewb began at the beginning.
 
Posts: 5
Karma: 10
Join Date: Jul 2009
Device: PRS-505
I forgot to mention, this occurred on Ubuntu 9.04
andrewb is offline   Reply With Quote
Old 07-25-2009, 05:47 AM   #3
smartroad
Junior Member
smartroad doesn't littersmartroad doesn't litter
 
Posts: 4
Karma: 182
Join Date: Jan 2009
Device: PRS-505
I have just checked the repository in Ubuntu 9.04 and it lists the latest version as 0.4.143?! I am reasonably new to linux so I may be confusing this as the installed version I have is 0.5.13 according to the Calibre but Synaptic says it is this 0.4.413 installed. I am confused

Sorry don't mean to hijack your thread but thought it was relevant.
smartroad is offline   Reply With Quote
Old 07-25-2009, 07:48 AM   #4
user_none
Sigil & calibre developer
user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.
 
user_none's Avatar
 
Posts: 2,433
Karma: 950001
Join Date: Jan 2009
Location: Florida, USA
Device: Nook STR
Quote:
Originally Posted by smartroad View Post
I have just checked the repository in Ubuntu 9.04 and it lists the latest version as 0.4.143?! I am reasonably new to linux so I may be confusing this as the installed version I have is 0.5.13 according to the Calibre but Synaptic says it is this 0.4.413 installed. I am confused

Sorry don't mean to hijack your thread but thought it was relevant.
Ubuntu freezes the versions of applications they distribute for the life of a release. They either back port security fixes or do minor version bumps when necessary. 0.4.143 is the lastest they are offering though their package system. You probably used the binary installer to get 0.5.13.
user_none is offline   Reply With Quote
Old 07-25-2009, 11:23 AM   #5
kovidgoyal
creator of calibre
kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.
 
kovidgoyal's Avatar
 
Posts: 25,380
Karma: 4961459
Join Date: Oct 2006
Location: Mumbai, India
Device: Various
If you're on a 64 bit computer, you need a 32bit version of the libphonon library.
kovidgoyal is offline   Reply With Quote
Old 07-25-2009, 11:33 AM   #6
andrewb
Junior Member
andrewb began at the beginning.
 
Posts: 5
Karma: 10
Join Date: Jul 2009
Device: PRS-505
I have 32 bit Ubuntu 9.04. Had several previous versions of Calibre working successfully, but not 0.6.0. The last was 0.5.13 or 5.14.

What does libphonon come with? It's not on my distribution.

A fruitless web search pulled up a lot of references to KDE for libphonon. However, I use gnome.

Secondly, is it possible to install the previous binary version? If so, how does one do that?

Last edited by andrewb; 07-25-2009 at 11:46 AM.
andrewb is offline   Reply With Quote
Old 07-25-2009, 11:45 AM   #7
user_none
Sigil & calibre developer
user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.
 
user_none's Avatar
 
Posts: 2,433
Karma: 950001
Join Date: Jan 2009
Location: Florida, USA
Device: Nook STR
Quote:
Originally Posted by andrewb View Post
I have 32 bit Ubuntu 9.04. Had several previous versions of Calibre working successfully, but not 0.6.0. The last was 0.5.13 or 5.14.

What does libphonon come with? It's not on my distribution.
Install the phonon package. It will pull in libphonon4 and phonon-backend-gstreamer packages.
user_none is offline   Reply With Quote
Old 07-25-2009, 12:04 PM   #8
andrewb
Junior Member
andrewb began at the beginning.
 
Posts: 5
Karma: 10
Join Date: Jul 2009
Device: PRS-505
Red face

Quote:
Originally Posted by user_none View Post
Install the phonon package. It will pull in libphonon4 and phonon-backend-gstreamer packages.
sudo apt-get install libphonon

that worked, but it pulled down 30+mb of libraries and such. This dependency should be called out somewhere on the download page, along with tips for the users who aren't terribly familiar with linux to get around it.
andrewb is offline   Reply With Quote
Old 07-26-2009, 03:47 AM   #9
AprilHare
Wizard
AprilHare ought to be getting tired of karma fortunes by now.AprilHare ought to be getting tired of karma fortunes by now.AprilHare ought to be getting tired of karma fortunes by now.AprilHare ought to be getting tired of karma fortunes by now.AprilHare ought to be getting tired of karma fortunes by now.AprilHare ought to be getting tired of karma fortunes by now.AprilHare ought to be getting tired of karma fortunes by now.AprilHare ought to be getting tired of karma fortunes by now.AprilHare ought to be getting tired of karma fortunes by now.AprilHare ought to be getting tired of karma fortunes by now.AprilHare ought to be getting tired of karma fortunes by now.
 
AprilHare's Avatar
 
Posts: 2,827
Karma: 11253505
Join Date: Apr 2008
Device: Sony Reader PRS-T2
OK. I need 32 bit libphonon library to install calibre 0.6.0. How to actually install that on AMD64 (safely) is something I am unsure of.
AprilHare is offline   Reply With Quote
Old 07-26-2009, 01:52 PM   #10
Janothar
Member
Janothar began at the beginning.
 
Posts: 13
Karma: 10
Join Date: Jul 2009
Device: Kindle DX
I'm getting the same error as andrewb on an older Kubuntu: 8.04. My best guess so far is that my error is due to my using KDE 3.5 rather than KDE 4. Anyone managed to get this working on 3.5? My last Calibre was 0.5.7, and it worked perfectly.
Janothar is offline   Reply With Quote
Old 07-26-2009, 01:55 PM   #11
kovidgoyal
creator of calibre
kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.
 
kovidgoyal's Avatar
 
Posts: 25,380
Karma: 4961459
Join Date: Oct 2006
Location: Mumbai, India
Device: Various
0.6.1 will include a bundled libphonon that I hope will fix these issues
kovidgoyal is offline   Reply With Quote
Old 07-26-2009, 03:56 PM   #12
libraryaddict
Member
libraryaddict began at the beginning.
 
Posts: 10
Karma: 10
Join Date: Jun 2009
Device: Sony? convince me
Another problem: seems to fit this thread, though!

I'm trying to install calibre on my Eee pc, I've got as far as the setup, but got the response

File "setup.py", line 73
podofo_inc = '/usr/include/podofo' if islinux else \

Syntax error: invalid syntax


Can anybody tell me where I am going wrong? (I'm a complete beginner with linux, so no explanation is too simple). Thank you!
libraryaddict is offline   Reply With Quote
Old 07-26-2009, 03:58 PM   #13
kovidgoyal
creator of calibre
kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.
 
kovidgoyal's Avatar
 
Posts: 25,380
Karma: 4961459
Join Date: Oct 2006
Location: Mumbai, India
Device: Various
If you're installing from source you need to have python2.6, otherwise use the binary installer
kovidgoyal is offline   Reply With Quote
Old 07-26-2009, 04:02 PM   #14
libraryaddict
Member
libraryaddict began at the beginning.
 
Posts: 10
Karma: 10
Join Date: Jun 2009
Device: Sony? convince me
I've tried using the binary installer, but don't seem to be getting anywhere with it.

I've got python 2.6.
libraryaddict is offline   Reply With Quote
Old 07-26-2009, 04:03 PM   #15
libraryaddict
Member
libraryaddict began at the beginning.
 
Posts: 10
Karma: 10
Join Date: Jun 2009
Device: Sony? convince me
And, sorry, thanks for the help!
libraryaddict is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Txtr does not launch Rique Apple Devices 8 08-12-2010 09:59 PM
PRS-900 Sony Digital Edition Library Install, and Install, ... Hamlet53 Sony Reader 3 04-05-2010 03:29 PM
Can't Launch Calibre after fresh install hfrummer Calibre 14 11-18-2008 04:20 PM
failure to launch whymany Calibre 4 10-06-2008 07:06 AM
UK Launch when? THJahar Sony Reader 28 10-20-2006 12:30 PM


All times are GMT -4. The time now is 04:19 PM.


MobileRead.com is a privately owned, operated and funded community.