Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre

Notices

Reply
 
Thread Tools Search this Thread
Old 07-06-2009, 07:06 PM   #1
Gammaquant
Junior Member
Gammaquant began at the beginning.
 
Posts: 1
Karma: 10
Join Date: Jul 2009
Device: Sony PRS-700
PRS-700 not recognized (Win2K)

Hi there,

I just got my PRS-700 today. Unfortunately calibre 0.5.14 doesn't recognize it.

Maybe important: This is a Windows 2000 box (which I know calibre doesn't officially support; I was just hoping it might work anyway).

What happens when I plug in the reader:
A USB mass storage device is added to the system, providing 3 drives. I can browse the first one with Explorer - that seems to be the PRS's internal memory; the others are obviously the two card slots (no cards in there for now).

When starting calibre-debug -d i get the following output:
Code:
D:\Program Files\calibre>calibre-debug.exe -d
USB devices on system: [u'usb\\hub_vid_05e3&pid_0608&rev_0702', u'usb\\hub_vid_0
5e3&pid_0608&rev_0702', u'usb\\root_hub', u'usb\\root_hub', u'usb\\root_hub', u'
usb\\root_hub', u'usb\\root_hub', u'usb\\root_hub20&vid8086&pid24cd&rev0002', u'
usb\\root_hub20&vid1033&pid00e0&rev0004', u'usb\\vid_051d&pid_0002&rev_0106', u'
usb\\vid_054c&pid_031e&rev_031:']
Drives detected:
        (ID, Partitions, Drive letter)
        ('IDE\\DISKMAXTOR_6B300R0__________________________BAH41B10\\36424130394
44831202020202020202020202020', 'No mount points found')
        ('IDE\\DISKMAXTOR_6Y160P0__________________________YAR41BW0\\345944374E3
5454B202020202020202020202020', 1, u'E:\\')
        ('SCSI\\DISK&VEN_3WARE&PROD_7500-4:0_DRV_0&REV__1.0\\5&8EF4966&0&000', 2
, u'C:\\')
        ('USBSTOR\\DISK&VEN_SONY&PROD_PRS-700/UC&REV_1.00\\0800461000A3DFEF&0',
'No mount points found')
        ('USBSTOR\\DISK&VEN_SONY&PROD_PRS-700/UC:MS&REV_1.00\\0800461000A3DFEF&1
', 'No mount points found')
        ('USBSTOR\\DISK&VEN_SONY&PROD_PRS-700/UC:SD&REV_1.00\\0800461000A3DFEF&2
', 'No mount points found')
Looking for PRS500
Looking for PRS505
Looking for PRS700
Device Connected: <class 'calibre.devices.prs700.driver.PRS700'>
Trying to open device...
Traceback (most recent call last):
  File "debug.py", line 179, in <module>
  File "debug.py", line 161, in main
  File "debug.py", line 124, in debug_device_driver
  File "calibre\devices\prs505\driver.pyo", line 243, in open
  File "calibre\devices\prs505\driver.pyo", line 168, in open_windows
calibre.devices.errors.DeviceError: Unable to detect the PRS700 disk drive. Try
rebooting.
What surprises me a bit is the 'No mount points found' on the 3 drives - at the same time they're visible in Explorer as drives F:, G: and I:.

Any ideas what I could try next? Or will it simply not work on Win2K?

Thanks in advance!
Gammaquant is offline   Reply With Quote
Old 07-06-2009, 07:19 PM   #2
kovidgoyal
creator of calibre
kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.
 
kovidgoyal's Avatar
 
Posts: 25,362
Karma: 4961459
Join Date: Oct 2006
Location: Mumbai, India
Device: Various
calibre uses something called WMI to query the OS for mountpoints. Presumably that doesn't work in Win2k, hence the error
kovidgoyal is online now   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sony PRS 505 not recognized scottsan Calibre 17 06-29-2010 02:15 AM
PRS-500 not recognized by Calibre kenlkelley Calibre 5 02-28-2010 03:25 AM
PRS-500 not recognized by Calibre? TheMooch Calibre 29 12-15-2009 09:29 AM
New PRS-700: "USB Device Not Recognized" -- HELP! Cyrusx7 Sony Reader 13 09-10-2009 12:38 AM
PRS 700 not recognized on Calibre 0.4.140 + Linux eyp Calibre 4 02-26-2009 02:43 AM


All times are GMT -4. The time now is 08:23 AM.


MobileRead.com is a privately owned, operated and funded community.