Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre

Notices

Reply
 
Thread Tools Search this Thread
Old 05-11-2009, 01:13 PM   #1
Bierius
Enthusiast
Bierius began at the beginning.
 
Posts: 32
Karma: 10
Join Date: May 2006
Location: UK, Cambridge
Device: Kindle 2 / Sony PRS-505&500 / ipod touch 2nd gen
installing calibre on JJ: Help!

When I try to install Calibre (using the steps shown on the download page) on my system running Ubuntu JJ I get this error message:

calibre-0.5.11/pyqtdistutils.py", line 14, in <module>
import sipconfig, os, sys, string, glob, shutil
ImportError: No module named sipconfig

Can anyone point out what the problem is?

Cheers,
Bierius is offline   Reply With Quote
Old 05-11-2009, 05:08 PM   #2
kovidgoyal
creator of calibre
kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.
 
kovidgoyal's Avatar
 
Posts: 26,314
Karma: 5382313
Join Date: Oct 2006
Location: Mumbai, India
Device: Various
ubuntu jj has a calibre package in its repository, use that
kovidgoyal is online now   Reply With Quote
Old 05-12-2009, 03:50 AM   #3
Bierius
Enthusiast
Bierius began at the beginning.
 
Posts: 32
Karma: 10
Join Date: May 2006
Location: UK, Cambridge
Device: Kindle 2 / Sony PRS-505&500 / ipod touch 2nd gen
Excellent! Thanks
Bierius is offline   Reply With Quote
Old 06-15-2009, 02:46 AM   #4
BKR
Junior Member
BKR began at the beginning.
 
Posts: 9
Karma: 10
Join Date: Jun 2009
Location: San Diego
Device: Kindle2, Sony PRS505
Trying to Install on Fedora 10

Hello,

I'm trying to install Calibre on Fedora 10 (already searched the fedora & rpm fusion repo's...not there), I keep getting this: File "setup.py", line 50, in <module>
from pyqtdistutils import PyQtExtension, build_ext, Extension
File "/home/bob/src/calibre-0.5.14/pyqtdistutils.py", line 14, in <module>
import sipconfig, os, sys, string, glob, shutil
ImportError: No module named sipconfig. Thank you for any assistance you can provide.
BKR is offline   Reply With Quote
Old 06-15-2009, 03:19 AM   #5
netseeker
sleepless reader
netseeker ought to be getting tired of karma fortunes by now.netseeker ought to be getting tired of karma fortunes by now.netseeker ought to be getting tired of karma fortunes by now.netseeker ought to be getting tired of karma fortunes by now.netseeker ought to be getting tired of karma fortunes by now.netseeker ought to be getting tired of karma fortunes by now.netseeker ought to be getting tired of karma fortunes by now.netseeker ought to be getting tired of karma fortunes by now.netseeker ought to be getting tired of karma fortunes by now.netseeker ought to be getting tired of karma fortunes by now.netseeker ought to be getting tired of karma fortunes by now.
 
netseeker's Avatar
 
Posts: 4,770
Karma: 615335
Join Date: Jan 2008
Location: Germany, near Stuttgart
Device: Sony PRS-505, PB 360° & 302, nook wi-fi, Kindle 3
Make sure that python-sip4 as well as python-sip4-dev are installed (beside the dependencies listed on the calibre linux download page).
netseeker is offline   Reply With Quote
Old 06-15-2009, 12:11 PM   #6
BKR
Junior Member
BKR began at the beginning.
 
Posts: 9
Karma: 10
Join Date: Jun 2009
Location: San Diego
Device: Kindle2, Sony PRS505
Quote:
Originally Posted by netseeker View Post
Make sure that python-sip4 as well as python-sip4-dev are installed (beside the dependencies listed on the calibre linux download page).
Thank you for the help, but it did not work - this is what I get:
sudo yum install python-sip4 python-sip4-dev
Loaded plugins: refresh-packagekit
fedora | 2.8 kB 00:00
rpmfusion-free-updates | 2.8 kB 00:00
rpmfusion-nonfree-updates | 2.8 kB 00:00
rpmfusion-free | 2.7 kB 00:00
rpmfusion-nonfree | 2.7 kB 00:00
updates | 3.0 kB 00:00
Setting up Install Process
Parsing package install arguments
No package python-sip4 available.
No package python-sip4-dev available.
Nothing to do
BKR is offline   Reply With Quote
Old 06-15-2009, 12:39 PM   #7
netseeker
sleepless reader
netseeker ought to be getting tired of karma fortunes by now.netseeker ought to be getting tired of karma fortunes by now.netseeker ought to be getting tired of karma fortunes by now.netseeker ought to be getting tired of karma fortunes by now.netseeker ought to be getting tired of karma fortunes by now.netseeker ought to be getting tired of karma fortunes by now.netseeker ought to be getting tired of karma fortunes by now.netseeker ought to be getting tired of karma fortunes by now.netseeker ought to be getting tired of karma fortunes by now.netseeker ought to be getting tired of karma fortunes by now.netseeker ought to be getting tired of karma fortunes by now.
 
netseeker's Avatar
 
Posts: 4,770
Karma: 615335
Join Date: Jan 2008
Location: Germany, near Stuttgart
Device: Sony PRS-505, PB 360° & 302, nook wi-fi, Kindle 3
In fedora it should be just
yum install sip
yum install sip-devel
if python is already installed. And i'm not sure if sip-devel is really required.

In Ubuntu JJ the packages are called sip4, python-sip4 and python-sip4-dev.
netseeker is offline   Reply With Quote
Old 06-15-2009, 03:37 PM   #8
BKR
Junior Member
BKR began at the beginning.
 
Posts: 9
Karma: 10
Join Date: Jun 2009
Location: San Diego
Device: Kindle2, Sony PRS505
(have to sudo or su install) I have installed sip.i386, no package sip-dev avail. Ran update of PyQt4, then I got a new error: "you do not have pyrcc4 in your path. Install PyQt4 dev tools" - Done.
Re-booted and tried again..Now after I run python setup.py build && sudo python setup.py install, I get this: building 'calibre.plugins.pictureflow' extension
qmake -o Makefile.qt pictureflow.pro
unable to execute qmake: No such file or directory
error: command 'qmake' failed with exit status 1. Hmm - not sure why all the problems with this install, Calibre installed perfectly the last time I had it on this computer. I certainly appreciate the help you have been giving me.
BKR is offline   Reply With Quote
Old 06-15-2009, 04:00 PM   #9
BKR
Junior Member
BKR began at the beginning.
 
Posts: 9
Karma: 10
Join Date: Jun 2009
Location: San Diego
Device: Kindle2, Sony PRS505
found this link http://calibre.kovidgoyal.net/ticket/2571 (reopened) - will give a try.


O.K. at this point I have upgraded to Fedora 11, confirmed all dependencies, installed sip-devel, wget, PyQt4, PyQt4-devel, python-setuptools.noarch, python.setuptools-devel.noarch.

..and now this - gcc -pthread -fno-strict-aliasing -DNDEBUG -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -D_GNU_SOURCE -fPIC -fPIC -Isrc/calibre/utils/lzx -I/usr/include/python2.6 -c src/calibre/utils/lzx/lzxmodule.c -o build/temp.linux-x86_64-2.6/src/calibre/utils/lzx/lzxmodule.o
unable to execute gcc: No such file or directory
error: command 'gcc' failed with exit status 1.

Not sure what else to do or try, any help would be greatly appreciated.

Last edited by BKR; 06-15-2009 at 06:40 PM. Reason: update
BKR is offline   Reply With Quote
Old 06-16-2009, 04:31 PM   #10
BKR
Junior Member
BKR began at the beginning.
 
Posts: 9
Karma: 10
Join Date: Jun 2009
Location: San Diego
Device: Kindle2, Sony PRS505
OK this is weird, I have reinstalled fedora 10 and just when I thought I would have to look for another e-book manager, I decided to give calibre one last shot. I used the binary installer and it installed successfully Well I'm so glad calibre is working great now, but after all of this I must say I hate software (sometimes).
BKR is offline   Reply With Quote
Old 06-16-2009, 04:43 PM   #11
netseeker
sleepless reader
netseeker ought to be getting tired of karma fortunes by now.netseeker ought to be getting tired of karma fortunes by now.netseeker ought to be getting tired of karma fortunes by now.netseeker ought to be getting tired of karma fortunes by now.netseeker ought to be getting tired of karma fortunes by now.netseeker ought to be getting tired of karma fortunes by now.netseeker ought to be getting tired of karma fortunes by now.netseeker ought to be getting tired of karma fortunes by now.netseeker ought to be getting tired of karma fortunes by now.netseeker ought to be getting tired of karma fortunes by now.netseeker ought to be getting tired of karma fortunes by now.
 
netseeker's Avatar
 
Posts: 4,770
Karma: 615335
Join Date: Jan 2008
Location: Germany, near Stuttgart
Device: Sony PRS-505, PB 360° & 302, nook wi-fi, Kindle 3
BKR, i'm glad that it's finally working for you.
netseeker is offline   Reply With Quote
Old 06-17-2009, 05:56 PM   #12
Sabardeyn
Guru
Sabardeyn ought to be getting tired of karma fortunes by now.Sabardeyn ought to be getting tired of karma fortunes by now.Sabardeyn ought to be getting tired of karma fortunes by now.Sabardeyn ought to be getting tired of karma fortunes by now.Sabardeyn ought to be getting tired of karma fortunes by now.Sabardeyn ought to be getting tired of karma fortunes by now.Sabardeyn ought to be getting tired of karma fortunes by now.Sabardeyn ought to be getting tired of karma fortunes by now.Sabardeyn ought to be getting tired of karma fortunes by now.Sabardeyn ought to be getting tired of karma fortunes by now.Sabardeyn ought to be getting tired of karma fortunes by now.
 
Sabardeyn's Avatar
 
Posts: 629
Karma: 1242364
Join Date: May 2009
Location: The Right Coast
Device: PC (Calibre), Nexus 7 2013 (Moon+ Pro), HTC HD2/Leo (Freda)
Shoot, I don't remember the other topic name, but Kovid did just mention that one of the older (pre v0.6) installation methods has been discontinued.
Sabardeyn is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing Calibre on MAC arjay99 Calibre 12 06-05-2012 05:49 PM
Problem installing calibre jamic1301 Calibre 3 08-10-2011 11:05 AM
INSTALLING 0.6.29 CALIBRE VERSION nones Calibre 12 12-25-2009 11:40 AM
Calibre 0.5.14 issues when installing coplate Calibre 1 06-21-2009 09:27 PM
Problem installing Calibre Derry Calibre 1 12-23-2008 01:57 PM


All times are GMT -4. The time now is 01:11 AM.


MobileRead.com is a privately owned, operated and funded community.