Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Readers > Sony Reader

Notices

Reply
 
Thread Tools Search this Thread
Old 03-10-2009, 11:02 PM   #1
dmcgowan
Junior Member
dmcgowan began at the beginning.
 
Posts: 1
Karma: 10
Join Date: Mar 2009
Device: Sony digital reader PRS-505
What Am I Doing Wrong?

My battery is not holding a charge. I am charging my reader while it is on and I attach the USB cable to my laptop. The red light comes on and when it goes off, I disconnect, start to read, and the battery starts going down immediately. I then connect my reader to the adapter and the same things happens. HELP
dmcgowan is offline   Reply With Quote
Old 03-10-2009, 11:21 PM   #2
AnemicOak
Bookaholic
AnemicOak ought to be getting tired of karma fortunes by now.AnemicOak ought to be getting tired of karma fortunes by now.AnemicOak ought to be getting tired of karma fortunes by now.AnemicOak ought to be getting tired of karma fortunes by now.AnemicOak ought to be getting tired of karma fortunes by now.AnemicOak ought to be getting tired of karma fortunes by now.AnemicOak ought to be getting tired of karma fortunes by now.AnemicOak ought to be getting tired of karma fortunes by now.AnemicOak ought to be getting tired of karma fortunes by now.AnemicOak ought to be getting tired of karma fortunes by now.AnemicOak ought to be getting tired of karma fortunes by now.
 
AnemicOak's Avatar
 
Posts: 10,429
Karma: 28936355
Join Date: Oct 2007
Location: Minnesota
Device: HDX 8.9, AuraHD, Nook HD+, Kindle 2,3,T , Opus, Nexus7, iPhone5, etc
Sounds like maybe a bad battery. Have you contacted Sony support? They're generally quite helpful.
AnemicOak is offline   Reply With Quote
Old 03-10-2009, 11:23 PM   #3
lilac_jive
Grand Sorcerer
lilac_jive has much to be proud oflilac_jive has much to be proud oflilac_jive has much to be proud oflilac_jive has much to be proud oflilac_jive has much to be proud oflilac_jive has much to be proud oflilac_jive has much to be proud oflilac_jive has much to be proud oflilac_jive has much to be proud oflilac_jive has much to be proud oflilac_jive has much to be proud of
 
lilac_jive's Avatar
 
Posts: 5,871
Karma: 27376
Join Date: Dec 2008
Location: Pennsylvania
Device: PRS-505
Quote:
Originally Posted by AnemicOak View Post
Sounds like maybe a bad battery. Have you contacted Sony support? They're generally quite helpful.
Ditto this.
lilac_jive is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
What am I doing wrong?? artemisblossom Calibre 1 06-15-2009 04:14 PM
Its all gone wrong! Please help blackrat779 Bookeen 11 06-08-2009 04:43 AM
What have I done wrong justlizz Calibre 2 05-13-2009 06:45 PM
What is wrong now? CarmenBurden Sony Reader 1 02-15-2008 02:01 PM
They got this so wrong... cbarnett Lounge 3 10-20-2004 12:45 AM


All times are GMT -4. The time now is 09:57 PM.


MobileRead.com is a privately owned, operated and funded community.