Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre

Notices

Reply
 
Thread Tools Search this Thread
Old 10-08-2008, 09:13 AM   #1
angevin
Et In Arcadia Ego
angevin began at the beginning.
 
angevin's Avatar
 
Posts: 18
Karma: 10
Join Date: Dec 2007
Location: NewYork
Device: Sony prs-505
I can't get calibre to build/install on 64 bit linux

Hello,

I use Slamd64 linux which is a port of slackware to 64 bit processors. Anyway, calibre won't build/compile. I also have two different non-conflicting co-existing versions of QT installed QT-3.3.8 and QT 4.4.1. I don't know if that is causing the problem or not. Here is the output of ' python setup.py build':

Quote:
python setup.py build
Setup calibre version: 0.4.92
running build
running resources
Resources are up to date
running translations
Translations up to date
running gui
Images are up to date
running build_py
running egg_info
writing src/calibre.egg-info/PKG-INFO
writing top-level names to src/calibre.egg-info/top_level.txt
writing dependency_links to src/calibre.egg-info/dependency_links.txt
writing entry points to src/calibre.egg-info/entry_points.txt
reading manifest file 'src/calibre.egg-info/SOURCES.txt'
writing manifest file 'src/calibre.egg-info/SOURCES.txt'
running build_ext
building 'calibre.plugins.pictureflow' extension
qmake -o Makefile.qt pictureflow.pro
make -f Makefile.qt
g++ -c -pipe -O2 -Wall -W -D_REENTRANT -fPIC -DQT_NO_DEBUG -DQT_GUI_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/lib64/qt-4.4.1/mkspecs/linux-g++ -I. -I/usr/lib/qt-4.4.1/include/QtCore -I/usr/lib/qt-4.4.1/include/QtGui -I/usr/lib/qt-4.4.1/include -I. -I. -o pictureflow.o ../../../../src/calibre/gui2/pictureflow/pictureflow.cpp
In file included from ../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:59:
../../../../src/calibre/gui2/pictureflow/pictureflow.h:61:19: error: QWidget: No such file or directory
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:61:23: error: QBasicTimer: No such file or directory
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:62:18: error: QCache: No such file or directory
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:63:18: error: QImage: No such file or directory
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:64:21: error: QKeyEvent: No such file or directory
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:65:20: error: QPainter: No such file or directory
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:66:19: error: QPixmap: No such file or directory
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:67:18: error: QTimer: No such file or directory
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:68:19: error: QVector: No such file or directory
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:70:17: error: QTime: No such file or directory
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:76:18: error: QDebug: No such file or directory
In file included from ../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:59:
../../../../src/calibre/gui2/pictureflow/pictureflow.h:64: error: expected class-name before '{' token
../../../../src/calibre/gui2/pictureflow/pictureflow.h:65: error: ISO C++ forbids declaration of 'Q_OBJECT' with no type
../../../../src/calibre/gui2/pictureflow/pictureflow.h:67: error: expected ';' before 'public'
../../../../src/calibre/gui2/pictureflow/pictureflow.h:69: error: 'QImage' does not name a type
../../../../src/calibre/gui2/pictureflow/pictureflow.h:70: error: 'QString' does not name a type
../../../../src/calibre/gui2/pictureflow/pictureflow.h:73: error: expected primary-expression before 'void'
../../../../src/calibre/gui2/pictureflow/pictureflow.h:73: error: ISO C++ forbids declaration of 'signals' with no type
../../../../src/calibre/gui2/pictureflow/pictureflow.h:73: error: expected ';' before 'void'
../../../../src/calibre/gui2/pictureflow/pictureflow.h:90: error: expected class-name before '{' token
../../../../src/calibre/gui2/pictureflow/pictureflow.h:91: error: 'Q_OBJECT' does not name a type
../../../../src/calibre/gui2/pictureflow/pictureflow.h:116: error: 'QSize' does not name a type
../../../../src/calibre/gui2/pictureflow/pictureflow.h:121: error: 'QSize' has not been declared
../../../../src/calibre/gui2/pictureflow/pictureflow.h:143: error: 'QImage' does not name a type
../../../../src/calibre/gui2/pictureflow/pictureflow.h:150: error: expected `:' before 'slots'
../../../../src/calibre/gui2/pictureflow/pictureflow.h:156: error: expected primary-expression before 'void'
../../../../src/calibre/gui2/pictureflow/pictureflow.h:156: error: ISO C++ forbids declaration of 'slots' with no type
../../../../src/calibre/gui2/pictureflow/pictureflow.h:156: error: expected ';' before 'void'
../../../../src/calibre/gui2/pictureflow/pictureflow.h:187: error: expected primary-expression before 'void'
../../../../src/calibre/gui2/pictureflow/pictureflow.h:187: error: ISO C++ forbids declaration of 'signals' with no type
../../../../src/calibre/gui2/pictureflow/pictureflow.h:187: error: expected ';' before 'void'
../../../../src/calibre/gui2/pictureflow/pictureflow.h:193: error: 'QPaintEvent' has not been declared
../../../../src/calibre/gui2/pictureflow/pictureflow.h:194: error: 'QKeyEvent' has not been declared
../../../../src/calibre/gui2/pictureflow/pictureflow.h:195: error: 'QMouseEvent' has not been declared
../../../../src/calibre/gui2/pictureflow/pictureflow.h:196: error: 'QMouseEvent' has not been declared
../../../../src/calibre/gui2/pictureflow/pictureflow.h:197: error: 'QMouseEvent' has not been declared
../../../../src/calibre/gui2/pictureflow/pictureflow.h:198: error: 'QResizeEvent' has not been declared
../../../../src/calibre/gui2/pictureflow/pictureflow.h:199: error: 'QTimerEvent' has not been declared
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:324: error: 'QSize' does not name a type
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:325: error: 'QSize' has not been declared
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:330: error: 'QImage' does not name a type
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:331: error: expected ',' or '...' before '&' token
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:331: error: ISO C++ forbids declaration of 'QImage' with no type
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:350: error: 'QImage' does not name a type
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:351: error: 'QBasicTimer' does not name a type
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:355: error: 'QPoint' does not name a type
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:356: error: 'QPoint' does not name a type
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:357: error: 'QTime' does not name a type
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:375: error: ISO C++ forbids declaration of 'QVector' with no type
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:375: error: expected ';' before '<' token
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:376: error: ISO C++ forbids declaration of 'QVector' with no type
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:376: error: expected ';' before '<' token
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:378: error: ISO C++ forbids declaration of 'QVector' with no type
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:378: error: expected ';' before '<' token
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:384: error: 'QImage' does not name a type
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:385: error: ISO C++ forbids declaration of 'QCache' with no type
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:385: error: expected ';' before '<' token
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:386: error: 'QTimer' does not name a type
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:394: error: 'QRect' does not name a type
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:395: error: ISO C++ forbids declaration of 'QImage' with no type
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:395: error: expected ';' before '*' token
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp: In constructor 'PictureFlowPrivate::PictureFlowPrivate(PictureFlo w*, int)':
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:417: error: 'triggerTimer' was not declared in this scope
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:419: error: 'QObject' has not been declared
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:419: error: 'timeout' was not declared in this scope
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:419: error: 'SIGNAL' was not declared in this scope
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:419: error: 'SLOT' was not declared in this scope
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp: In member function 'void PictureFlowPrivate::dataChanged()':
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:426: error: 'surfaceCache' was not declared in this scope
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp: In member function 'void PictureFlowPrivate::setImages(FlowImages*)':
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:433: error: 'QObject' has not been declared
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:433: error: 'SIGNAL' was not declared in this scope
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:433: error: 'SLOT' was not declared in this scope
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:436: error: 'QObject' has not been declared
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp: In member function 'int PictureFlowPrivate::slideCount() const':
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:441: error: 'class FlowImages' has no member named 'count'
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp: At global scope:
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:444: error: 'QSize' does not name a type
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:449: error: variable or field 'setSlideSize' declared void
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:449: error: 'QSize' was not declared in this scope
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp: In member function 'void PictureFlowPrivate::setZoomFactor(int)':
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:468: error: 'buffer' was not declared in this scope
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp: At global scope:
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:472: error: 'QImage' does not name a type
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp: In member function 'void PictureFlowPrivate::setCurrentSlide(int)':
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:490: error: 'class FlowImages' has no member named 'count'
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:490: error: 'qBound' was not declared in this scope
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp: In member function 'void PictureFlowPrivate::showPrevious()':
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:510: error: 'qMax' was not declared in this scope
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp: In member function 'void PictureFlowPrivate::showNext()':
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:518: error: 'class FlowImages' has no member named 'count'
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:526: error: 'class FlowImages' has no member named 'count'
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:526: error: 'qMin' was not declared in this scope
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp: In member function 'void PictureFlowPrivate::showSlide(int)':
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:532: error: 'qMax' was not declared in this scope
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:533: error: 'class FlowImages' has no member named 'count'
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:533: error: 'qMin' was not declared in this scope
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp: In member function 'void PictureFlowPrivate::resetSlides()':
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:557: error: 'leftSlides' was not declared in this scope
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:569: error: 'rightSlides' was not declared in this scope
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp: At global scope:
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:585: error: 'QImage' does not name a type
../../../../src/calibre/gui2/pictureflow/pictureflow.cpp:632: error: expected constructor, destructor, or type conversion before '*' token
make: *** [pictureflow.o] Error 1
error: command 'make' failed with exit status 2

Last edited by angevin; 10-08-2008 at 01:53 PM.
angevin is offline   Reply With Quote
Old 10-08-2008, 09:32 AM   #2
angevin
Et In Arcadia Ego
angevin began at the beginning.
 
angevin's Avatar
 
Posts: 18
Karma: 10
Join Date: Dec 2007
Location: NewYork
Device: Sony prs-505
I have a new error messages since I worked out the previous problem I had-- I just edited the above post to reflect that fact.

Last edited by angevin; 10-08-2008 at 01:55 PM.
angevin is offline   Reply With Quote
 
Advertisement
Old 10-08-2008, 02:26 PM   #3
kovidgoyal
creator of calibre
kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.
 
kovidgoyal's Avatar
 
Posts: 26,450
Karma: 5383257
Join Date: Oct 2006
Location: Mumbai, India
Device: Various
do you have the package pyqt4-dev installed?
kovidgoyal is offline   Reply With Quote
Old 10-08-2008, 03:13 PM   #4
angevin
Et In Arcadia Ego
angevin began at the beginning.
 
angevin's Avatar
 
Posts: 18
Karma: 10
Join Date: Dec 2007
Location: NewYork
Device: Sony prs-505
Question

Quote:
Originally Posted by kovidgoyal View Post
do you have the package pyqt4-dev installed?
I have pyqt4-4.4.2 installed . Do you mean I need the development snapshot of pyqt4 aka the 4.4.4 version instead of the stable 4.4.2 or that I need both installed? Your website states that the dependency for the minimum version is 4.4.2 but then it also states that I need the -dev package too which is confusing to me. Also, if I do need the development packages of these packages is it just the python packages or all the packages that I need the development versions of ?

Last edited by angevin; 10-08-2008 at 03:29 PM.
angevin is offline   Reply With Quote
Old 10-08-2008, 03:17 PM   #5
kovidgoyal
creator of calibre
kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.
 
kovidgoyal's Avatar
 
Posts: 26,450
Karma: 5383257
Join Date: Oct 2006
Location: Mumbai, India
Device: Various
the -dev packages means the packages that are needed to compile software. They have names like pyqt4-dev-4.4.2
kovidgoyal is offline   Reply With Quote
Old 10-08-2008, 03:59 PM   #6
angevin
Et In Arcadia Ego
angevin began at the beginning.
 
angevin's Avatar
 
Posts: 18
Karma: 10
Join Date: Dec 2007
Location: NewYork
Device: Sony prs-505
Quote:
Originally Posted by kovidgoyal View Post
the -dev packages means the packages that are needed to compile software. They have names like pyqt4-dev-4.4.2
slackware and slamd64 have no precompiled packages named -dev for such tools. Third party packages in slackware/slamd64 are compiled by hand. This -dev naming convention for pre-canned binaries seems like Debian and Fedora thing to me.

Anyway, from the Debian repository it says this :

Quote:
Development tools for PyQt4

This package contains various support tools for PyQt4 developers:

* a user interface compiler (pyuic4)
* a resource file generator (pyrcc4)
* a translation string finder (pylupdate)
I have pyuic4,pyrcc4 and pylupdate installed so I do have the development packages you are asking about allready installed on my system. They are located in /usr/bin on my system.

_

Last edited by angevin; 10-08-2008 at 04:12 PM.
angevin is offline   Reply With Quote
Old 10-08-2008, 04:01 PM   #7
kovidgoyal
creator of calibre
kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.
 
kovidgoyal's Avatar
 
Posts: 26,450
Karma: 5383257
Join Date: Oct 2006
Location: Mumbai, India
Device: Various
But you dont have the header files that are needed for compilation to succeed. Note that you also need the qt4 development package installed. That error message indicates you're missing the qt4 development files.
kovidgoyal is offline   Reply With Quote
Old 10-08-2008, 04:57 PM   #8
angevin
Et In Arcadia Ego
angevin began at the beginning.
 
angevin's Avatar
 
Posts: 18
Karma: 10
Join Date: Dec 2007
Location: NewYork
Device: Sony prs-505
Quote:
Originally Posted by kovidgoyal View Post
But you dont have the header files that are needed for compilation to succeed. Note that you also need the qt4 development package installed. That error message indicates you're missing the qt4 development files.
In general, slackware/slamd64 does not separate headers and stuff into -dev packages like other distros seem to like doing, so if one installs a slackware/slamd64 package then one has everything one needs and there is no need for a seperate -dev package.

For instance above it says it can't find QWidget, QCache and QBasicTimer include header files etc... etc.. but these are all installed on my system :

/usr/lib64/qt-4.4.1/include/QtCore/QCache

/usr/lib64/qt-4.4.1/include/QtGui/QWidget

/usr/lib64/qt-4.4.1/include/QtCore/QBasicTimer

etc.. etc..

Also, I have symbolic link between /usr/lib64/qt-4.4.1 and /usr/lib64/qt so it's not like it's in some hard to find arcane directory or something.

Last edited by angevin; 10-08-2008 at 05:00 PM.
angevin is offline   Reply With Quote
Old 10-08-2008, 05:10 PM   #9
kovidgoyal
creator of calibre
kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.
 
kovidgoyal's Avatar
 
Posts: 26,450
Karma: 5383257
Join Date: Oct 2006
Location: Mumbai, India
Device: Various
Hmm, sorry you're going to have to ask on your distro's forums for help, I'm out of ideas.
kovidgoyal is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Build calibre-0.7.17 install issue PCreighton Calibre 1 09-03-2010 11:04 PM
Calibre 0.6.40 source - segfault after successful build on Linux Megatron-UK Calibre 7 02-20-2010 05:29 AM
New Calibre install won't start/seg faults on Ubuntu 9.10 64-bit lizajane999 Calibre 4 02-06-2010 03:42 PM
Calibre 0.6.4 Linux Install Issue notsure Calibre 4 08-03-2009 07:47 PM
Calibre will build but won't install on bluewhite64 linux distro angevin Calibre 5 10-18-2008 11:20 PM


All times are GMT -4. The time now is 04:11 PM.


MobileRead.com is a privately owned, operated and funded community.