Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre > Devices

Notices

Reply
 
Thread Tools Search this Thread
Old 08-25-2014, 02:50 PM   #1
nataltom
Junior Member
nataltom began at the beginning.
 
Posts: 6
Karma: 10
Join Date: Aug 2014
Location: France
Device: none
Calibre 2.0 Crashing at start up

Hello

Sorry for my english, I'm french.

I installed the new version of caliber. I have a problem with cons. Every time I start the program, there is an error message. (no problem with the old version)
I've uninstalled everything, cleaned the directory and did a clean install is the same every time.

The program has an error with the qt5core.dll

I'm still using windows xp

If you have an idea, I'm interested.

thank you

nataltom is offline   Reply With Quote
Old 08-25-2014, 03:03 PM   #2
chaley
"chaley", not "charley"
chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.
 
Posts: 5,778
Karma: 1212746
Join Date: Jan 2010
Location: France
Device: Many android devices
The download page for calibre says:
Quote:
calibre 2.x uses Qt 5 which is known to be incompatible with some Windows XP machines. If you are using Windows XP and calibre crashes soon after startup, use calibre 1.48, which works with all Windows XP machines, from here. Simply un-install calibre 2.x and install 1.48, doing so will not affect your books/settings.
In fact, the problems are so severe that starting with the release coming on Friday 29/8, calibre 2.x will refuse to install on XP. Your only choices are to stay on 1.48 or to upgrade Windows.

Pour être clair -- calibre 2.x ne fonctionne pas sur XP. À partir de vendredi 29/8, calibre va refuser de s’installer sur XP. Vos choix sont 1) rester sur 1.48, ou 2) installer windows vista, 7, ou 8.
chaley is offline   Reply With Quote
Old 08-25-2014, 03:29 PM   #3
nataltom
Junior Member
nataltom began at the beginning.
 
Posts: 6
Karma: 10
Join Date: Aug 2014
Location: France
Device: none
Hello

Thank you for your reply.

I made an installation on another machine also installed xp and there does it work correctly. The version will stop working the same 29/8 on computers that work properly?

Is there still a way to make the program run under XP?
nataltom is offline   Reply With Quote
Old 08-25-2014, 04:11 PM   #4
chaley
"chaley", not "charley"
chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.
 
Posts: 5,778
Karma: 1212746
Join Date: Jan 2010
Location: France
Device: Many android devices
Quote:
Originally Posted by nataltom View Post
Hello

Thank you for your reply.

I made an installation on another machine also installed xp and there does it work correctly. The version will stop working the same 29/8 on computers that work properly?

Is there still a way to make the program run under XP?
Starting with the next release, calibre 2.x will refuse to install or run on any computer running Windows XP. That might change in the future if Kovid finds what the problems are, but I don't think that there is much chance of this happening.
chaley is offline   Reply With Quote
Old 08-25-2014, 04:44 PM   #5
Katsunami
Wizard
Katsunami ought to be getting tired of karma fortunes by now.Katsunami ought to be getting tired of karma fortunes by now.Katsunami ought to be getting tired of karma fortunes by now.Katsunami ought to be getting tired of karma fortunes by now.Katsunami ought to be getting tired of karma fortunes by now.Katsunami ought to be getting tired of karma fortunes by now.Katsunami ought to be getting tired of karma fortunes by now.Katsunami ought to be getting tired of karma fortunes by now.Katsunami ought to be getting tired of karma fortunes by now.Katsunami ought to be getting tired of karma fortunes by now.Katsunami ought to be getting tired of karma fortunes by now.
 
Katsunami's Avatar
 
Posts: 3,557
Karma: 15397267
Join Date: Mar 2008
Location: Netherlands
Device: Kindle Paperwhite
Quote:
Originally Posted by chaley View Post
Starting with the next release, calibre 2.x will refuse to install or run on any computer running Windows XP. That might change in the future if Kovid finds what the problems are, but I don't think that there is much chance of this happening.
And even if he does find what the problems are, he might not be able to fix them. He might not even *want* to fix them, even if he can; Microsoft finally stopped supporting XP, which is over 13 years old now, so it is expected that software developers will also; they already have, or will in the very near future.

It is not a good idea to stay on Windows XP, except if you have a very good reason. Think about it; Windows 7 is 5 years old already, Windows 8 is 2 years old, and Windows 9 is coming in March/May next year... XP is getting *really* long in the tooth now.

Last edited by Katsunami; 08-25-2014 at 05:00 PM.
Katsunami is offline   Reply With Quote
Old 08-25-2014, 04:52 PM   #6
montalex
Addict
montalex ought to be getting tired of karma fortunes by now.montalex ought to be getting tired of karma fortunes by now.montalex ought to be getting tired of karma fortunes by now.montalex ought to be getting tired of karma fortunes by now.montalex ought to be getting tired of karma fortunes by now.montalex ought to be getting tired of karma fortunes by now.montalex ought to be getting tired of karma fortunes by now.montalex ought to be getting tired of karma fortunes by now.montalex ought to be getting tired of karma fortunes by now.montalex ought to be getting tired of karma fortunes by now.montalex ought to be getting tired of karma fortunes by now.
 
Posts: 391
Karma: 517398
Join Date: Mar 2010
Device: Kindle 2i, Kindle Keyboard 3G
I'm running Windows 7, and I have the same problem. I do have a very old Pentium IV computer, though.
montalex is offline   Reply With Quote
Old 08-25-2014, 04:53 PM   #7
nataltom
Junior Member
nataltom began at the beginning.
 
Posts: 6
Karma: 10
Join Date: Aug 2014
Location: France
Device: none
Microsoft actually decided to stop windows xp and that's a shame because it was a very good OS.

I will stay on the old version still hoping that the program developer to find a solution for XP is still widely used.

Thank you for your answers.

nataltom is offline   Reply With Quote
Old 08-25-2014, 05:14 PM   #8
chaley
"chaley", not "charley"
chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.
 
Posts: 5,778
Karma: 1212746
Join Date: Jan 2010
Location: France
Device: Many android devices
Quote:
Originally Posted by montalex View Post
I'm running Windows 7, and I have the same problem. I do have a very old Pentium IV computer, though.
Qt5, included in calibre 2.x, requires the SSE2 instruction set, introduced by Intel in 2001 and AMD in 2003. If your processor does not support SSE2 then you must stay with calibre 1.48.

According to this web page http://www.mathworks.com/matlabcentr...or-supports-it there is a program you can run to check if your processor supports SSE2.

Note that if you are running Win64 then you might need the SSE2 extended instruction set, introduced by AMD in 2003 and Intel in 2004.
chaley is offline   Reply With Quote
Old 08-25-2014, 05:15 PM   #9
chaley
"chaley", not "charley"
chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.
 
Posts: 5,778
Karma: 1212746
Join Date: Jan 2010
Location: France
Device: Many android devices
Quote:
Originally Posted by nataltom View Post
Microsoft actually decided to stop windows xp and that's a shame because it was a very good OS.

I will stay on the old version still hoping that the program developer to find a solution for XP is still widely used.
My guess is that you will wait for a long time ...
chaley is offline   Reply With Quote
Old 08-25-2014, 05:41 PM   #10
nataltom
Junior Member
nataltom began at the beginning.
 
Posts: 6
Karma: 10
Join Date: Aug 2014
Location: France
Device: none
Quote:
Originally Posted by chaley View Post
Qt5, included in calibre 2.x, requires the SSE2 instruction set, introduced by Intel in 2001 and AMD in 2003. If your processor does not support SSE2 then you must stay with calibre 1.48.

According to this web page http://www.mathworks.com/matlabcentr...or-supports-it there is a program you can run to check if your processor supports SSE2.

Note that if you are running Win64 then you might need the SSE2 extended instruction set, introduced by AMD in 2003 and Intel in 2004.
At first I just did the test, my processor supports SSE2
nataltom is offline   Reply With Quote
Old 08-26-2014, 06:25 PM   #11
JSWolf
Resident Curmudgeon
JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.
 
JSWolf's Avatar
 
Posts: 37,772
Karma: 18492088
Join Date: Nov 2006
Location: Roslindale, Massachusetts
Device: Sony Reader PRS-650, iPad, nook STR
Quote:
Originally Posted by chaley View Post
My guess is that you will wait for a long time ...
That would be forever.
JSWolf is offline   Reply With Quote
Old 08-26-2014, 06:46 PM   #12
BetterRed
null operator
BetterRed ought to be getting tired of karma fortunes by now.BetterRed ought to be getting tired of karma fortunes by now.BetterRed ought to be getting tired of karma fortunes by now.BetterRed ought to be getting tired of karma fortunes by now.BetterRed ought to be getting tired of karma fortunes by now.BetterRed ought to be getting tired of karma fortunes by now.BetterRed ought to be getting tired of karma fortunes by now.BetterRed ought to be getting tired of karma fortunes by now.BetterRed ought to be getting tired of karma fortunes by now.BetterRed ought to be getting tired of karma fortunes by now.BetterRed ought to be getting tired of karma fortunes by now.
 
Posts: 3,805
Karma: 2698649
Join Date: Mar 2012
Location: NSW Australia
Device: none
Quote:
Originally Posted by JSWolf View Post
That would be forever.
Not necessarily see ==>> GoodSync Version News- Windows

Quote:
Version 9.9.4 Aug 15, 2014
...
* Make GoodSync work on old Athlon and AMD processor do not have SSE2 instructions.
Of course, I have no idea what they actually did, nor if it actually works

I noticed the SSE2 note when I downloaded latest GoodSynch Tuesday evening.

BR
BetterRed is online now   Reply With Quote
Old 08-26-2014, 06:54 PM   #13
Katsunami
Wizard
Katsunami ought to be getting tired of karma fortunes by now.Katsunami ought to be getting tired of karma fortunes by now.Katsunami ought to be getting tired of karma fortunes by now.Katsunami ought to be getting tired of karma fortunes by now.Katsunami ought to be getting tired of karma fortunes by now.Katsunami ought to be getting tired of karma fortunes by now.Katsunami ought to be getting tired of karma fortunes by now.Katsunami ought to be getting tired of karma fortunes by now.Katsunami ought to be getting tired of karma fortunes by now.Katsunami ought to be getting tired of karma fortunes by now.Katsunami ought to be getting tired of karma fortunes by now.
 
Katsunami's Avatar
 
Posts: 3,557
Karma: 15397267
Join Date: Mar 2008
Location: Netherlands
Device: Kindle Paperwhite
Quote:
Originally Posted by BetterRed View Post
Not necessarily see ==>> GoodSync Version News- Windows
Possibly they have compiled the program in such a way that it uses SSE2 if it is available, and doesn't use it if it's not. Maybe this is possible with QT5 as well, but to be honest, I think it's not worth the trouble.

Why support a 13 year old operating system running on hardware that is even older than that (as SSE2 was introduced in 2001)? I'm not one for upgrading ASAP; the computer I'm typing this on is 6 years old (but has a quad-core, SSD, 8GB RAM, and Windows 7 x64). That's somewhat old, but 13 years is ancient history in computing.
Katsunami is offline   Reply With Quote
Old 08-26-2014, 07:16 PM   #14
BetterRed
null operator
BetterRed ought to be getting tired of karma fortunes by now.BetterRed ought to be getting tired of karma fortunes by now.BetterRed ought to be getting tired of karma fortunes by now.BetterRed ought to be getting tired of karma fortunes by now.BetterRed ought to be getting tired of karma fortunes by now.BetterRed ought to be getting tired of karma fortunes by now.BetterRed ought to be getting tired of karma fortunes by now.BetterRed ought to be getting tired of karma fortunes by now.BetterRed ought to be getting tired of karma fortunes by now.BetterRed ought to be getting tired of karma fortunes by now.BetterRed ought to be getting tired of karma fortunes by now.
 
Posts: 3,805
Karma: 2698649
Join Date: Mar 2012
Location: NSW Australia
Device: none
There are enterprises that use Windows Server 2003, and many will continue to use it after it reaches its EOL next year. I know of a significant multinational corporation that still has some LAN Manager servers dotted around the planet

And IIRC the POS version of XP EOL is 2019.

BR
BetterRed is online now   Reply With Quote
Old 08-26-2014, 09:00 PM   #15
kapaka
Member
kapaka began at the beginning.
 
Posts: 15
Karma: 10
Join Date: Dec 2008
Device: Hanlin Papyre
I have calibre in a machine that still uses server2003
Guess I am stuck with 1.48. But it's not the only app I have stopped upgrading, so it's OK
Thanks for calibre
kapaka is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
sigil 7.4 and maverick crashing crashing crashing Carrigboy Sigil 103 09-04-2014 12:47 PM
Calibre Crashing at start up Gazza1158 Calibre 6 08-24-2014 07:25 AM
Calibre wont start (first time start up) Mike Railton Devices 15 05-25-2012 03:14 AM
Calibre Crashing on Start - Content Server Tkosh Calibre 2 01-06-2012 09:57 AM
Connect Reader Crashing- won't start eppythacher Sony Reader 5 01-14-2010 09:58 PM


All times are GMT -4. The time now is 01:29 AM.


MobileRead.com is a privately owned, operated and funded community.