Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Readers > Kobo Reader > Kobo Developer's Corner

Notices

Reply
 
Thread Tools Search this Thread
Old 01-04-2014, 05:03 PM   #1
axellec
Junior Member
axellec began at the beginning.
 
Posts: 8
Karma: 10
Join Date: Jan 2014
Device: Kobo Aura HD
Can't telnet / dropbear: no IP address seen for device

Hello,
I'm trying to telnet to my new Kobo Aura HD but it does not work: I can't see my ereader with an nmap 192.168.0.10-30 (that's the range where it should be).

I also tried dropbear, no more success.

This is what I did.
I created a KoboRoot.tgz to drop in .kobo with
etc/init.d/rcS: added to the end:

Code:
/mnt/onboard/run.sh &
mkdir -p /dev/pts
mount -t devpts devpts /dev/pts
etc/inittab

Code:
::sysinit:/etc/init.d/rcS
::respawn:/sbin/getty -L ttymxc0 115200 vt100
::ctrlaltdel:/sbin/reboot
::shutdown:/bin/umount -a -r
::restart:/sbin/init
::respawn:/usr/sbin/inetd -f /etc/inetd.conf
etc/inetd.conf: my inetd.conf differs from the ones I usually see on the net.
I tried this:
Code:
# <service_name> <sock_type> <proto> <flags> <user> <server_path> <args>
#ftp    stream  tcp     nowait  root    /usr/sbin/tcpd          in.ftpd
telnet  stream  tcp     nowait  root    /bin/busybox telnetd -i
or this:
Code:
# <service_name> <sock_type> <proto> <flags> <user> <server_path> <args>
ftp     stream  tcp     nowait  root    /usr/sbin/tcpd          in.ftpd
telnet  stream  tcp     nowait  root    /usr/sbin/telnetd       telnetd -l /bin/login
My run.sh contains:
Code:
cat /proc/cpuinfo > /mnt/onboard/CPUINFO
cp /etc/inittab /mnt/onboard
cp /etc/inetd.conf /mnt/onboard
/sbin/ifconfig -a > /mnt/onboard/NETWORK
/mnt/onboard/dropbear/dropbear -r /mnt/onboard/dropbear/kobokey
echo "DONE" >> /mnt/onboard/CPUINFO
I get the expected output in CPUINFO, including the trailing DONE.

Code:
Processor	: ARMv7 Processor rev 5 (v7l)
BogoMIPS	: 999.42
Features	: swp half thumb fastmult vfp edsp neon vfpv3 
CPU implementer	: 0x41
CPU architecture: 7
CPU variant	: 0x2
CPU part	: 0xc08
CPU revision	: 5

Hardware	: Freescale MX50 Reference Design Platform
Revision	: 50011
Serial		: 0000000000000000
DONE
I am a bit surprised that NETWORK only shows lo:
Code:
lo        Link encap:Local Loopback  
          LOOPBACK  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
But perhaps network is not set at the time run.sh is run.

Anyway, in the end, impossible to telnet my device. I don't see any host up with a possible IP address.

Of course, my device is connected to my local wifi, and that's working.

Can anyone suggest an idea?



Thanks.

PS. I have a Kobo Aura HD with 3.1.1 firmware.
SerialNumber: N204B3xxxx...
axellec is offline   Reply With Quote
Old 01-04-2014, 05:20 PM   #2
surquizu
Addict
surquizu is out to avenge the death of his or her father, Domingo Montoya.surquizu is out to avenge the death of his or her father, Domingo Montoya.surquizu is out to avenge the death of his or her father, Domingo Montoya.surquizu is out to avenge the death of his or her father, Domingo Montoya.surquizu is out to avenge the death of his or her father, Domingo Montoya.surquizu is out to avenge the death of his or her father, Domingo Montoya.surquizu is out to avenge the death of his or her father, Domingo Montoya.surquizu is out to avenge the death of his or her father, Domingo Montoya.surquizu is out to avenge the death of his or her father, Domingo Montoya.surquizu is out to avenge the death of his or her father, Domingo Montoya.surquizu is out to avenge the death of his or her father, Domingo Montoya.
 
surquizu's Avatar
 
Posts: 242
Karma: 34776
Join Date: Jun 2008
Location: Zaragoza (Spain)
Device: prs-505, kobo auraHD, kobo auraH2O
Telnet works perfectly on my auraHD (3.1.1) with Wi-Fi and USB. I followed the instructions in these posts:

WIFI:
http://www.mobileread.com/forums/sho...et#post2700881

USB (PBCHESS):
http://www.mobileread.com/forums/sho...d.php?t=201632

http://www.mobileread.com/forums/sho...1&postcount=48

surquizu is offline   Reply With Quote
Old 01-05-2014, 05:54 AM   #3
axellec
Junior Member
axellec began at the beginning.
 
Posts: 8
Karma: 10
Join Date: Jan 2014
Device: Kobo Aura HD
SSH works :)

Okay I solved my problem:

- not seeing the device with nmap: looks like the device wasn't connected straight away to the wifi. If I use the browser once, then it connects, gets an IP address, and then no problem I see my device.

- telnet port not open, but I don't really care, because ssh is working and that's what I really want. So actually, I removed telnet and ftp.

Thanks!
axellec is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help from those who have telnet access giorgio130 Kobo Developer's Corner 10 06-12-2013 03:03 PM
360 Plus How to enter address into browser address field? Hope PocketBook 15 04-06-2012 12:07 PM
SSH keys with dropbear? enn Kindle Developer's Corner 2 10-07-2010 12:54 AM
iLiad PC and iliad together: ssh? dropbear? daudi iRex Developer's Corner 10 01-13-2008 09:47 AM
iLiad dropbear ssh: how to change root password? daudi iRex Developer's Corner 2 01-10-2008 04:49 PM


All times are GMT -4. The time now is 08:25 PM.


MobileRead.com is a privately owned, operated and funded community.