Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Sigil

Notices

Reply
 
Thread Tools Search this Thread
Old 05-03-2013, 07:15 PM   #1
Gian Carlo M.
Junior Member
Gian Carlo M. began at the beginning.
 
Posts: 8
Karma: 10
Join Date: May 2013
Device: none
Sigil 0.7 - Unable to start with WindowsXP

I can't migrate from Sigil 0.6 to Sigil 0.7. While Sigil 0.6.2 works OK on my PC with Windows XP SP2, I'm not able to use Sigil 0.7. I tried with versions 0.7.0, 0.7.1, 0.7.2. I also tried with portable versions. Unfortunately the program doesn't start, I can't imagine why.
Did anybody experience the same problem and find a solution?
Thank you.
Gian Carlo M. is offline   Reply With Quote
Old 05-03-2013, 07:23 PM   #2
theducks
Grand Sorcerer
theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.
 
theducks's Avatar
 
Posts: 14,619
Karma: 5628865
Join Date: Aug 2009
Location: (The original) Silicon Valley, USA
Device: Galaxy Tab 2, Astak Pocket Pro, K4NT
Quote:
Originally Posted by Gian Carlo M. View Post
I can't migrate from Sigil 0.6 to Sigil 0.7. While Sigil 0.6.2 works OK on my PC with Windows XP SP2, I'm not able to use Sigil 0.7. I tried with versions 0.7.0, 0.7.1, 0.7.2. I also tried with portable versions. Unfortunately the program doesn't start, I can't imagine why.
Did anybody experience the same problem and find a solution?
Thank you.
SP2? SP3 has been out for years and ONLY SP3 can get current M$ security patches. (SP2 is now unsupported).

Sigil 7 uses QT5... That may be your issue. One of the building blocks may not be compatible with SP2.
theducks is offline   Reply With Quote
 
Enthusiast
Old 05-03-2013, 07:54 PM   #3
yekim54
What the Dog Saw
yekim54 ought to be getting tired of karma fortunes by now.yekim54 ought to be getting tired of karma fortunes by now.yekim54 ought to be getting tired of karma fortunes by now.yekim54 ought to be getting tired of karma fortunes by now.yekim54 ought to be getting tired of karma fortunes by now.yekim54 ought to be getting tired of karma fortunes by now.yekim54 ought to be getting tired of karma fortunes by now.yekim54 ought to be getting tired of karma fortunes by now.yekim54 ought to be getting tired of karma fortunes by now.yekim54 ought to be getting tired of karma fortunes by now.yekim54 ought to be getting tired of karma fortunes by now.
 
yekim54's Avatar
 
Posts: 305
Karma: 981684
Join Date: Jul 2008
Location: Dunn Loring
Device: Sony PRS-505, PRS-650, Asus TF101
Quote:
Originally Posted by Gian Carlo M. View Post
I can't migrate from Sigil 0.6 to Sigil 0.7. While Sigil 0.6.2 works OK on my PC with Windows XP SP2, I'm not able to use Sigil 0.7. I tried with versions 0.7.0, 0.7.1, 0.7.2. I also tried with portable versions. Unfortunately the program doesn't start, I can't imagine why.
Did anybody experience the same problem and find a solution?
Thank you.
I have 3 PCs with Windows XP SP3 and Sigil 0.7.2 only runs on one of them...the one with 2 GB RAM. The other two PCs only have 1 GB RAM and Sigil 0.7.2 will not start. How much RAM do you have on your PC?
yekim54 is offline   Reply With Quote
Old 05-03-2013, 08:22 PM   #4
theducks
Grand Sorcerer
theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.
 
theducks's Avatar
 
Posts: 14,619
Karma: 5628865
Join Date: Aug 2009
Location: (The original) Silicon Valley, USA
Device: Galaxy Tab 2, Astak Pocket Pro, K4NT
Another known NO GO is old AMD processors that don't have SSE2

Last edited by theducks; 05-04-2013 at 12:42 PM. Reason: added the 2 to SSE
theducks is offline   Reply With Quote
Old 05-04-2013, 08:31 AM   #5
Gian Carlo M.
Junior Member
Gian Carlo M. began at the beginning.
 
Posts: 8
Karma: 10
Join Date: May 2013
Device: none
Quote:
Originally Posted by yekim54 View Post
I have 3 PCs with Windows XP SP3 and Sigil 0.7.2 only runs on one of them...the one with 2 GB RAM. The other two PCs only have 1 GB RAM and Sigil 0.7.2 will not start. How much RAM do you have on your PC?
1.25 GB, unfortunately. Thank you.
Gian Carlo M. is offline   Reply With Quote
Old 05-04-2013, 08:38 AM   #6
PeterT
Taking a break; Fed up
PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.
 
PeterT's Avatar
 
Posts: 6,759
Karma: 43922916
Join Date: Nov 2007
Location: Toronto
Device: Wife: Touch, Arc, Vox Me: Nexus 7, Glo
I really doubt it is a real memory issue. What processor does the PC have?
PeterT is offline   Reply With Quote
Old 05-04-2013, 08:38 AM   #7
Gian Carlo M.
Junior Member
Gian Carlo M. began at the beginning.
 
Posts: 8
Karma: 10
Join Date: May 2013
Device: none
Quote:
Originally Posted by theducks View Post
Another known NO GO is old AMD processors that don't have SSE
My AMD has SSE. About SP3 you're right. I didn't upgrade XP to that service packs since I'm not sure some old programs of mine work correctly.

But perhaps the problem is RAM, as suggested by yekim54.

Thank you.
Gian Carlo M. is offline   Reply With Quote
Old 05-04-2013, 08:43 AM   #8
Gian Carlo M.
Junior Member
Gian Carlo M. began at the beginning.
 
Posts: 8
Karma: 10
Join Date: May 2013
Device: none
Quote:
Originally Posted by PeterT View Post
I really doubt it is a real memory issue. What processor does the PC have?
AMD Sempron 2200+, 1.5 GB RAM. Thank you.
Gian Carlo M. is offline   Reply With Quote
Old 05-04-2013, 09:00 AM   #9
DiapDealer
Grand Sorcerer
DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.
 
DiapDealer's Avatar
 
Posts: 9,012
Karma: 40855212
Join Date: Jan 2010
Device: Nexus 7, Kindle Fire HD
SSE isn't enough. Your processor must support SSE2. But there must be something else in play here, because the SSE2 requirement has been around since version 0.3, and you've indicated you were able to use version 0.6. So unless you were patching and compiling your own version of 0.6, it's probably not the SSE2 problem. That doesn't mean that Qt5 hasn't introduced some other special instruction code that your processor is lacking, however.

You could try Dependecy Walker (depends.exe) for Windows and see if it reveals any missing dependencies, but it probably won't help if it's a processor instruction issue.
DiapDealer is online now   Reply With Quote
Old 05-04-2013, 12:10 PM   #10
townsend
Enthusiast
townsend got an A in P-Chem.townsend got an A in P-Chem.townsend got an A in P-Chem.townsend got an A in P-Chem.townsend got an A in P-Chem.townsend got an A in P-Chem.townsend got an A in P-Chem.townsend got an A in P-Chem.townsend got an A in P-Chem.townsend got an A in P-Chem.townsend got an A in P-Chem.
 
townsend's Avatar
 
Posts: 29
Karma: 6366
Join Date: Oct 2011
Device: Sigil
You might want to try the Sigil Portable version. It can be installed anywhere, including a thumb drive. No dependencies or registry entries needed. And the current version is up to date: 7.2.

townsend is offline   Reply With Quote
Old 05-04-2013, 12:14 PM   #11
DiapDealer
Grand Sorcerer
DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.
 
DiapDealer's Avatar
 
Posts: 9,012
Karma: 40855212
Join Date: Jan 2010
Device: Nexus 7, Kindle Fire HD
Significant to note that that's not an "official" Sigil release. Not saying there's anything at all wrong with it ... just saying it should be noted and the appropriate measure taken.
DiapDealer is online now   Reply With Quote
Old 05-04-2013, 12:20 PM   #12
PeterT
Taking a break; Fed up
PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.
 
PeterT's Avatar
 
Posts: 6,759
Karma: 43922916
Join Date: Nov 2007
Location: Toronto
Device: Wife: Touch, Arc, Vox Me: Nexus 7, Glo
And if the processor of the user does not support SSE2 ....... Need I say more!
PeterT is offline   Reply With Quote
Old 05-04-2013, 06:42 PM   #13
Gian Carlo M.
Junior Member
Gian Carlo M. began at the beginning.
 
Posts: 8
Karma: 10
Join Date: May 2013
Device: none
Quote:
Originally Posted by townsend View Post
You might want to try the Sigil Portable version. It can be installed anywhere, including a thumb drive. No dependencies or registry entries needed. And the current version is up to date: 7.2.
Unfortunately portable releases 0.7.0, 0.7.1, and 0.7.2 do not start.
Gian Carlo M. is offline   Reply With Quote
Old 05-04-2013, 06:50 PM   #14
AnotherCat
Addict
AnotherCat ought to be getting tired of karma fortunes by now.AnotherCat ought to be getting tired of karma fortunes by now.AnotherCat ought to be getting tired of karma fortunes by now.AnotherCat ought to be getting tired of karma fortunes by now.AnotherCat ought to be getting tired of karma fortunes by now.AnotherCat ought to be getting tired of karma fortunes by now.AnotherCat ought to be getting tired of karma fortunes by now.AnotherCat ought to be getting tired of karma fortunes by now.AnotherCat ought to be getting tired of karma fortunes by now.AnotherCat ought to be getting tired of karma fortunes by now.AnotherCat ought to be getting tired of karma fortunes by now.
 
Posts: 395
Karma: 599183
Join Date: May 2012
Device: Sony PRS-T1
Quote:
Originally Posted by Gian Carlo M. View Post
AMD Sempron 2200+, 1.5 GB RAM. Thank you.
The 2200+ does not support SSE2.

Any relationship between the amount of RAM and whether Sigil runs or not is possibly just that older machines tend not to have so much RAM installed but also do not support SSE2. So small RAM and no SSE2 support tend to go together.
AnotherCat is offline   Reply With Quote
Old 05-04-2013, 07:48 PM   #15
DiapDealer
Grand Sorcerer
DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.
 
DiapDealer's Avatar
 
Posts: 9,012
Karma: 40855212
Join Date: Jan 2010
Device: Nexus 7, Kindle Fire HD
But the Xerces component of Sigil also requires SSE2--has for a long time. The OP indicated he was able to run Sigil 0.6.x on that same hardware--which should be impossible unless he was running a patched, custom build of Sigil (unless Sigil's Xerces component is configured in the Windows build without the SSE2 requirements that the Linux config has).

But regardless of all that, the bottom line is: no SSE2... no Sigil 0.7.x.

Last edited by DiapDealer; 05-04-2013 at 07:55 PM.
DiapDealer is online now   Reply With Quote
Reply

Tags
sigil 0.7

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
PRS-505 Reader Unable to start voyage_34 Sony Reader 5 11-23-2011 06:21 AM
Unable to start Sigil weedfreak Sigil 3 08-15-2011 03:28 AM
Unable to read Quick Start Guide redcomyn Calibre 6 01-27-2011 12:11 PM
Unable to start Openinkpot 0.2 lighty OpenInkpot 3 12-12-2009 06:39 PM
Unable to start Calibre after reinstall cuffy Calibre 2 03-26-2009 01:51 PM


All times are GMT -4. The time now is 11:50 AM.


MobileRead.com is a privately owned, operated and funded community.