Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Readers > Sony Reader > Sony Reader Dev Corner

Notices

Reply
 
Thread Tools Search this Thread
Old 07-22-2013, 11:38 AM   #106
entodoays
Zealot
entodoays will become famous soon enoughentodoays will become famous soon enoughentodoays will become famous soon enoughentodoays will become famous soon enoughentodoays will become famous soon enoughentodoays will become famous soon enoughentodoays will become famous soon enough
 
entodoays's Avatar
 
Posts: 139
Karma: 706
Join Date: Oct 2011
Device: Sony Reader PRS-T1
Did you do a backup of your preload partition before trying to flash mine?

Did you try to restore your original one?

What version of Reader do you have and what was the original firmware version when you bought it? Mine had version 1.0 (I bought it immediately on release).

Is it possible they modified the partition table structure after the original release?

Did you flash Rupor's full dictionaries pack?
entodoays is offline   Reply With Quote
Old 07-22-2013, 06:26 PM   #107
Br*ste1
Member
Br*ste1 began at the beginning.
 
Posts: 24
Karma: 10
Join Date: Jul 2012
Device: PRS-T1
It seems like in the meantime I was able to fix my PRS-T1 (although I was very close to taking a ride to the local Sony shop and nailing it on their front door).

I ultimately ended up rebuilding all partitions according to these instructions here: http://wiki.mobileread.com/wiki/PRST...itioning_Guide

One of the unnerving parts was that I found it impossible to get the correct sizes under Linux - but Putty under Windows finally did the trick.

After rebooting, I simply dd'ed the partitions again you gave me, there were no errors and I've had no problems ever since (knocking on wood).

Bottom line: "Something" screwed up my partitions. Interesting idea that SONY themselves might have changed the partition setup over time, but then again I bought my device over a year ago, so I doubt it (if that lead to all the problems I encountered, it would basically mean that it's unrootable with the standard packages out there, and I assume someone would have reported it by now).

As for the dictionary pack - yes, I flashed that one as well.

Will I root again: Gut says no, brain says now that I know it all, I would be stupid not to.

For now, however, I'm not touching anything for the next couple of months to make sure the problems are really gone.
Br*ste1 is offline   Reply With Quote
 
Enthusiast
Old 12-21-2013, 05:45 AM   #108
cielke
Junior Member
cielke began at the beginning.
 
Posts: 1
Karma: 10
Join Date: Dec 2013
Device: Sony PRS-T1
Hi Guys,

Thank you all very much. Special thanks to entodoays for the post #72.
I followed your guide to bring back the dictionary feature.

I just got one favour. Please correct the entry:
Quote:
Originally Posted by entodoays View Post
Code:
sudo dd if=PRST1/sdb1.bin of=/dev/sdb1
I nearly sh*tted my pants after getting an error message at that stage.
Oh! and the other thing is, you only need a SD card to fit the rescue pack ~25mb so basically any microSD will do ;-)

thank again and have a wonderful X-mas!
cielke is offline   Reply With Quote
Old 12-21-2013, 08:19 AM   #109
entodoays
Zealot
entodoays will become famous soon enoughentodoays will become famous soon enoughentodoays will become famous soon enoughentodoays will become famous soon enoughentodoays will become famous soon enoughentodoays will become famous soon enoughentodoays will become famous soon enough
 
entodoays's Avatar
 
Posts: 139
Karma: 706
Join Date: Oct 2011
Device: Sony Reader PRS-T1
Thanks for the correction. I hadn't realised and even though others used the procedure, nobody told me of the error. It is corrected now.
entodoays is offline   Reply With Quote
Old 02-17-2014, 01:37 AM   #110
snip
Junior Member
snip began at the beginning.
 
Posts: 1
Karma: 10
Join Date: Nov 2011
Device: PRS-T1
Thanks for #72 endtodays,

Could you also provide a good version of the data partition (partition 9)? My reader is still unresponsive after following your procedure and doing a full factory reset.

Last edited by snip; 02-17-2014 at 02:01 AM.
snip is offline   Reply With Quote
Old 02-27-2014, 12:25 PM   #111
entodoays
Zealot
entodoays will become famous soon enoughentodoays will become famous soon enoughentodoays will become famous soon enoughentodoays will become famous soon enoughentodoays will become famous soon enoughentodoays will become famous soon enoughentodoays will become famous soon enough
 
entodoays's Avatar
 
Posts: 139
Karma: 706
Join Date: Oct 2011
Device: Sony Reader PRS-T1
Quote:
Originally Posted by snip View Post
Thanks for #72 endtodays,

Could you also provide a good version of the data partition (partition 9)? My reader is still unresponsive after following your procedure and doing a full factory reset.
There is no need to post the Data partition. Simply doing a hard reset of the unit formats the data partition and permits you to start from scratch hopefully without problems.
entodoays is offline   Reply With Quote
Reply

Tags
amr, hanging, prst1, sony

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
PRS-T1 PRS-T1 stuck off and unresponsive...but no serial to return samadam Sony Reader 3 06-15-2012 12:13 PM
PRS-350 Unresponsive Buttons mer10 Sony Reader 9 04-05-2012 04:41 PM
PRS-350 sony prs 350: blank unresponsive screen, blinking orange light halipleumon Sony Reader 5 05-30-2011 06:49 AM
Unresponsive Prs-505 Reader 101 Sony Reader 1 09-15-2008 04:19 AM
Unresponsive honeybunny Amazon Kindle 8 07-17-2008 05:18 PM


All times are GMT -4. The time now is 08:28 AM.


MobileRead.com is a privately owned, operated and funded community.