Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre > Devices

Notices

Reply
 
Thread Tools Search this Thread
Old 11-08-2012, 12:10 AM   #1
duckpuppy
Junior Member
duckpuppy began at the beginning.
 
Posts: 5
Karma: 10
Join Date: Feb 2011
Device: nook
Standalone content-server and Calibre Companion issues

I have two issues, one with Calibre's standalone content server and one with Calibre Companion.

First, the standalone content-server doesn't announce itself over Bonjour/Zeroconf/whatever, so Calibre Companion doesn't see it without manually setting the IP address and port numbers. Calibre Companion works with the default empty values if I've started the content server via the GUI, but not by running the standalone content-server app. This wouldn't be as much of a problem if not for #2...

Secondly, I'm running the content-server with a url prefix of /calibre, which is the suggested way to handle integrating the content-server into another server via reverse proxy. That works nicely, except that there's no way to tell Calibre Companion that I'm using a prefix, which means that it can't see the content server even if I give it the IP address and port.

I suppose I could run multiple content server services, one with a prefix and one without, to get both to work, but that seems a bit overloaded. Is there a better way to work around these problems, or can I at least request support for a url prefix in Calibre Companion? I know my situation is a bit advanced, but I'm sure I'm not the only one out there doing this.
duckpuppy is offline   Reply With Quote
Old 11-08-2012, 04:31 AM   #2
chaley
"chaley", not "charley"
chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.
 
Posts: 5,292
Karma: 821512
Join Date: Jan 2010
Location: France
Device: Many android devices
Quote:
Originally Posted by duckpuppy View Post
I have two issues, one with Calibre's standalone content server and one with Calibre Companion.

First, the standalone content-server doesn't announce itself over Bonjour/Zeroconf/whatever, so Calibre Companion doesn't see it without manually setting the IP address and port numbers. Calibre Companion works with the default empty values if I've started the content server via the GUI, but not by running the standalone content-server app. This wouldn't be as much of a problem if not for #2...
The standalone server does advertize using bonjour.

Our experience when building CC was that a *lot* of home network routers block MDNS (bonjour) multicast packets, making bonjour close to useless for CC. We had no end of trouble and complaints about connection problems. Because of this we added a UDP broadcast "find" mechanism to calibre's wireless driver (similar to DHCP), which is only running if the GUI is running. It is almost certain that in your case CC is seeing answers from this mechanism and that bonjour packets are being suppressed somewhere.
Quote:
Secondly, I'm running the content-server with a url prefix of /calibre, which is the suggested way to handle integrating the content-server into another server via reverse proxy. That works nicely, except that there's no way to tell Calibre Companion that I'm using a prefix, which means that it can't see the content server even if I give it the IP address and port.
I have this problem. I run a standalone server on a VPS in some data center and therefore need to separate the two connection schemes. I have already started work on this.

In the not-far future, the content server IP setup will be separated from the wireless device setup. The new scheme will allow a user to:
- use the settings from the wireless device setup, meaning that ip and port information are determined from the broadcast setup. This will be the default
- use a different IP address & port
- use a specific URL, in which case the port must be embedded in the URL. The URL will the one for the main content server page, not the OPDS subpage. CC takes care of the sub-navigation.

I don't use a prefix so I will use the second scheme. You will use the third.

In the meantime, you might be able to use a port-based named virtual host as the reverse proxy, eliminating the prefix. This works if you have some control over your DNS and are able to add sub-zones. Instead of www.foo.com/library you would use library.foo.com:9090. If you have full access to your configuration files and are running apache, then you could also use www.foo.com:9090 and have that match a different virtual host.
chaley is offline   Reply With Quote
 
Enthusiast
Old 11-08-2012, 07:54 AM   #3
duckpuppy
Junior Member
duckpuppy began at the beginning.
 
Posts: 5
Karma: 10
Join Date: Feb 2011
Device: nook
Thanks for the reply!

Quote:
Originally Posted by chaley View Post
The standalone server does advertize using bonjour.

Our experience when building CC was that a *lot* of home network routers block MDNS (bonjour) multicast packets, making bonjour close to useless for CC. We had no end of trouble and complaints about connection problems. Because of this we added a UDP broadcast "find" mechanism to calibre's wireless driver (similar to DHCP), which is only running if the GUI is running. It is almost certain that in your case CC is seeing answers from this mechanism and that bonjour packets are being suppressed somewhere.
Given that my router is an Apple AirPort Extreme, I would hope it's one of the routers that does MDNS well. I can browse other Bonjour services on that PC (it is a Windows machine) such as Growl and Plex Media Server with an MDNS discovery tool running on my phone. I do not see an MDNS announcement for Calibre, either with GUI running or not, though.

Quote:
Originally Posted by chaley View Post
In the meantime, you might be able to use a port-based named virtual host as the reverse proxy, eliminating the prefix. This works if you have some control over your DNS and are able to add sub-zones. Instead of www.foo.com/library you would use library.foo.com:9090. If you have full access to your configuration files and are running apache, then you could also use www.foo.com:9090 and have that match a different virtual host.
I don't have full control over the DNS for my connection right now, but the port based virtual host might be the right idea for my setup. I'm hosting this on my home machines and I'm currently using a very simple setup for my dynamic DNS (no wildcard DNS, just a single hostname) and using rewrite rules and mod_proxy as needed.

That said, I can't wait for the new IP configuration options.
duckpuppy is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Calibre Content Server and Windows Home Server 2011 HughMcC Calibre 7 11-15-2013 06:10 PM
[Android App] Calibre Companion content server integration chaley Devices 44 10-21-2012 02:26 AM
500 Internal Server Error accessing content server Calibre 0.8.8 DaddyO57 Calibre 1 07-20-2012 06:08 PM
Calibre Content Server rosebudcassidy Calibre 0 07-26-2011 12:21 PM
Calibre Content Server TonytheBookworm Calibre 2 09-07-2010 09:47 PM


All times are GMT -4. The time now is 05:30 PM.


MobileRead.com is a privately owned, operated and funded community.