Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Readers > Sony Reader > Sony Reader Dev Corner

Notices

Reply
 
Thread Tools Search this Thread
Old 10-27-2012, 09:33 AM   #1
m3l7d0wN
Zealot
m3l7d0wN is generous with chocolatem3l7d0wN is generous with chocolatem3l7d0wN is generous with chocolatem3l7d0wN is generous with chocolatem3l7d0wN is generous with chocolatem3l7d0wN is generous with chocolatem3l7d0wN is generous with chocolatem3l7d0wN is generous with chocolatem3l7d0wN is generous with chocolatem3l7d0wN is generous with chocolatem3l7d0wN is generous with chocolate
 
Posts: 102
Karma: 33708
Join Date: Apr 2011
Device: Sony PRS-T1
Firmware upgrade 1.04 problem

hi,
I've just updated my T1 to 1.04 (I wanted to install the modified reader).
The problem is that after every reboot the device will do the reinitialization.
Also, a minor problem, everytime I plug in the usb cable, it appears usb debug enable in the notification bar. If I try to disable debug, the device freeze and I need to reboot it manualy (this problem was also present in the previous firmware version).
Any suggestions?
thanks :P
m3l7d0wN is offline   Reply With Quote
Old 10-27-2012, 05:42 PM   #2
uboot
Evangelist
uboot seems famous, but is in fact legendary.uboot seems famous, but is in fact legendary.uboot seems famous, but is in fact legendary.uboot seems famous, but is in fact legendary.uboot seems famous, but is in fact legendary.uboot seems famous, but is in fact legendary.uboot seems famous, but is in fact legendary.uboot seems famous, but is in fact legendary.uboot seems famous, but is in fact legendary.uboot seems famous, but is in fact legendary.uboot seems famous, but is in fact legendary.
 
Posts: 418
Karma: 75216
Join Date: Nov 2011
Location: old europe
Device: Kobo Mini, Sony PRS T1
I would boot into recovery and simply format the data partition. Alternatively you can do a factory reset, but I suspect this will format reader partition as well...
uboot is offline   Reply With Quote
Old 10-27-2012, 07:04 PM   #3
m3l7d0wN
Zealot
m3l7d0wN is generous with chocolatem3l7d0wN is generous with chocolatem3l7d0wN is generous with chocolatem3l7d0wN is generous with chocolatem3l7d0wN is generous with chocolatem3l7d0wN is generous with chocolatem3l7d0wN is generous with chocolatem3l7d0wN is generous with chocolatem3l7d0wN is generous with chocolatem3l7d0wN is generous with chocolatem3l7d0wN is generous with chocolate
 
Posts: 102
Karma: 33708
Join Date: Apr 2011
Device: Sony PRS-T1
yeah, the data partition was corrupted (I have a custom partition table). Reformatted, now it works correctly :P Still I have that annoying debug notification, but it's not a great issue
m3l7d0wN is offline   Reply With Quote
Old 10-28-2012, 08:09 AM   #4
uboot
Evangelist
uboot seems famous, but is in fact legendary.uboot seems famous, but is in fact legendary.uboot seems famous, but is in fact legendary.uboot seems famous, but is in fact legendary.uboot seems famous, but is in fact legendary.uboot seems famous, but is in fact legendary.uboot seems famous, but is in fact legendary.uboot seems famous, but is in fact legendary.uboot seems famous, but is in fact legendary.uboot seems famous, but is in fact legendary.uboot seems famous, but is in fact legendary.
 
Posts: 418
Karma: 75216
Join Date: Nov 2011
Location: old europe
Device: Kobo Mini, Sony PRS T1
congrats!

regarding debug mode - you may try to flash enableadb package...
uboot is offline   Reply With Quote
Old 10-28-2012, 08:11 AM   #5
anddam
Junior Member
anddam began at the beginning.
 
Posts: 6
Karma: 10
Join Date: Oct 2012
Device: PRS-T1
Quote:
Originally Posted by m3l7d0wN View Post
hi,
I've just updated my T1 to 1.04 (I wanted to install the modified reader).
The problem is that after every reboot the device will do the reinitialization.
Also, a minor problem, everytime I plug in the usb cable, it appears usb debug enable in the notification bar.
I had the same issue despite using both uboot's restore packages at this thread.

I had installed porkupan packages and I wanted to switch to rupor's but when trying to flash rupor's AMR I had errors in update script.

It turned out I had to reverse each single package in order to have a clean status on which to apply another flash package.

In my case I applied disable-adb and restore-set from porkupan's flash packages, this fixed both adb notification (that I thought had been cleaned by the Sony's firmware upgrade) and the nagging initialization on every boot.

edit:
I just re-read uboot's thread and only this time I understood that
Quote:
There are reports of the reader being unable to store settings with this packages and asking for initial settings on every boot.
applies to both pakages.

The packages' description and the way the post is formatted with the sentence
Quote:
This package has been reported to work.
before first download link suggested me that only Package 2 had issue while the Package 1 was a sure way to go.
This seems to not be the case, I had issues of re-initialization with both packages, well applied (I checked logs and I kept them apart).

Last edited by anddam; 10-28-2012 at 08:18 AM. Reason: adding note about linked flash packages
anddam is offline   Reply With Quote
Old 10-28-2012, 02:16 PM   #6
m3l7d0wN
Zealot
m3l7d0wN is generous with chocolatem3l7d0wN is generous with chocolatem3l7d0wN is generous with chocolatem3l7d0wN is generous with chocolatem3l7d0wN is generous with chocolatem3l7d0wN is generous with chocolatem3l7d0wN is generous with chocolatem3l7d0wN is generous with chocolatem3l7d0wN is generous with chocolatem3l7d0wN is generous with chocolatem3l7d0wN is generous with chocolate
 
Posts: 102
Karma: 33708
Join Date: Apr 2011
Device: Sony PRS-T1
thanks anddam!
the disable-adb package worked well..
I needed to log into recovery console and run do_update.sh manually since the normal update procedure didn't work
m3l7d0wN is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Why can’t I complete the Kobo Touch firmware upgrade or Desktop upgrade? DarrellAtKobo Kobo Reader 31 08-31-2012 11:45 PM
Problem with Firmware Upgrade maria23 Astak EZReader 18 03-16-2010 11:21 PM
How to do a firmware upgrade!! Robertb Astak EZReader 1 02-07-2010 06:51 PM
problem with firmware upgrade pekos Bookeen 4 10-09-2008 06:51 AM
Problem during firmware upgrade to 1.1.00.xxxxx on PRS505 - Need HELP!!! EssKayEss Sony Reader 5 08-01-2008 02:39 AM


All times are GMT -4. The time now is 11:05 AM.


MobileRead.com is a privately owned, operated and funded community.