Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre > Plugins

Notices

Reply
 
Thread Tools Search this Thread
Old 03-17-2014, 03:25 AM   #1
BetterRed
null operator
BetterRed ought to be getting tired of karma fortunes by now.BetterRed ought to be getting tired of karma fortunes by now.BetterRed ought to be getting tired of karma fortunes by now.BetterRed ought to be getting tired of karma fortunes by now.BetterRed ought to be getting tired of karma fortunes by now.BetterRed ought to be getting tired of karma fortunes by now.BetterRed ought to be getting tired of karma fortunes by now.BetterRed ought to be getting tired of karma fortunes by now.BetterRed ought to be getting tired of karma fortunes by now.BetterRed ought to be getting tired of karma fortunes by now.BetterRed ought to be getting tired of karma fortunes by now.
 
Posts: 2,756
Karma: 1676604
Join Date: Mar 2012
Location: NSW Australia
Device: none
Deprecated Plugins

When a new version of a plug-in is available calibre shows a message in the status line.

But there is nothing to inform one that a plug-in has been deprecated. If left installed a deprecated plug-in can cause calibre to malfunction. See this thread - http://www.mobileread.com/forums/sho...d.php?t=236002

Could the function that checks for new versions of installed plug-ins also check to see if any installed plug-ins have been deprecated, and if there are any then put a message in the status line. See attachment for how it might look.

I installed the now deprecated Kindle Collections plug-in to ensure it wasn't already being done.

BR
Attached Thumbnails
Click image for larger version

Name:	Capture.JPG
Views:	71
Size:	115.7 KB
ID:	120389  
BetterRed is online now   Reply With Quote
Old 03-17-2014, 04:34 AM   #2
kovidgoyal
creator of calibre
kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.
 
kovidgoyal's Avatar
 
Posts: 25,268
Karma: 4961457
Join Date: Oct 2006
Location: Mumbai, India
Device: Various
deprecated plugins dont cause calibre to stop working. If a plugin fails during initialization, it is simply ignored. The OPs error was caused by having a font that was causing Qt's text rendering to fail.
kovidgoyal is online now   Reply With Quote
Old 03-17-2014, 05:41 AM   #3
DoctorOhh
US Navy, Retired
DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.
 
DoctorOhh's Avatar
 
Posts: 8,737
Karma: 12488297
Join Date: Feb 2009
Location: North Carolina
Device: Nexus 7
Quote:
Originally Posted by BetterRed View Post
But there is nothing to inform one that a plug-in has been deprecated. If left installed a deprecated plug-in can cause calibre to malfunction. See this thread - http://www.mobileread.com/forums/sho...d.php?t=236002
Kovid beat me to it, the deprecated plugins in the thread you pointed to had nothing to do with the OP's problem. Griker and I simply pointed out some harmless housekeeping.

Update: BR you picked one of the two plugins listed as deprecated that are both deprecated yet still active. The Kindle Collections plugin and the Mobi Unpack plugin (now called Kindle Unpack) are listed as both in the index. The Kindle collections plugin has been taken on by another developer (NiLuJe) who has been updating it for new devices.

Last edited by DoctorOhh; 03-17-2014 at 06:00 AM.
DoctorOhh is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
[Metadata Source Plugin] Libri.hu [Deprecated] Daermond Plugins 5 10-02-2012 05:07 AM
[Metadata Source Plugin] Moly.hu [Deprecated] Daermond Plugins 7 09-23-2012 03:48 AM
composite_formatter and eval_formatter APIs deprecated chaley Development 0 06-26-2011 09:53 AM
[Metadata Source Plugin] Antikvarium.hu **Deprecated** Daermond Plugins 0 05-27-2011 08:06 AM
--output-format deprecated? Robotech_Master Calibre 6 01-03-2011 10:07 PM


All times are GMT -4. The time now is 05:16 AM.


MobileRead.com is a privately owned, operated and funded community.