Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre > Library Management

Notices

Reply
 
Thread Tools Search this Thread
Old 09-03-2012, 07:23 PM   #1
p014k
Junior Member
p014k began at the beginning.
 
Posts: 2
Karma: 10
Join Date: Sep 2012
Device: Kindle
Python error using ebook-convert (Linux)

Hello.

I'm trying to convert an .epub to a .mobi using the ebook-convert command line included with Calibre (version 0.7.44) on Linux. I've used it before with several successful conversions, but for this particular .epub, I'm getting this error;

Code:
Traceback (most recent call last):
  File "/usr/bin/ebook-convert", line 19, in <module>
    sys.exit(main())
  File "/usr/lib/calibre/calibre/ebooks/conversion/cli.py", line 279, in main
    plumber.run()
  File "/usr/lib/calibre/calibre/ebooks/conversion/plumber.py", line 904, in run
    accelerators, tdir)
  File "/usr/lib/calibre/calibre/customize/conversion.py", line 204, in __call__
    log, accelerators)
  File "/usr/lib/calibre/calibre/ebooks/epub/input.py", line 138, in convert
    zf.extractall(os.getcwd())
  File "/usr/lib/calibre/calibre/utils/zipfile.py", line 1054, in extractall
    self.extract(zipinfo, path, pwd)
  File "/usr/lib/calibre/calibre/utils/zipfile.py", line 1042, in extract
    return self._extract_member(member, path, pwd)
  File "/usr/lib/calibre/calibre/utils/zipfile.py", line 1097, in _extract_member
    shutil.copyfileobj(source, target)
  File "/usr/lib/python2.7/shutil.py", line 48, in copyfileobj
    buf = fsrc.read(length)
  File "/usr/lib/calibre/calibre/utils/zipfile.py", line 649, in read
    newdata = self.dc.decompress(newdata)
zlib.error: Error -3 while decompressing: invalid stored block lengths
Does anyone have a solution to this problem?
p014k is offline   Reply With Quote
Old 09-04-2012, 01:30 AM   #2
DoctorOhh
US Navy, Retired
DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.
 
DoctorOhh's Avatar
 
Posts: 8,801
Karma: 12534285
Join Date: Feb 2009
Location: North Carolina
Device: Nexus 7
Quote:
Originally Posted by p014k View Post
I'm trying to convert an .epub to a .mobi using the ebook-convert command line included with Calibre (version 0.7.44) on Linux. I've used it before with several successful conversions, but for this particular .epub, I'm getting this error;
...~~~...
Does anyone have a solution to this problem?
I'm afraid I have no solution for you. Why are you using a version of calibre over a year and a half old?
DoctorOhh is offline   Reply With Quote
 
Enthusiast
Old 09-04-2012, 10:10 AM   #3
theducks
Grand Sorcerer
theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.
 
theducks's Avatar
 
Posts: 14,444
Karma: 5567061
Join Date: Aug 2009
Location: The (original) Silicon Valley, USA
Device: Galaxy Tab 2, Astak Pocket Pro, K4NT
Quote:
Originally Posted by dwanthny View Post
I'm afraid I have no solution for you. Why are you using a version of calibre over a year and a half old?
I suspect that is the version in the Repository for that Distro's release version which never gets an update once the 'version release' is done (Ubuntu). To get the next (already out of date) Calibre, you have to uggrade your Distro version.

OP
Uninstall that version and paste the command line on the Calibre Linux download page (repeat for every Calibre update you want)
theducks is offline   Reply With Quote
Old 09-10-2012, 04:15 PM   #4
p014k
Junior Member
p014k began at the beginning.
 
Posts: 2
Karma: 10
Join Date: Sep 2012
Device: Kindle
Indeed, I was running an old version. I upgraded to 0.8.68 and now this is the error I get;
Code:
Traceback (most recent call last):
  File "site.py", line 58, in main
  File "site-packages/calibre/ebooks/conversion/cli.py", line 325, in main
  File "site-packages/calibre/ebooks/conversion/plumber.py", line 989, in run
  File "site-packages/calibre/customize/conversion.py", line 239, in __call__
  File "site-packages/calibre/ebooks/conversion/plugins/epub_input.py", line 154, in convert
  File "site-packages/calibre/utils/zipfile.py", line 1087, in extractall
  File "site-packages/calibre/utils/zipfile.py", line 1071, in extract
  File "site-packages/calibre/utils/zipfile.py", line 1140, in _extract_member
  File "shutil.py", line 49, in copyfileobj
  File "site-packages/calibre/utils/zipfile.py", line 607, in read
  File "site-packages/calibre/utils/zipfile.py", line 659, in read1
error: Error -3 while decompressing: invalid stored block lengths
p014k is offline   Reply With Quote
Old 09-10-2012, 10:24 PM   #5
kovidgoyal
creator of calibre
kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.
 
kovidgoyal's Avatar
 
Posts: 25,666
Karma: 4998489
Join Date: Oct 2006
Location: Mumbai, India
Device: Various
THat error indicates the epub file you are trying to convert is not a valid zip file.
kovidgoyal is offline   Reply With Quote
Reply

Tags
calibre, ebook-convert, linux, python error

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ebook-convert not working (linux) Kino Calibre 4 01-24-2012 10:35 AM
calibre-0.8.14 Linux ebook-convert cpu run/endless loop? rogerx Conversion 7 09-02-2011 10:56 PM
=calibre-0.8.14 Linux No X ebook-convert bug rogerx Conversion 2 09-02-2011 07:41 PM
ebook-convert error on PDF output without X hiperlink Conversion 3 04-04-2011 07:23 AM
ebook-convert for linux Patton Calibre 5 02-10-2010 09:57 PM


All times are GMT -4. The time now is 07:46 AM.


MobileRead.com is a privately owned, operated and funded community.