Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Sigil

Notices

Reply
 
Thread Tools Search this Thread
Old 05-19-2012, 06:43 AM   #1
njm55n
Junior Member
njm55n began at the beginning.
 
Posts: 6
Karma: 22
Join Date: May 2012
Device: Kindle2 & Kindle3
Unhappy Sigil error in Ubuntu 12.04

I've just reinstalled Ubuntu following a disk failure, in the process upgrading from 11.04 to 12.04 (HATE the Unity interface!).
Reinstalled Sigil 0.5.3 x86 from same file as previously used. Tried to load Sigil from the desktop loader, no apparent response. From a terminal, ran the following:

cd /opt/sigil
./sigil.sh

result was:

/opt/sigil/./sigil: symbol lookup error: /usr/lib/i386-linux-gnu/qt4/plugins/bearer/libqconnmanbearer.so: undefined symbol: _ZN6QMutex12lockInternalEv

I'm a relatively new linux user, so need help to fix this, please.
njm55n is offline   Reply With Quote
Old 05-19-2012, 07:23 AM   #2
meme
Sigil developer
meme ought to be getting tired of karma fortunes by now.meme ought to be getting tired of karma fortunes by now.meme ought to be getting tired of karma fortunes by now.meme ought to be getting tired of karma fortunes by now.meme ought to be getting tired of karma fortunes by now.meme ought to be getting tired of karma fortunes by now.meme ought to be getting tired of karma fortunes by now.meme ought to be getting tired of karma fortunes by now.meme ought to be getting tired of karma fortunes by now.meme ought to be getting tired of karma fortunes by now.meme ought to be getting tired of karma fortunes by now.
 
Posts: 1,275
Karma: 1101600
Join Date: Jan 2011
Location: UK
Device: Kindle PW, K4 NT, K3, Kobo Touch
Try just running /opt/sigil/sigil

Sigil 0.5.3 wasn't built for 12.04 so there's no guarantee it will run.

Its likely the binary for Linux will be removed from the downloads for the next version, and users will have to hope someone builds a package for their specific linux distribution, or they'll need to build it from source.
meme is offline   Reply With Quote
 
Advertisement
Old 05-19-2012, 07:37 AM   #3
DiapDealer
Grand Sorcerer
DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.
 
DiapDealer's Avatar
 
Posts: 9,553
Karma: 44291176
Join Date: Jan 2010
Device: Nexus 7, Kindle Fire HD
Quote:
Originally Posted by meme View Post
Its likely the binary for Linux will be removed from the downloads for the next version, and users will have to hope someone builds a package for their specific linux distribution, or they'll need to build it from source.
I find that a little sad... but not completely unexpected or tragically unreasonable, I guess. Most linux users are used to rolling their own anyway, but I'd be lying if I said it wasn't kind of nice to just run that windjammer script at upgrade time.
DiapDealer is offline   Reply With Quote
Old 05-19-2012, 07:43 AM   #4
njm55n
Junior Member
njm55n began at the beginning.
 
Posts: 6
Karma: 22
Join Date: May 2012
Device: Kindle2 & Kindle3
Many thanks, Meme. That works fine!
I've looked at the script (/opt/sigil/sigil.sh), but can't understand it, I remember being at this stage with DOS, Windows command language, OS400 command scripting, NetWare etc., so I guess I'll get there again.
For any other newbies reading this, don't rely on the Sigil shortcut (loader) created on the desktop, which calls /opt/sigil/sigil.sh - run the command as per Meme's post, which (I presume) calls the executable file.
njm55n is offline   Reply With Quote
Old 05-19-2012, 08:05 AM   #5
DiapDealer
Grand Sorcerer
DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.
 
DiapDealer's Avatar
 
Posts: 9,553
Karma: 44291176
Join Date: Jan 2010
Device: Nexus 7, Kindle Fire HD
Quote:
For any other newbies reading this, don't rely on the Sigil shortcut (loader) created on the desktop, which calls /opt/sigil/sigil.sh - run the command as per Meme's post, which (I presume) calls the executable file.
The script just adds Sigil's executable directory to the LD_LIBRARY_PATH environment variable so that the included custom Qt libraries are used.

I would only recommend linking directly to the executable in the event the script isn't working for you (like in your case). The custom Qt interface looks much cleaner than the stock version on my system... to me anyway. *shrugs* But if the custom libs aren't compatible with your system—then you don't have much choice, of course.

Last edited by DiapDealer; 05-19-2012 at 08:08 AM.
DiapDealer is offline   Reply With Quote
Old 05-19-2012, 09:06 AM   #6
meme
Sigil developer
meme ought to be getting tired of karma fortunes by now.meme ought to be getting tired of karma fortunes by now.meme ought to be getting tired of karma fortunes by now.meme ought to be getting tired of karma fortunes by now.meme ought to be getting tired of karma fortunes by now.meme ought to be getting tired of karma fortunes by now.meme ought to be getting tired of karma fortunes by now.meme ought to be getting tired of karma fortunes by now.meme ought to be getting tired of karma fortunes by now.meme ought to be getting tired of karma fortunes by now.meme ought to be getting tired of karma fortunes by now.
 
Posts: 1,275
Karma: 1101600
Join Date: Jan 2011
Location: UK
Device: Kindle PW, K4 NT, K3, Kobo Touch
Quote:
Originally Posted by DiapDealer View Post
I find that a little sad... but not completely unexpected or tragically unreasonable, I guess. Most linux users are used to rolling their own anyway, but I'd be lying if I said it wasn't kind of nice to just run that windjammer script at upgrade time.
Yeah, too many variations. But since I run 12.04 as my main system, I'll certainly work on packaging it up. And since most of the main variants have packages available and linked to from the Sigil site - its just that they aren't available as direct downloads - I don't think it'll be too much of an issue.
meme is offline   Reply With Quote
Old 05-19-2012, 09:42 AM   #7
DiapDealer
Grand Sorcerer
DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.
 
DiapDealer's Avatar
 
Posts: 9,553
Karma: 44291176
Join Date: Jan 2010
Device: Nexus 7, Kindle Fire HD
Quote:
Originally Posted by meme View Post
Yeah, too many variations. But since I run 12.04 as my main system, I'll certainly work on packaging it up. And since most of the main variants have packages available and linked to from the Sigil site - its just that they aren't available as direct downloads - I don't think it'll be too much of an issue.
I just went through a trial build and it was fairly painless, so I don't expect much trouble either.

I wasn't able to build the "makeinstaller" target on 11.10, though. I assumed (and INSTALL.txt suggested) that could be used to build the installer binary on linux? No biggie if not, but I was sort of curious what the issue might be. Haven't had a chance to do much investigating.

Spoiler:
Code:
Scanning dependencies of target copyfiles
[100%] Copying installer files to temporary location...
Error copying file "location-NOTFOUND" to "/home/user1/builds/temp_folder/Sigil/".
make[3]: *** [copyfiles] Error 1
make[2]: *** [src/Sigil/CMakeFiles/copyfiles.dir/all] Error 2
make[1]: *** [src/Sigil/CMakeFiles/makeinstaller.dir/rule] Error 2
make: *** [makeinstaller] Error 2

Last edited by DiapDealer; 05-19-2012 at 10:01 AM.
DiapDealer is offline   Reply With Quote
Old 05-19-2012, 12:14 PM   #8
st_albert
Fanatic
st_albert has top level security clearance to Area 51.st_albert has top level security clearance to Area 51.st_albert has top level security clearance to Area 51.st_albert has top level security clearance to Area 51.st_albert has top level security clearance to Area 51.st_albert has top level security clearance to Area 51.st_albert has top level security clearance to Area 51.st_albert has top level security clearance to Area 51.st_albert has top level security clearance to Area 51.st_albert has top level security clearance to Area 51.st_albert has top level security clearance to Area 51.
 
Posts: 552
Karma: 94420
Join Date: Feb 2010
Device: none
Quote:
Originally Posted by DiapDealer View Post
I just went through a trial build and it was fairly painless, so I don't expect much trouble either.

I wasn't able to build the "makeinstaller" target on 11.10, though. I assumed (and INSTALL.txt suggested) that could be used to build the installer binary on linux? No biggie if not, but I was sort of curious what the issue might be. Haven't had a chance to do much investigating.

Spoiler:
Code:
Scanning dependencies of target copyfiles
[100%] Copying installer files to temporary location...
Error copying file "location-NOTFOUND" to "/home/user1/builds/temp_folder/Sigil/".
make[3]: *** [copyfiles] Error 1
make[2]: *** [src/Sigil/CMakeFiles/copyfiles.dir/all] Error 2
make[1]: *** [src/Sigil/CMakeFiles/makeinstaller.dir/rule] Error 2
make: *** [makeinstaller] Error 2
This is just a guess, but it's probably trying and failing to find the libphonon library, which sigil doesn't need and isn't present (I think) in Ubuntu 11.10.

If you edit ./src/Sigil/CMakeFiles/copyfiles.dir/build.make to comment out the line where it's trying to copy location-NOTFOUND, I think it will then work. But it's been a while since I tried it, and YMMV.
st_albert is offline   Reply With Quote
Old 05-19-2012, 03:18 PM   #9
signum
Connoisseur
signum is that somebody.signum is that somebody.signum is that somebody.signum is that somebody.signum is that somebody.signum is that somebody.signum is that somebody.signum is that somebody.signum is that somebody.signum is that somebody.signum is that somebody.
 
Posts: 66
Karma: 45332
Join Date: Aug 2011
Device: none
For Ubuntu users: has anybody tried using any of the Personal Project Archives (PPAs) from launchpad.net? Apparently, all you have to do is add the PPA to your apt sources list and do a normal update. I'd be interested in any experiences with this, either pro or con.
signum is offline   Reply With Quote
Old 05-19-2012, 03:35 PM   #10
EowynCarter
Wizard
EowynCarter ought to be getting tired of karma fortunes by now.EowynCarter ought to be getting tired of karma fortunes by now.EowynCarter ought to be getting tired of karma fortunes by now.EowynCarter ought to be getting tired of karma fortunes by now.EowynCarter ought to be getting tired of karma fortunes by now.EowynCarter ought to be getting tired of karma fortunes by now.EowynCarter ought to be getting tired of karma fortunes by now.EowynCarter ought to be getting tired of karma fortunes by now.EowynCarter ought to be getting tired of karma fortunes by now.EowynCarter ought to be getting tired of karma fortunes by now.EowynCarter ought to be getting tired of karma fortunes by now.
 
Posts: 4,133
Karma: 1604192
Join Date: Oct 2008
Location: Paris
Device: Cybooks; Sony PRS-T1
https://launchpad.net/~sunab/+archive/sigil-git

Ah, there's that it seams.
Should work, but as it's updated regularily, you might get unstable suiff every now and then.

That one, older, but more likely to be stable.
https://launchpad.net/~rgibert/+archive/ebook

Last edited by EowynCarter; 05-19-2012 at 03:46 PM.
EowynCarter is offline   Reply With Quote
Old 05-19-2012, 04:20 PM   #11
EowynCarter
Wizard
EowynCarter ought to be getting tired of karma fortunes by now.EowynCarter ought to be getting tired of karma fortunes by now.EowynCarter ought to be getting tired of karma fortunes by now.EowynCarter ought to be getting tired of karma fortunes by now.EowynCarter ought to be getting tired of karma fortunes by now.EowynCarter ought to be getting tired of karma fortunes by now.EowynCarter ought to be getting tired of karma fortunes by now.EowynCarter ought to be getting tired of karma fortunes by now.EowynCarter ought to be getting tired of karma fortunes by now.EowynCarter ought to be getting tired of karma fortunes by now.EowynCarter ought to be getting tired of karma fortunes by now.
 
Posts: 4,133
Karma: 1604192
Join Date: Oct 2008
Location: Paris
Device: Cybooks; Sony PRS-T1
The sigi-git version refuse to open an ePub. Not sure what's up. John ? Are you aware of problems there ?

The second one seams to work.

Quote:
Its likely the binary for Linux will be removed from the downloads for the next version, and users will have to hope someone builds a package for their specific linux distribution, or they'll need to build it from source.
Mmm, what ? I don't like the sound of that at all. Valoric seams to have no problem with linux release. So what's the matter ?

Last edited by EowynCarter; 05-19-2012 at 04:40 PM.
EowynCarter is offline   Reply With Quote
Old 05-19-2012, 05:45 PM   #12
user_none
Sigil & calibre developer
user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.
 
user_none's Avatar
 
Posts: 2,473
Karma: 1053245
Join Date: Jan 2009
Location: Florida, USA
Device: Nook STR
Quote:
Originally Posted by EowynCarter View Post
The sigi-git version refuse to open an ePub. Not sure what's up. John ? Are you aware of problems there ?
Git has no guarantees because it's actively been worked on. The typical process is work on something, get it to build and do minimal testing on OS X. At a later date check if it builds on another platform. Do minimal testing. Repeat. Before a release do more extensive testing across all platform. Something that works with the compiler on OS X might not work with another compiler. Some bugs (like one I'm trying to figure out right now) only happens on Linux but doesn't appear on OS X or Windows. Keeping git perfectly usable and stable across multiple platforms just isn't going to happen.

Quote:
Originally Posted by EowynCarter View Post
Mmm, what ? I don't like the sound of that at all. Valoric seams to have no problem with linux release. So what's the matter ?
The matter is the generic installer package didn't work across a large number of distros. It didn't work properly (required tweaking) with Fedora. A new version of Ubuntu comes out and the previous release (built on the previous version of Ubuntu) suddenly doesn't work properly. I'd rather not lie and say get the Linux build that in the majority of cases won't actually work. Valoric didn't have problem providing one generic Linux binary but I'm not happy with it.

I made changes (as part of 0.6.0) required by Debian, Ubuntu and Fedora, packagers to accommodate them packaging Sigil. The build system was changed to allow the use of system libraries. Intial patches were provided by a user who was interested in seeing it happen. I replaced the GPL zip code (ZipArchive) because in the Debian packaging bug it was stated that it had to be removed because the commenter apparently can't understand that a GPL library can also be dual released under a commercial license.

There are only two outstanding packaging changes. 1) Allow the use of an unmodified Tidy. Not easy due to the changes to Tidy. I've been looking at moving to tidy-html5 as it's supposed to support html5 and is actively maintained. 2) Allow FlightCrew to be installed as a library by Sigil. This won't happen until there is an EPUB 3 release of FC because this requires changes to FC as well as Sigil.

For those interested https://bugs.launchpad.net/debian/+bug/610876 and http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=590180 and https://bugzilla.redhat.com/show_bug.cgi?id=772362 .

I also want to point out that there are Linux packaging patches in those bug reports. I've said that I was interested in helping make it easier for distros to packages Sigil and even said that to a Debian person. That's as far as it got. Not a single patch was was ever sent to me, or made known to me by the distro people. The patches were collated and pushed by a user who was interested. They have been incorporated and as I said I even made more drastic changes to make Sigil more palatable to Linux packagers.

I've been in contact so far with one packager and that conversation ended with me expressing interested in incorporating patches. Those patches were submitted to me 6 moths later by a third party. Other distros, not a single person has contacted me to offer their patches, express concerns or even inform me of what they want/need to see to make it so they can/will package Sigil.

If your distro of choice doesn't feel Sigil is appropriate for them to package then that is a discussion you need to take up with them. If they want to package Sigil then they can do so or contact me so we can work together so they can do so. But I have no interested in A) providing a broken Linux package or B) providing different Linux packages for every release of every distro under the sun.
user_none is offline   Reply With Quote
Old 05-20-2012, 04:48 AM   #13
EowynCarter
Wizard
EowynCarter ought to be getting tired of karma fortunes by now.EowynCarter ought to be getting tired of karma fortunes by now.EowynCarter ought to be getting tired of karma fortunes by now.EowynCarter ought to be getting tired of karma fortunes by now.EowynCarter ought to be getting tired of karma fortunes by now.EowynCarter ought to be getting tired of karma fortunes by now.EowynCarter ought to be getting tired of karma fortunes by now.EowynCarter ought to be getting tired of karma fortunes by now.EowynCarter ought to be getting tired of karma fortunes by now.EowynCarter ought to be getting tired of karma fortunes by now.EowynCarter ought to be getting tired of karma fortunes by now.
 
Posts: 4,133
Karma: 1604192
Join Date: Oct 2008
Location: Paris
Device: Cybooks; Sony PRS-T1
Quote:
Git has no guarantees because it's actively been worked on. The typical process is work on something, get it to build and do minimal testing on OS X. At a later date check if it builds on another platform. Do minimal testing. Repeat. Before a release do more extensive testing across all platform. Something that works with the compiler on OS X might not work with another compiler. Some bugs (like one I'm trying to figure out right now) only happens on Linux but doesn't appear on OS X or Windows. Keeping git perfectly usable and stable across multiple platforms just isn't going to happen.
Yup, i understand that well enough. Just wanted to know if you were aware of that one bug, to avoid some trouble later.
Or if it was just some weirdo occurrence on my computer.
EowynCarter is offline   Reply With Quote
Old 05-20-2012, 07:19 AM   #14
EowynCarter
Wizard
EowynCarter ought to be getting tired of karma fortunes by now.EowynCarter ought to be getting tired of karma fortunes by now.EowynCarter ought to be getting tired of karma fortunes by now.EowynCarter ought to be getting tired of karma fortunes by now.EowynCarter ought to be getting tired of karma fortunes by now.EowynCarter ought to be getting tired of karma fortunes by now.EowynCarter ought to be getting tired of karma fortunes by now.EowynCarter ought to be getting tired of karma fortunes by now.EowynCarter ought to be getting tired of karma fortunes by now.EowynCarter ought to be getting tired of karma fortunes by now.EowynCarter ought to be getting tired of karma fortunes by now.
 
Posts: 4,133
Karma: 1604192
Join Date: Oct 2008
Location: Paris
Device: Cybooks; Sony PRS-T1
Quote:
Originally Posted by EowynCarter View Post
Yup, i understand that well enough. Just wanted to know if you were aware of that one bug, to avoid some trouble later.
Or if it was just some weirdo occurrence on my computer.
Wonderful, one morning spent trying to build sigil, and i will have to do it all over again because virtualbox screwed up... I just hate having to do that kind of things...
EowynCarter is offline   Reply With Quote
Reply

Tags
error message, loading problem, ubuntu

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sigil & Ubuntu Oneiric 11.10 Rand Brittain Sigil 1 10-16-2011 12:18 AM
segmentation fault when using Sigil with Ubuntu Linux lunixer Sigil 1 05-31-2011 03:34 PM
Conversion error in Ubuntu filmprof Conversion 1 02-10-2011 04:33 PM
DateUtil error when running on Ubuntu donnyspi Calibre 0 01-20-2010 12:45 PM
Compiling Sigil 0.1.3 on Ubuntu Intrepid rogue_ronin Sigil 7 10-04-2009 10:35 AM


All times are GMT -4. The time now is 08:12 PM.


MobileRead.com is a privately owned, operated and funded community.