Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Readers > Sony Reader > Sony Reader Dev Corner

Notices

Reply
 
Thread Tools Search this Thread
Old 01-19-2012, 04:21 AM   #1
rubentje1991
Enthusiast
rubentje1991 began at the beginning.
 
Posts: 33
Karma: 10
Join Date: Jan 2012
Device: Sony PRS-T1
undo changes

Hello all;
[ if you want to skip the reading, my question itself is at the ending ]
About a week ago, I rooted and customized my PRS-T1...

I'm satisfied with everything the reader can accomplish (more than I'd have thought is possible)...
=> but for several days now, my reader app is behaving bad; it's OK for normal reading, but when I close it, I get an error (stopped unexpectedly, try again or something like that - and then force close button);
the same happens when I go (in the reader app) to Options >> More >> Settings (or preferences in English, I don't know): same error;

I thought, something wrong with the permissions (had to do a reset a while before that, installed fixPermissions app - but that only does data-apps, no system-apps)...
Then I tried the fix_permissions script, running via the terminal emulator on the device itself (no adb installed)... as response I get: "shift: can't shift that many";
so, opened the script on the pc, saw an option "-f" for only specifying the apk; I tried to find the apk of the built-in reader app, if I'm correct, it's at /system/app/EbookReader.apk (reinstalling of that doesn't work ); so I run: "fix_permissions -f /system/app/EbookReader.apk", but that doesn't help neither (anymore? I think it once worked, but after cold boot, was all over again and running fix_permissions helped nothing)....

Now I'm thinking of getting started "fresh" again (a little more experienced now)...
=> I've seen some "initialization" entry in the settings of the reader; one option to format the memory, and an option to restore the defaults....
I also saw the "factory reset" entry on the wiki (which is very helpful)...

But I don't know what having to do now;
=> I have an extended partition on my microSD, with apps linked to it;

Just format the memory, restore the defaults and a factory reset: is that enough to start fresh, or do I first have to undo the rooting, or copying some image file again? [yes, everything should be formatted, I'm not going to loose the files ]

Thanks in advance!
rubentje1991 is offline   Reply With Quote
Old 01-19-2012, 11:07 AM   #2
rubentje1991
Enthusiast
rubentje1991 began at the beginning.
 
Posts: 33
Karma: 10
Join Date: Jan 2012
Device: Sony PRS-T1
Well, it would be possible to install the adapted EbookReader.apk (as mentioned in the other thread)... but as I see, there are still some little bugs in it....

So, it would be very useful if someone has some advice on this problem - of how to do a full reset with a rooted and adjusted device.....
=> because maybe someone has experience with it, if that's not the case - I'm going to try the factory reset and see what happens then
rubentje1991 is offline   Reply With Quote
Old 01-19-2012, 12:04 PM   #3
rubentje1991
Enthusiast
rubentje1991 began at the beginning.
 
Posts: 33
Karma: 10
Join Date: Jan 2012
Device: Sony PRS-T1
Question

Or other possibility:
someone who can explain me how to reinstall the EbookReader.apk (without using adb)?

But an answer to the previous posts is still preferred (to do a clean start - and I've read the wiki several times => maybe I didn't understand some part?)
rubentje1991 is offline   Reply With Quote
Old 01-20-2012, 04:31 AM   #4
rubentje1991
Enthusiast
rubentje1991 began at the beginning.
 
Posts: 33
Karma: 10
Join Date: Jan 2012
Device: Sony PRS-T1
OK, I'm going to format the memory, and reset to factory settings - and see what happens
rubentje1991 is offline   Reply With Quote
Old 01-20-2012, 04:55 AM   #5
rubentje1991
Enthusiast
rubentje1991 began at the beginning.
 
Posts: 33
Karma: 10
Join Date: Jan 2012
Device: Sony PRS-T1
Cool

I get more and more admiration for the root-method.....

So, I formatted the SD card and the internal reader-memory;
then I did a factory reset, and started playing with the device - but the root was still active (me happy )
Why happy?: my reader app is repaired (no stupid errors anymore), and my other apps are all still available (even my custom installed apps)
=> after 2 cold boots, everything still going smooth!
(only the contacts-app is always gone on each cold boot, installing again takes about 5 seconds - but that's the only thing that maybe can change in the future -- if I find lots of time somewhere, I maybe can build a new Android app myself, but..... that will have to wait))

Complete time used for formatting the memory and doing a factory reset: <5 minutes
(and my Adobe DRM is still active on the device)

Just for your information
rubentje1991 is offline   Reply With Quote
Old 01-20-2012, 04:58 AM   #6
uboot
Evangelist
uboot seems famous, but is in fact legendary.uboot seems famous, but is in fact legendary.uboot seems famous, but is in fact legendary.uboot seems famous, but is in fact legendary.uboot seems famous, but is in fact legendary.uboot seems famous, but is in fact legendary.uboot seems famous, but is in fact legendary.uboot seems famous, but is in fact legendary.uboot seems famous, but is in fact legendary.uboot seems famous, but is in fact legendary.uboot seems famous, but is in fact legendary.
 
Posts: 416
Karma: 75216
Join Date: Nov 2011
Location: old europe
Device: Kobo Mini, Sony PRS T1
maybe your filesystem got corrupted. this can happen when the reader crashes or is reset...
uboot is online now   Reply With Quote
Old 01-20-2012, 11:06 AM   #7
j0534ng31
Connoisseur
j0534ng31 can extract oil from cheesej0534ng31 can extract oil from cheesej0534ng31 can extract oil from cheesej0534ng31 can extract oil from cheesej0534ng31 can extract oil from cheesej0534ng31 can extract oil from cheesej0534ng31 can extract oil from cheesej0534ng31 can extract oil from cheesej0534ng31 can extract oil from cheese
 
Posts: 83
Karma: 1224
Join Date: Dec 2011
Location: Gijon (Spain)
Device: Sony PRS-T1 black
We are going to see this behaviour with increased frequency, I suppose!
j0534ng31 is offline   Reply With Quote
Old 01-21-2012, 03:15 AM   #8
uboot
Evangelist
uboot seems famous, but is in fact legendary.uboot seems famous, but is in fact legendary.uboot seems famous, but is in fact legendary.uboot seems famous, but is in fact legendary.uboot seems famous, but is in fact legendary.uboot seems famous, but is in fact legendary.uboot seems famous, but is in fact legendary.uboot seems famous, but is in fact legendary.uboot seems famous, but is in fact legendary.uboot seems famous, but is in fact legendary.uboot seems famous, but is in fact legendary.
 
Posts: 416
Karma: 75216
Join Date: Nov 2011
Location: old europe
Device: Kobo Mini, Sony PRS T1
But what is it like with other android devices? Do they fsck before mounting? And how about the old embedded Linux based PRS readers?
uboot is online now   Reply With Quote
Old 01-21-2012, 09:35 AM   #9
j0534ng31
Connoisseur
j0534ng31 can extract oil from cheesej0534ng31 can extract oil from cheesej0534ng31 can extract oil from cheesej0534ng31 can extract oil from cheesej0534ng31 can extract oil from cheesej0534ng31 can extract oil from cheesej0534ng31 can extract oil from cheesej0534ng31 can extract oil from cheesej0534ng31 can extract oil from cheese
 
Posts: 83
Karma: 1224
Join Date: Dec 2011
Location: Gijon (Spain)
Device: Sony PRS-T1 black
Quote:
Originally Posted by uboot View Post
But what is it like with other android devices? Do they fsck before mounting? And how about the old embedded Linux based PRS readers?
Have you seen my PM?

About other android... I don't know.

CyanogenMod ROMs checks it at boot... But I haven't had any other PRS before this T1

Anyway, this have to be done... somehow
j0534ng31 is offline   Reply With Quote
Old 01-22-2012, 12:23 PM   #10
rubentje1991
Enthusiast
rubentje1991 began at the beginning.
 
Posts: 33
Karma: 10
Join Date: Jan 2012
Device: Sony PRS-T1
Well, after doing some testing, I think Calibre is the cause (when you use it in the wrong way)....
=> I saw that when you just closed Calibre, without ejecting the device, and then unmounted the device in Linux, it had this behavior. I think it caused some problem in the book.db database file....
Everytime I did it in the "wrong" way, my reader started working "weird" (with that force closing message when closing the reader-app, and when going into the settings of the reader-app => to see e.g. details / more info about the book)

Resetting works (beautifully), and now, when properly ejecting the reader first from Calibre, and then unmounting it in my OS, I don't have any problem at all anymore;
so probably just my fault (not knowing how to use Calibre )
I learned something,
but yes, sometimes the reader should do a fsck (every 50 boots at least or so?) to check the integrity of the filesystem; else it will be giving problems in the future! (or they would have implemented some other way of assuring the integrity of the filesystem - but I doubt about that )
rubentje1991 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sigil undo crutledge Sigil 15 08-16-2011 11:11 AM
Undo function? travger Library Management 7 07-15-2011 09:48 AM
Replace actions undo themselves? Rand Brittain Sigil 19 04-26-2011 06:18 PM
Undo feature Beege Calibre 3 04-25-2009 02:12 PM
How do I undo this mess? Vortex Calibre 2 12-28-2008 04:19 PM


All times are GMT -4. The time now is 11:59 AM.


MobileRead.com is a privately owned, operated and funded community.