Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Readers > Sony Reader > Sony Reader Dev Corner

Notices

Reply
 
Thread Tools Search this Thread
Old 07-20-2014, 10:54 AM   #1
lorenc
Junior Member
lorenc began at the beginning.
 
Posts: 1
Karma: 10
Join Date: Jul 2014
Device: prs-t1
flashed wrong adb-set to T1,and every time connected to PC ,freeze

Hello, Everyone~
I meet a problem on my PRS-T1 Japanese version.

I rooted it with Japanese Minimal Root Package (minimal-root-jp) by borodas,at that time the T1's fireware's version is 1.0.00.10050.
I thought of that the device can't be certified by sony even before get rooted,it may be caused by the firmware is too old?
So I upgraded the FW with eBook Transfer for Reader, to 3.1.00.18240,and then use restore-set-jp,then the wifi became not worked

Then don't ask me why I tried to install the adb-set-jp(for FW 2.0.00.xxxx),and then I found when I connect the T1 to PC, it freezes

I found this thread in mobileread.

Then I read rupor's thread and made a backup image with Roadkil's Disk Image.

Then I tried to use sd-rescue(for western devices?) to save my T1,but after 1h+,the sdcard's light was still bilinking,I pressed reset button and got it restarted...some parts of the system become in English,the two problems--WiFI error,USB connect still didn' be solved.

then I use rupor-rescue to enter recovery mode,and use putty to run disable-adb-jp...for Firmware 2.0.xxxxx,and the freeze don't get any change.

Then I connect the T1 to ubuntu under VMware,and I can see several partitions I couldn't see under WIN.

Then I use boroda's PRST1_update_tools_jp,update_unpack_all.sh to extract the PRS-T1 Updater.package from PRS-T1_Updater_3.1.00.18240.exe,follow this thread's #8,and get /system and /preload 's image,
Then I copy folder 'wifi' from the image to T1's system version,and restart T1,the Wifi get worked again!~

Then I find the /system partition of T1 just has 128M+,and has only 313k space, but the size of 'system 'of .img has 135+M... I can't copy the 'lost' file into it.
I followed the turtorial to repartition PRST1,but then I found my T1 lost some partitions and could't run normally... I think it may be caused by the difference of partition way between western and japanese version?And I don't know how to solve it.And I tried to use partition tools like Minitool and gparted,they can't change the size of system anyway...But I think it may be not a problem for me.

By reading 'do_update.sh' file included in disable-adb-jp-20 ,I found it writes nboote-orig.bin and ramdisk.uimg to /mmcblk2;changes the 'ramdisk&u-boot' from 'readme,adb-set-jp'.
And the two files may be uncompatible with my 3.0.xxxx firmware

And it seems that they can be made by other files included in system?

What can I do to let my T1 not be freezed when be connected to PC?

Any advice is welcome
lorenc is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Kindle touch wrong time mike7 Amazon Kindle 4 03-03-2013 03:25 AM
Touch Wrong time tecweston Barnes & Noble NOOK 2 12-04-2012 10:34 AM
First time with e-reader: what's wrong with conversion? elberto Conversion 1 04-10-2012 09:37 PM
Hacks Kindle 4 SO - How to set the time? Driver_2k Amazon Kindle 0 11-03-2011 11:58 AM
Classic Wrong Time on my Nook evan2000 Barnes & Noble NOOK 2 04-19-2010 01:16 PM


All times are GMT -4. The time now is 11:41 AM.


MobileRead.com is a privately owned, operated and funded community.