Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Readers > Android Devices > enTourage eDGe

Notices

Reply
 
Thread Tools Search this Thread
Old 10-13-2011, 09:42 PM   #1
GlutinFreeMan
Junior Member
GlutinFreeMan began at the beginning.
 
Posts: 8
Karma: 10
Join Date: Oct 2011
Location: Detroit, MI
Device: Entourage Pocket Edge
Help! Updating

I know a lot of people have had trouble getting the Edges to go into update mode, but I haven't seen any quite as bad as mine yet.

I got one of the Pocket Edges on Woot in the most recent sale. I've been lurking in these forums for a while, and have found them very helpful - Thanks!

I played with it for about a week, then updated it to Ermine. That update happened quickly and easily.

I sideloaded a couple applications (DioPen, FBReader, EverNote, etc.), but have not played with root, have not tried to install gapps, have not tried to gain market.

When Allmine was released last week, I decided it was time to update it, so I downloaded the 2nd version (I missed the first one), and put it on the same USB drive I used to update to Ermine. I spent 3-4 hours trying to update it. I'd hold down Menu and Rotate, and it would show 1 dot, reboot, show 2 dots, read the USB drive, reboot, and repeat.
I definitely have the file in the root of the drive, and it's definitely named "update.zip" (according to two separate computers and the Edge itself).

I've been reading other stories about problems updating, and the usual answer seems to be "keep trying". So I have. I've tried 5 different USB drives, ranging in size from 64MB to 16GB, I've tried two different microSD cards, 2GB and 16GB. I've tried just the USB drive, just the SD card, and both. I've re-downloaded the Allmine update 3x. I've tried the Ermine update. I've tried the Dingo update. I can't get the Edge to recognize that there's an update available and go into update mode.

This morning, a co-worker brought his Pocket Edge in (he got one when I got mine). He updated with Allmine in about 5 minutes, then gave me his USB drive to try. I still can't get into update mode. I figure over the last week I've rebooted the Edge some 200-300x trying to get it into update mode. I'll try for about 30 minutes at a time, then quit when I get discouraged or my fingers get tired of holding down Menu and Rotate. It's never varied from the 1 dot, reboot, 2 dots, read USB, reboot and repeat.

The PE works fine otherwise. I can read all of the drives I've tried to update with, and all the functions seem to work normally.

This morning, out of desperation, I tried the Factory Reset (under Settings -> Privacy) it's supposed to remove all the user information, all the user added applications, erase the library, etc.

I hit OK, the PE warned me it would reboot. It shutdown, rebooted, and was exactly the same as before the Factory Reset. I tried it again, with the same result. It does not delete any applications. All the data is still available. My library is the same.

Does Factory Reset work for others, or is this another symptom of the problem I'm having, and maybe a clue as to why I can't get update to start?

Help!

I've been playing with Linux since the early '90s,and have configured systems in Slackware from scratch, so while I'm no guru, I can usually manage to find my way around an OS. This is my first Android machine, so I'm not very familiar with it yet.

I've been reading the thread on the serial port, and it sounds promising. I'd be willing to make a serial cable and pop the Edge open, if it means I can get update to work.

Any suggestions?
GlutinFreeMan is offline   Reply With Quote
Old 10-14-2011, 12:58 AM   #2
nikkie
Guru
nikkie is slicker than a case of WD-40nikkie is slicker than a case of WD-40nikkie is slicker than a case of WD-40nikkie is slicker than a case of WD-40nikkie is slicker than a case of WD-40nikkie is slicker than a case of WD-40nikkie is slicker than a case of WD-40nikkie is slicker than a case of WD-40nikkie is slicker than a case of WD-40nikkie is slicker than a case of WD-40nikkie is slicker than a case of WD-40
 
nikkie's Avatar
 
Posts: 607
Karma: 73700
Join Date: Oct 2009
Location: Redmond, WA
Device: iPhone, iRex DR800SG, Pocket Edge, iPad
If you have the soldering skills, opening up the PE and using the serial cable to debug it, or to instruct it to reflash itself, is very easy. It might be worth it just to see *why* your device is rebooting while you are trying to flash it.

Do you have any other problems with the menu or rotate buttons?
nikkie is offline   Reply With Quote
 
Enthusiast
Old 10-14-2011, 07:21 AM   #3
GlutinFreeMan
Junior Member
GlutinFreeMan began at the beginning.
 
Posts: 8
Karma: 10
Join Date: Oct 2011
Location: Detroit, MI
Device: Entourage Pocket Edge
The buttons work fine normally, and I'm pretty sure the rebooting behavior is correct (except for not starting the update routine). Of course, I don't have another PE to compare it to.

I'm sure I've got parts laying around the house somewhere that will build a serial cable. I'll see if I can put one together this weekend.

Thanks, Nikkie
GlutinFreeMan is offline   Reply With Quote
Old 10-27-2011, 09:19 PM   #4
GlutinFreeMan
Junior Member
GlutinFreeMan began at the beginning.
 
Posts: 8
Karma: 10
Join Date: Oct 2011
Location: Detroit, MI
Device: Entourage Pocket Edge
OK - I finally got around to building a serial cable, connecting it, and trying to "run boot_user" to see if I can get it to update.

No update yet, but I did get a clue...
(from the terminal log)

[ 5.465639] sd 0:0:0:0: [sda] Assuming drive cache: write through
[ 5.473855] mmc1: new high speed SDIO card at address 0001
[ 5.479408] sd 0:0:0:0: [sda] Attached SCSI removable disk
[ 15.516036] RAMDISK: gzip image found at block 0
[ 16.084036] uncompression error
[ 16.217311] EXT2-fs (ram0): warning: checktime reached, running e2fsck is recommended
[ 16.225200] VFS: Mounted root (ext2 filesystem) on device 1:0.
[ 16.231271] Freeing init memory: 896K
[ 16.235032] EXT2-fs (ram0): error: ext2_lookup: deleted inode referenced: 4136
[ 16.242354] EXT2-fs (ram0): error: ext2_lookup: deleted inode referenced: 4098
[ 16.249907] EXT2-fs (ram0): error: ext2_lookup: deleted inode referenced: 4218
[ 16.257198] EXT2-fs (ram0): error: ext2_lookup: deleted inode referenced: 4218
[ 16.264436] Kernel panic - not syncing: No init found. Try passing init= option to kernel. See Linux Documentation/init.txt for guidance.
[ 16.276923] Rebooting in 1 seconds..

OK - I read that as an inability to boot to the image on the RAM disk, which would explain why it can't perform an update.

I would guess that I need to try to recover the missing or corrupted image...

Any suggestions on how that might be possible?
GlutinFreeMan is offline   Reply With Quote
Old 10-27-2011, 11:03 PM   #5
GlutinFreeMan
Junior Member
GlutinFreeMan began at the beginning.
 
Posts: 8
Karma: 10
Join Date: Oct 2011
Location: Detroit, MI
Device: Entourage Pocket Edge
Still trying...

Thought I'd start with the obvious, so I tried "run boot_maint", but that also appears to rely on the RAM image and wouldn't boot (same error as boot_user).

I tried "run boot_maintsd", which looks for an image (I assume) on the microSD card. I didn't have one inserted, so needed to hit the reset button to get out of that mode. That may be a good method to investigate if I can find out what the bootable image should look like.

Next, I tried "mtest" which is described in the monitor help file as "simple RAM test".
I got the following:
Code:
EdgeJr>> mtest
Pattern 00000000  Writing...  Reading...
Mem error @ 0x00CEF81C: found 0000000A, expected 002FBE07

Mem error @ 0x00CEF820: found 00000000, expected 002FBE08

Mem error @ 0x00CEF824: found 00F15DFC, expected 002FBE09

Mem error @ 0x00CEF828: found 00F2BDE6, expected 002FBE0A

Mem error @ 0x00CEF82C: found 00CEF828, expected 002FBE0B

Mem error @ 0x00CEF830: found 00CEF828, expected 002FBE0C

Mem error @ 0x00CEF834: found 002FBE0C, expected 002FBE0D
Pattern FFFFFFFF  Writing...
It never came back after that (I gave it about 15 minutes).
GlutinFreeMan is offline   Reply With Quote
Old 10-27-2011, 11:44 PM   #6
nikkie
Guru
nikkie is slicker than a case of WD-40nikkie is slicker than a case of WD-40nikkie is slicker than a case of WD-40nikkie is slicker than a case of WD-40nikkie is slicker than a case of WD-40nikkie is slicker than a case of WD-40nikkie is slicker than a case of WD-40nikkie is slicker than a case of WD-40nikkie is slicker than a case of WD-40nikkie is slicker than a case of WD-40nikkie is slicker than a case of WD-40
 
nikkie's Avatar
 
Posts: 607
Karma: 73700
Join Date: Oct 2009
Location: Redmond, WA
Device: iPhone, iRex DR800SG, Pocket Edge, iPad
Hi Glutin.

Looks like your maintenance kernel is fried. You are now in the same position as Vicinc and perldude69. You should come and hang out in the thread we've got going for that. Perldude has apparently managed to tftpboot his device, which is a good start.
nikkie is offline   Reply With Quote
Old 10-29-2011, 10:17 PM   #7
vicinc
Guru
vicinc has a complete set of Star Wars action figures.vicinc has a complete set of Star Wars action figures.vicinc has a complete set of Star Wars action figures.vicinc has a complete set of Star Wars action figures.vicinc has a complete set of Star Wars action figures.
 
Posts: 733
Karma: 443
Join Date: May 2011
Location: UK
Device: Pocket Edgex2(1unborked), Alex, Nook B&W, Nook Color, Nook STR
yeap got the same on memtest
Pattern 00000000 Writing... [08][08][08][08][08][08][08][08][08][08]Reading...
Mem error @ 0x00CEF81C: found 0000000A, expected 002FBE07

Mem error @ 0x00CEF820: found 00000000, expected 002FBE08

Mem error @ 0x00CEF824: found 00F15DFC, expected 002FBE09

Mem error @ 0x00CEF828: found 00F2BDE6, expected 002FBE0A

Mem error @ 0x00CEF82C: found 00CEF828, expected 002FBE0B

Mem error @ 0x00CEF830: found 00CEF828, expected 002FBE0C

Mem error @ 0x00CEF834: found 002FBE0C, expected 002FBE0D

Pattern FFFFFFFF Writing... [08][08][08][08][08][08][08][08][08][08]
vicinc is offline   Reply With Quote
Old 10-29-2011, 10:18 PM   #8
vicinc
Guru
vicinc has a complete set of Star Wars action figures.vicinc has a complete set of Star Wars action figures.vicinc has a complete set of Star Wars action figures.vicinc has a complete set of Star Wars action figures.vicinc has a complete set of Star Wars action figures.
 
Posts: 733
Karma: 443
Join Date: May 2011
Location: UK
Device: Pocket Edgex2(1unborked), Alex, Nook B&W, Nook Color, Nook STR
so am I suppose we have to tftpboot my device?
vicinc is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help updating to PE bfewell enTourage eDGe 1 09-20-2011 02:56 AM
UPDATING Calibre ginette Calibre 5 09-05-2010 02:54 PM
Updating...... cancelx Astak EZReader 4 03-26-2010 11:38 PM
Updating to 0.33g Teyrnon Ectaco jetBook 23 09-16-2009 07:43 AM
Firmware Update Updating rubikscube99 Amazon Kindle 8 04-18-2009 01:24 PM


All times are GMT -4. The time now is 10:05 AM.


MobileRead.com is a privately owned, operated and funded community.