Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Sigil

Notices

Reply
 
Thread Tools Search this Thread
Old 08-01-2011, 11:07 PM   #1
dicknskip
Zealot
dicknskip began at the beginning.
 
Posts: 110
Karma: 10
Join Date: Nov 2009
Location: Okotoks, AB, Canada
Device: iPad V-3
KDE 4.7

Is anyone having trouble with Sigil, KDE 4.7 and Kubuntu? I can't get Sigil to do a save-as epub from an html file. Thanks
dicknskip is offline   Reply With Quote
Old 08-02-2011, 05:34 AM   #2
Ahmad Samir
Zealot
Ahmad Samir , Klaatu Barada Niktu!Ahmad Samir , Klaatu Barada Niktu!Ahmad Samir , Klaatu Barada Niktu!Ahmad Samir , Klaatu Barada Niktu!Ahmad Samir , Klaatu Barada Niktu!Ahmad Samir , Klaatu Barada Niktu!Ahmad Samir , Klaatu Barada Niktu!Ahmad Samir , Klaatu Barada Niktu!Ahmad Samir , Klaatu Barada Niktu!Ahmad Samir , Klaatu Barada Niktu!Ahmad Samir , Klaatu Barada Niktu!
 
Posts: 114
Karma: 5246
Join Date: Jul 2010
Device: none
You didn't give enough details, what happens when you try to save the file?
Ahmad Samir is offline   Reply With Quote
Old 08-02-2011, 08:55 AM   #3
dicknskip
Zealot
dicknskip began at the beginning.
 
Posts: 110
Karma: 10
Join Date: Nov 2009
Location: Okotoks, AB, Canada
Device: iPad V-3
It's an html file that was edited in LibreOffice for a spell check. It opens fine in Sigil and I can even add a .css file. When I press the save as button I get a dialogue that Sigil has encountered an error. It offers the opportunity to close the window, view details, or go to a bug reporting function. I have seen this error dialogue before. However, in this case the dialogue is not responsive. The only way out of Sigil is to press the X button and wait for the window to time out as non-responsive. This is the latest version of Sigil, 0.3.4 running on Kubuntu 11.04/KDE 4.7. I have done this before and it worked fine. I was wondering if it is a problem with the new QT in KDE?
dicknskip is offline   Reply With Quote
Old 08-02-2011, 09:33 AM   #4
Ahmad Samir
Zealot
Ahmad Samir , Klaatu Barada Niktu!Ahmad Samir , Klaatu Barada Niktu!Ahmad Samir , Klaatu Barada Niktu!Ahmad Samir , Klaatu Barada Niktu!Ahmad Samir , Klaatu Barada Niktu!Ahmad Samir , Klaatu Barada Niktu!Ahmad Samir , Klaatu Barada Niktu!Ahmad Samir , Klaatu Barada Niktu!Ahmad Samir , Klaatu Barada Niktu!Ahmad Samir , Klaatu Barada Niktu!Ahmad Samir , Klaatu Barada Niktu!
 
Posts: 114
Karma: 5246
Join Date: Jul 2010
Device: none
Assuming you installed Sigil using the .run file; a shot in the dark, start Sigil from terminal like this:
Code:
QT_PLUGIN_PATH=  /path-to-sigil.sh
(replace /path-to-sigil.sh with the actual patch).
Ahmad Samir is offline   Reply With Quote
Old 08-02-2011, 10:15 AM   #5
dicknskip
Zealot
dicknskip began at the beginning.
 
Posts: 110
Karma: 10
Join Date: Nov 2009
Location: Okotoks, AB, Canada
Device: iPad V-3
QT_PLUGIN_PATH= /opt/sigil/sigil.sh
Debug: KGlobal::locale::Warning your global KLocale is being recreated with a valid main component instead of a fake component, this usually means you tried to call i18n related functions before your main component was created. You should not do that since it most likely will not work
Killed

I did as suggested and got the following in the terminal window. Would the KLocale cause an issue? I wouldn't think so. The Killed is from closing Sigil at the window not responding dialog box. I'll play around a little more and see if I can clear this up.
dicknskip is offline   Reply With Quote
Old 08-02-2011, 10:30 AM   #6
Ahmad Samir
Zealot
Ahmad Samir , Klaatu Barada Niktu!Ahmad Samir , Klaatu Barada Niktu!Ahmad Samir , Klaatu Barada Niktu!Ahmad Samir , Klaatu Barada Niktu!Ahmad Samir , Klaatu Barada Niktu!Ahmad Samir , Klaatu Barada Niktu!Ahmad Samir , Klaatu Barada Niktu!Ahmad Samir , Klaatu Barada Niktu!Ahmad Samir , Klaatu Barada Niktu!Ahmad Samir , Klaatu Barada Niktu!Ahmad Samir , Klaatu Barada Niktu!
 
Posts: 114
Karma: 5246
Join Date: Jul 2010
Device: none
No, the KLocale issue is there anyway, it shouldn't hamper usage like you describe... I don't have an Ubuntu installation to test.

Does the same issue happen with other files?
Ahmad Samir is offline   Reply With Quote
Old 08-02-2011, 10:32 AM   #7
dicknskip
Zealot
dicknskip began at the beginning.
 
Posts: 110
Karma: 10
Join Date: Nov 2009
Location: Okotoks, AB, Canada
Device: iPad V-3
That's what I'm playing with right now. It will take a few hours to try other files. I'll let you know what I find out. Thanks for the help so far. This is an awesome tool.
dicknskip is offline   Reply With Quote
Old 08-02-2011, 11:47 AM   #8
dicknskip
Zealot
dicknskip began at the beginning.
 
Posts: 110
Karma: 10
Join Date: Nov 2009
Location: Okotoks, AB, Canada
Device: iPad V-3
OK - I've tried three different files now and have the same issue. It would appear that the "Sigil has encountered a problem" dialogue is no longer responsive in KDE 4.7. I did have occasional issues with this dialogue before, it would pop up every time I tried to do a "save as", but I just needed to click the "close" button and it would disappear. The "close" button is no longer responsive. The dialogue just times out as unresponsive. I can't access the "details" to give any more information.

Maybe this is an issue layered on another issue? It was just an inconvenience before so I didn't say anything waiting to see if a new release would come along and fix it.

There have been several up-dates to the QT libraries and that may be the issue. Can I do anything else to help with this?
dicknskip is offline   Reply With Quote
Old 08-02-2011, 12:31 PM   #9
user_none
Sigil & calibre developer
user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.
 
user_none's Avatar
 
Posts: 2,460
Karma: 986493
Join Date: Jan 2009
Location: Florida, USA
Device: Nook STR
Try 0.4 RC1 and see if the issue is present in that version.
user_none is offline   Reply With Quote
Old 08-02-2011, 02:16 PM   #10
dicknskip
Zealot
dicknskip began at the beginning.
 
Posts: 110
Karma: 10
Join Date: Nov 2009
Location: Okotoks, AB, Canada
Device: iPad V-3
I did an uninstall on the 0.3.7 version and installed 0.4.0 RC1 from the Sigil site, the Linux 64 bit installer version. I have Qt 4.7.2 running. I have the same issue with the "save as". I did try a save on the .html and I got the warning message that I couldn't save an html file in Sigil. That dialogue was active and responsive. I opened the same .html files in Firefox and in Quanta plus without any issues. In Quanta I did a change and save as well. It appears that it's an issue with that dialog, 2 buttons and the big red X, in Qt 4.7.x. I'm willing try other tests if it can help.

EDIT: I just did another test that I think confirms the Qt issue with that dialogue box. I opened an ePub file that I know works and tried a "save as" just to save a copy. The same error message popped up and it was unresponsive.

Last edited by dicknskip; 08-02-2011 at 02:21 PM.
dicknskip is offline   Reply With Quote
Old 08-30-2011, 11:37 PM   #11
st_albert
Fanatic
st_albert calls his or her ebook reader Vera.st_albert calls his or her ebook reader Vera.st_albert calls his or her ebook reader Vera.st_albert calls his or her ebook reader Vera.st_albert calls his or her ebook reader Vera.st_albert calls his or her ebook reader Vera.st_albert calls his or her ebook reader Vera.st_albert calls his or her ebook reader Vera.st_albert calls his or her ebook reader Vera.st_albert calls his or her ebook reader Vera.st_albert calls his or her ebook reader Vera.
 
Posts: 544
Karma: 64420
Join Date: Feb 2010
Device: none
I have been playing with this also, on a virtual machine install of Kubuntu 11.10 with KDE 4.7 and QT 4.7.3 and Sigil 0.4.1 (both the release and one compiled on the Kubuntu system from source); and for comparison on a Debian Sid machine with KDE 4.6.5, QT 4.7.3 and Sigil 0.4.1 Release.

On the Kubuntu (KDE 4.7) I can reproduce the problem with either the release 0.4.1, which comes bundled with QT 4.7.2) and on the fresh-built 0.4.1 (which has QT 4.7.3). It happens no matter whether the QT_PLUGIN_PATH is set or unset.

On the Debian system (KDE 4.6.5) if I run the 0.4.1 Release version via the sigil.sh script (which puts Sigil's directory ahead of the rest of the LD_LIBRARY_PATH and unsets QT_PLUGIN_PATH), Sigil reports QT version 4.7.2 in help | about. There is no problem, and no error with 'save as'.

Moreover, if I run the sigil binary from a terminal without any sigil.sh (so both LD_LIBRARY_PATH and QT_PLUGIN_PATH are unmodified) I get lots of warnings, but no problem with 'save as' -- unless, in the save-file dialog, the "automatically select filename extension ).epub)" box is checked. In this case sigil reports QT4.7.3.

ETA: if the box IS checked, the dreaded error window pops up, but it is active. FWIW, the error shown is

Code:
Error info: Critical: kfilemodule(1649): couldn't create slave: "Unable to create io-slave:
klauncher said: Unknown protocol ''.
" 
Sigil version: 0.4.1
Runtime Qt: 4.7.3
Compiled Qt: 4.7.2
Platform: Linux
That is basically the same error that happens with Sigil 0.3.4 and QT 4.7.0 on the Debian machine. And again, if you run any of these with QT_PLUGIN_PATH unset, you don't get the KDE-style file-save window, there's no "automatically select..." box to uncheck, and you don't get the error at all.

Finally, the installer built on the Kubuntu machine using QT4.7.3, when installed on the Debian machine with KDE 4.6.5 also works without error (starting with the shell script, but now the bundled QT libs are 4.7.3).

ETA2: Note that I'm not sure the error that happens on the Kubuntu KDE 4.7 system is the same error as quoted above. Unlike the KDE 4.6.5 case, it seems to happen as soon as you press the save-as button, before the file-save dialog opens. Since the dialog freezes, you can't "show details." However, if you start sigil.sh from a shell, the following appears on the console when the error happens:

Code:
Debug: kfilemodule(2024)/kio (KDirModel) KDirModelPrivate::_k_slotDeleteItems: No node found for item that was just removed: KUrl("file:///vmlinuz")
So my guess is that the problem is with KDE 4.7 rather than QT 4.7.3

Last edited by st_albert; 08-31-2011 at 12:09 AM.
st_albert is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
sigil 0.3.3 and KDE 4.5.5 dicknskip Sigil 5 01-14-2011 01:53 PM
calibre on opensuse 11.3 with KDE 4.5.2 michaelbn Calibre 2 10-19-2010 02:03 PM


All times are GMT -4. The time now is 08:18 AM.


MobileRead.com is a privately owned, operated and funded community.