Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Readers > Sony Reader

Notices

Reply
 
Thread Tools Search this Thread
Old 10-12-2007, 03:39 AM   #1
jlc
Enthusiast
jlc began at the beginning.
 
Posts: 27
Karma: 10
Join Date: Jun 2007
Device: PRS-650
Charging light not working

The red light above the power button on my reader no longer comes on when I plug in the AC adapter or USB cable. However, the lightning symbol shows up and the battery does appear to be charging (judging from an increase in bars after plugging it in for a few hours). I initially thought the wire/lead connecting the LED must be disconnected or severed. But this guess was ruled out when I did a soft reset and saw the usual flashing yellow lights during startup.

To give a bit of background on my reader, I recently sent it in to Sony for a screen problem. They supposedly replaced the screen and updated the firmware. This was the first time I charged the reader since I got it back from them. Any suggestions/ideas?
jlc is offline   Reply With Quote
Old 10-12-2007, 04:33 AM   #2
Nogg
Literate!
Nogg knows what time it isNogg knows what time it isNogg knows what time it isNogg knows what time it isNogg knows what time it isNogg knows what time it isNogg knows what time it isNogg knows what time it isNogg knows what time it isNogg knows what time it isNogg knows what time it is
 
Posts: 256
Karma: 2247
Join Date: Mar 2007
Device: PRS-500
It may still be a bad connection to the red LED. Typically devices that have a single spot showing multiple colors of light, there's a plastic fiber-optic-like part that routes the appropriate LED's light to the hole. I haven't cracked mine open to verify this, but that'd be my first guess.
Nogg is offline   Reply With Quote
Old 10-12-2007, 05:14 AM   #3
jlc
Enthusiast
jlc began at the beginning.
 
Posts: 27
Karma: 10
Join Date: Jun 2007
Device: PRS-650
I found some internal pictures here: http://wiki.mobileread.com/wiki/Sony_Reader_Inside

The images show a plastic piece routing light but it's unclear as to how many LED's are under it. I was under the impression that only one LED exists and different voltage levels correspond to different colors.
jlc is offline   Reply With Quote
Old 10-23-2007, 04:08 PM   #4
jlc
Enthusiast
jlc began at the beginning.
 
Posts: 27
Karma: 10
Join Date: Jun 2007
Device: PRS-650
Update: Sony acknowledged that they were at fault and even sent me a pre-paid shipping label after a bit of coaxing. They ended up replacing the motherboard and updating the firmware. However, upon getting my reader back, a new set of problems have surfaced. Details here, http://www.mobileread.com/forums/showthread.php?t=15374
jlc is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
The red charging light artificial Kobo Reader 28 07-12-2011 02:42 PM
v3ext only working when charging grega_g OpenInkpot 0 03-29-2010 09:29 AM
Classic Nook light - pic of light in a case??? DD1509 Barnes & Noble NOOK 9 01-23-2010 11:20 PM
Red charging light, but not charging. SaRaH25 Sony Reader 5 01-01-2010 03:20 PM
New prs 600 cover with light vs Mighty Bright light topreader1 Sony Reader 3 11-22-2009 09:02 AM


All times are GMT -4. The time now is 08:24 AM.


MobileRead.com is a privately owned, operated and funded community.