Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Readers > Amazon Kindle > Kindle Developer's Corner

Notices

Reply
 
Thread Tools Search this Thread
Old 08-11-2011, 03:14 AM   #1
MacUsers
Member
MacUsers began at the beginning.
 
Posts: 17
Karma: 10
Join Date: Jul 2011
Device: Kindle 3
K3 ssh/telnet acess over WiFi

Dear all,

I can't get ssh/telnet access to Kindle 3 over WiFi - I'm trying to figure out the reason since last few hrs. but no joy so far. I can do ssh/telnet over USB though, but only if I set the IP address of RNDIS/Ethernet device as: 192.168.2.1 and access the Kindle using 192.168.2.2 - it doesn't work at all for any other IP address over USB.

Is it always the case that the IP must be 192.168.2.2 to get the shell access?

For the WiFi access, I followed this tutorial (I'm on Mac and Linux though):
http://www.mobileread.com/forums/sho...85#post1181285
but I can't even ping the Kindle when it's connected via WiFi. Dose any one know what am I missing? Or does anyone see the similar thing? Any help/suggestion(s) would be greatly appreciated. Cheers!!
MacUsers is offline   Reply With Quote
Old 08-12-2011, 09:22 AM   #2
khmann
Enthusiast
khmann once ate a cherry pie in a record 7 seconds.khmann once ate a cherry pie in a record 7 seconds.khmann once ate a cherry pie in a record 7 seconds.khmann once ate a cherry pie in a record 7 seconds.khmann once ate a cherry pie in a record 7 seconds.khmann once ate a cherry pie in a record 7 seconds.khmann once ate a cherry pie in a record 7 seconds.khmann once ate a cherry pie in a record 7 seconds.khmann once ate a cherry pie in a record 7 seconds.khmann once ate a cherry pie in a record 7 seconds.khmann once ate a cherry pie in a record 7 seconds.
 
Posts: 43
Karma: 1658
Join Date: Jul 2011
Device: b006
I think the firewall blocks it by default, iptables -P INPUT ACCEPT; iptables -F INPUT, or just remove the firewall script in /etc/init.d and reboot... or do it "properly", creating a rule for TCP port 22 SYN... but I didn't bother. Also you do have to edit the dropbear config. to allow it to listen on WiFi interface.
khmann is offline   Reply With Quote
 
Enthusiast
Old 08-13-2011, 02:33 AM   #3
kranu
I <3 my Kindle
kranu can understand the language of future parallel dimensionskranu can understand the language of future parallel dimensionskranu can understand the language of future parallel dimensionskranu can understand the language of future parallel dimensionskranu can understand the language of future parallel dimensionskranu can understand the language of future parallel dimensionskranu can understand the language of future parallel dimensionskranu can understand the language of future parallel dimensionskranu can understand the language of future parallel dimensionskranu can understand the language of future parallel dimensionskranu can understand the language of future parallel dimensions
 
Posts: 528
Karma: 51332
Join Date: Nov 2010
Location: United States
Device: Kindle 3G + WiFi
For USB, you can change the IP Address from the config file. When you use WiFi, the IP Address is usually assigned by the router. (Unless you used the advanced option when connecting to the WiFi network) Check the Kindle settings page for the IP Address, and use that IP Address instead.

Last edited by kranu; 08-13-2011 at 02:36 AM.
kranu is offline   Reply With Quote
Old 08-13-2011, 04:47 AM   #4
MacUsers
Member
MacUsers began at the beginning.
 
Posts: 17
Karma: 10
Join Date: Jul 2011
Device: Kindle 3
Hi khmann, is there any firewall script(s) in the .etc/init.d at all - hopefully I didn't miss it? I see the usual '/etc/sysconfig/iptables' one though. I've already made the necessary changes in the '/mnt/us/usbnet/etc/config' file. Cheers!!

Last edited by MacUsers; 08-13-2011 at 04:53 AM.
MacUsers is offline   Reply With Quote
Old 08-13-2011, 05:01 AM   #5
MacUsers
Member
MacUsers began at the beginning.
 
Posts: 17
Karma: 10
Join Date: Jul 2011
Device: Kindle 3
Quote:
Originally Posted by kranu View Post
For USB, you can change the IP Address from the config file. When you use WiFi, ......
In my case, I see it's different for me. I'm on Mac, if that makes any difference, I doubt though. So far, it only works for 192.168.2.1/2 over USB.

For WiFi, I'm getting the correct IP address (10.0.11.x) from the router but, as a starting point, I can't even ping it, that's the problem. It could be a firewall issue, as commented by khmann. The only catch is: I'm appeared to be the only one seeing it. Cheers!!
MacUsers is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't SSH or Telnet to Kindle 3 eshiku Kindle Developer's Corner 13 07-28-2011 07:23 PM
Troubleshooting Can't acess menu from settings... cam1john Amazon Kindle 2 06-07-2011 02:00 AM
Using Telnet on Kindle 3 DaGin WinterBorn Kindle Developer's Corner 0 05-22-2011 10:47 PM
Ssh/telnet access over 3G? lolcat Kindle Developer's Corner 12 02-21-2011 11:56 AM


All times are GMT -4. The time now is 12:45 PM.


MobileRead.com is a privately owned, operated and funded community.