Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre

Notices

Reply
 
Thread Tools Search this Thread
Old 08-05-2011, 03:53 AM   #1
Mean500
Junior Member
Mean500 began at the beginning.
 
Posts: 2
Karma: 10
Join Date: Aug 2011
Device: PRS 500
Trying to install version 0.6.29 in Mint 11 - HELP

I'm trying to install Calibre version 0.6.29 in Mint 11. I know it's a ancient version but it works good enough for me and is the last version that supports my Sony PRS 500.

I have version 0.6.29 up and running on a laptop running Mint 10. I'm sure all I did was install Calibre using the Binary install and then Downloaded the "calibre-0.6.29-x86_64.tar.bz2" deleted everything in opt/calibre and extracted the 0.6.29 files in there and it worked.

I have tried doing the same in Mint 11 but get the following errors


Traceback (most recent call last):
File "/tmp/init.py", line 46, in <module>
File "/home/kovid/build/calibre/src/calibre/gui2/__init__.py", line 15, in <module>
File "/home/kovid/build/calibre/src/calibre/ebooks/metadata/meta.py", line 9, in <module>
File "/home/kovid/build/calibre/src/calibre/ebooks/metadata/opf2.py", line 14, in <module>
File "ExtensionLoader_lxml_etree.py", line 12, in <module>
ImportError: /opt/calibre/libxml2.so.2: undefined symbol: inflateEnd


I even tried replacing the files in /opt with the ones of the laptop but that just comes up with permission denied error when I try and run Calibre.

Has something changed in in Mint 11 or is version 0.6.29 just dead in the water now.

I tried doing a Source install from "calibre-0.6.29.tar.gz" but that came up with a truck load of errors. So is there an easy way to install version 0.6.29 or is there no hope lol

Any help greatly appreciated
Mean500 is offline   Reply With Quote
Old 08-05-2011, 04:33 AM   #2
hairybiker
Connoisseur
hairybiker began at the beginning.
 
hairybiker's Avatar
 
Posts: 72
Karma: 10
Join Date: Aug 2009
Device: Kindle DX-4
It maybe that it needs an older version of Python that installed in Mint 11.
My Mint 11 has 2.7 so maybe backing that down to 2.x may help.
hairybiker is offline   Reply With Quote
Old 08-06-2011, 04:53 AM   #3
Mean500
Junior Member
Mean500 began at the beginning.
 
Posts: 2
Karma: 10
Join Date: Aug 2011
Device: PRS 500
Well I tried installing python 2.6 which is the same version in Mint 10 but still get the same errors.

I have got 0.6.29 working on another laptop running Fedora, so they must have messed up something in Mint lol

Thanks for the help anyway,
Mean500 is offline   Reply With Quote
Old 08-06-2011, 05:59 AM   #4
hairybiker
Connoisseur
hairybiker began at the beginning.
 
hairybiker's Avatar
 
Posts: 72
Karma: 10
Join Date: Aug 2009
Device: Kindle DX-4
Did you try running the binary installer for 0.6.29 or just extracting the tar?
Does the installer give any errors?
hairybiker is offline   Reply With Quote
Old 08-07-2011, 03:01 PM   #5
lamparty
Member
lamparty began at the beginning.
 
lamparty's Avatar
 
Posts: 24
Karma: 10
Join Date: Aug 2009
Device: Sony Reader PRS-505
Correct me if I am wrong, but I thought that the PRS500 was included in the "all other Sony Devices"?
Calibre doesn't usually drop support for devices once they are included, even though they may no longer be specifically mentioned! Softpedia download specifically mentions the PRS500 as supported by Calibre 0.8.13! So instead of messing with the outdated ones dependencies, try the latest binary install which will install with no trouble!

Last edited by lamparty; 08-07-2011 at 03:08 PM.
lamparty is offline   Reply With Quote
Old 08-07-2011, 03:51 PM   #6
user_none
Sigil & calibre developer
user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.user_none ought to be getting tired of karma fortunes by now.
 
user_none's Avatar
 
Posts: 2,460
Karma: 986493
Join Date: Jan 2009
Location: Florida, USA
Device: Nook STR
Support for the PRS 500 with the original firmware was dropped. Only the 500 with the EPUB upgrade (must send device to Sony) is supported.
user_none is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Book Designer Files and how to install — 2007-07-30 version (NEW) JSWolf Workshop 240 07-26-2013 11:40 AM
Calibre in Linux mint Cy1clown Calibre 6 05-18-2011 02:16 PM
How to install prior version of Calibre when newer version installed? SilentSeven Calibre 3 04-13-2011 12:46 PM
PRS-900 Sony Digital Edition Library Install, and Install, ... Hamlet53 Sony Reader 3 04-05-2010 03:29 PM
Can't install Calibre, lacking SysAdmin priviliges, older version instead? ZenEngineer Calibre 3 12-17-2009 12:57 AM


All times are GMT -4. The time now is 12:46 AM.


MobileRead.com is a privately owned, operated and funded community.